USB Audio Player PRO (UAPP): 24- and 32-bit playback, ubiquitous USB audio support for Android
Sep 3, 2022 at 11:38 AM Post #5,566 of 6,145
Anyone know of a fix for the stuttering issue when playing bit perfect tidal MQA through UAPP? This is happening on my Sony WM1AM2. Works fine on my phone. And non MQA files play perfectly fine.
Are you also using Bluetooth when streaming? I find that there are times that when I'm streaming MQA over Tidal (using either Shanling M6 Pro 21 with 16X hardware decoding or even a current Android 11 Lenovo tablet which uses the software unfold of UAPP) I will get stuttering and stalling of the stream. When I go back to wired phones, no problem on either. If Bluetooth, check the CODEC-- if LDAC, try a lower bandwidth such as aptx or SBC.

I also experience this sometimes when using the Tidal Android app in either of the above usage scenarios. Something about the higher data load of the MQA stream coming from the wireless router to the device and then adding the Bluetooth stream from device to headphones creating a data traffic jam. Anyway, it may apply to you or it may not, but the overhead of the MQA stream is the culprit somehow or another in my experience. Your phone may have a better/faster WiFi and BT hardware interplay so it doesn't have the problem.
 
Sep 3, 2022 at 12:18 PM Post #5,567 of 6,145
Are you also using Bluetooth when streaming? I find that there are times that when I'm streaming MQA over Tidal (using either Shanling M6 Pro 21 with 16X hardware decoding or even a current Android 11 Lenovo tablet which uses the software unfold of UAPP) I will get stuttering and stalling of the stream. When I go back to wired phones, no problem on either. If Bluetooth, check the CODEC-- if LDAC, try a lower bandwidth such as aptx or SBC.

I also experience this sometimes when using the Tidal Android app in either of the above usage scenarios. Something about the higher data load of the MQA stream coming from the wireless router to the device and then adding the Bluetooth stream from device to headphones creating a data traffic jam. Anyway, it may apply to you or it may not, but the overhead of the MQA stream is the culprit somehow or another in my experience. Your phone may have a better/faster WiFi and BT hardware interplay so it doesn't have the problem.
Nope, Bluetooth is disabled.
 
Sep 7, 2022 at 12:18 PM Post #5,569 of 6,145
I saw someone else post about this a long time ago, but I don't think there was a resolution to the issue...so here goes:

I have a FiiO M11 - and a library of approximately 40K songs. Browsing the list of Album Artists is very smooth, but when it comes to choosing an album, the load time to actually display the track list of the album can be about 30 seconds. It makes the app pretty unusable, unfortunately.

Is this a common issue for people with large file libraries?

Thanks!
 
Sep 7, 2022 at 12:22 PM Post #5,570 of 6,145
Sorry for the question. Have you updated your app to the latest? Thought this was resolved ages ago. Or it was for another issue (network related).
 
Sep 7, 2022 at 2:01 PM Post #5,572 of 6,145
Sep 7, 2022 at 7:51 PM Post #5,573 of 6,145
I use UAPP with a FiiO M11 Plus (ESS). I've noticed that DsD plays back at 384Khz instead of the "native" 5.6 MHz or 11.2 Mhz.

In the FiiO Music app DsD plays back at 5.6 and 11.2 Mhz. Is there a way to do the same in UAPP or does it convert everything to PCM?
 
Sep 8, 2022 at 2:59 AM Post #5,574 of 6,145
I use UAPP with a FiiO M11 Plus (ESS). I've noticed that DsD plays back at 384Khz instead of the "native" 5.6 MHz or 11.2 Mhz.

In the FiiO Music app DsD plays back at 5.6 and 11.2 Mhz. Is there a way to do the same in UAPP or does it convert everything to PCM?
I don't have my UAPP accessible to check the exact setting but I believe DSD playback settings are configurable in UAPP, and with my HibyRS6 it plays DSD natively and displays it as such.
 
Sep 8, 2022 at 1:00 PM Post #5,575 of 6,145
I don't have my UAPP accessible to check the exact setting but I believe DSD playback settings are configurable in UAPP, and with my HibyRS6 it plays DSD natively and displays it as such.
I think I've tried every setting to no avail.
 
Sep 8, 2022 at 2:51 PM Post #5,578 of 6,145
Have You setted in the Settings->USB audio->DSD mode to Native DSD?
Yep. UAPP says "Direct: 352.8kHz DSF: DSD 5.6MHz 1bit". I am not using the USB out, just the built in DAC on the M11 Plus.

Fiio M11 Plus also reports sample rate as 352.8kHz.
 
Sep 8, 2022 at 3:10 PM Post #5,579 of 6,145
Yep. UAPP says "Direct: 352.8kHz DSF: DSD 5.6MHz 1bit". I am not using the USB out, just the built in DAC on the M11 Plus.

Fiio M11 Plus also reports sample rate as 352.8kHz.

Same here. My guess is that @Davy Wentzler hasn't added DSD support for the M11 Plus (ESS).
 
Sep 8, 2022 at 3:22 PM Post #5,580 of 6,145
Try also playing the various flags on the Settings > Internal HiRes Audio > HiRes driver flags
 

Users who are viewing this thread

Back
Top