USB Audio Player PRO (UAPP): 24- and 32-bit playback, ubiquitous USB audio support for Android
Mar 17, 2022 at 10:44 PM Post #5,401 of 6,195
When using EQ will involve DSP processing therefor wil not be Bitperfect anymore. Therefor when it says "Bitperfect mode!" means it cannot execute command since you are in Bitperfect mode.


  1. It maybe in your upsampling settings that the device will output to 384kHz, or it is the max of your device.
  2. Need to do its work on what?
  3. PEQ uses DSP to process. Your signal will not be bitperfect anymore. Or in vice versa: when in bitperfect, PEQ is disabled.
  4. Because you turned off USB. It needs USB connection to communicate with your source device in order to play.
Apologies for not being clearer. I will try again.

In the situation when the R8 is not connected to USB, my source files are either music files (ALAC or .mp3) on a 512GB internal Sandisk, or streaming from Tidal via wifi.
In UAPP settings, the internal audio driver = hires digital driver. Under Android Audio, Android sample rate= ‘Device native sample rate’. ‘Bit perfect’= ‘when possible’ or "on" (what I describe below seems to occur identically with either Bit perfect setting). Upsampling =On. Music playback is via 3.5 SE or 4.4 mm balanced cables out of the R8. I purchased in-App UAPP add-ons for MQA and Toneboosters. When UAPP Bit perfect = on, of course PEQ does not work (as stated above) and I get an error message from UAPP displayed "bit perfect mode!" if I try to invoke EQ . I realize that MQA files do not allow EQ; however, the problem occurs if I try to play an MQA file or a non-MQA file. When bit perfect = on, both types of file play "normally".

If bit perfect = off, I can invoke PEQ i.e. EQ bands are displayed, but if I then try to play music, a UAPP message is displayed "failed to find or set up hires DAC". I have tried to fix this by changing UAPP Android Audio sample rate to 'variable rate'. This does not fix the problem. Sometimes after turning Bit perfect to off, and trying to play music (as described above) if I then turn Bit Perfect = on, UAPP will crash (though not always).

I have an R2R dongle, the Cayin RU-6. I can attach this to the R8 via USB cable. in this situation, the R8 serves as the source. Playback is via 3.5 mm or 4.4 mm output jacks from the RU-6 in this setup. When Ru-6 is attached, I initially receive a message "USB device initialised", displayed on the R8 in UAPP. Then, without changing any other UAPP settings, I can turn Bit perfect to OFF, and UAPP will play any/all files via 3.5 or 4.4 mm jacks via the RU-6. In its own oversampling mode, RU-6 plays back up to 384 Khz (its maximum). If a source file plays in UAPP on R8 that is MQA from Tidal, in this set up the MQA insignia is not displayed in UAPP, so I don't know if MQA unfolding is happening or not (nor do I care, really).

My question is, what setting do I need to change in UAPP, so that UAPP will play music on R8 when a USB device is NOTconnected, and Bit Perfect = off in UAPP settings. It seems to me that there is a software error in UAPP, since UAPP often crashes after I have turned Bit perfect=off and tried to play a song in UAPP (and received the error message ""failed to find or set up hires DAC") after turning Bit perfect back = on.
 
Last edited:
Mar 18, 2022 at 3:10 AM Post #5,403 of 6,195
Mar 18, 2022 at 3:51 AM Post #5,404 of 6,195
My question is, what setting do I need to change in UAPP, so that UAPP will play music on R8 when a USB device is NOTconnected, and Bit Perfect = off in UAPP settings. It seems to me that there is a software error in UAPP, since UAPP often crashes after I have turned Bit perfect=off and tried to play a song in UAPP (and received the error message ""failed to find or set up hires DAC") after turning Bit perfect back = on.

On using R8 only. Maybe UAPP's HiRes drive is not fully supported yet in R8. It is not in the official list. R5, R6 and R6 Pro yes but no R8. That is why you receive "failed to find or set up hires DAC". It's not fully supported. https://www.extreamsd.com/index.php/hires-audio-driver

On Cayin RU-6. When using RU-6 on your R8, ALL audio signals are bypassed TO RU-6. R8 will behave as transport/media player only and RU-6 as DAC. On RU-6 product page I don't see any MQA support. No MQA insignia is displayed because there is no MQA processing done in your RU-6.
 
Mar 18, 2022 at 9:46 AM Post #5,405 of 6,195
On using R8 only. Maybe UAPP's HiRes drive is not fully supported yet in R8. It is not in the official list. R5, R6 and R6 Pro yes but no R8. That is why you receive "failed to find or set up hires DAC". It's not fully supported. https://www.extreamsd.com/index.php/hires-audio-driver

On Cayin RU-6. When using RU-6 on your R8, ALL audio signals are bypassed TO RU-6. R8 will behave as transport/media player only and RU-6 as DAC. On RU-6 product page I don't see any MQA support. No MQA insignia is displayed because there is no MQA processing done in your RU-6.
Thanks this makes sense. I will write to the developers to learn if they have any plans to support. @gLer may also have information, as he mentioned UAPP as a useful player for an R8 user in his review of the R8 DAP
 
Mar 18, 2022 at 1:59 PM Post #5,406 of 6,195
Thanks this makes sense. I will write to the developers to learn if they have any plans to support. @gLer may also have information, as he mentioned UAPP as a useful player for an R8 user in his review of the R8 DAP
UAPP works a treat with RS6.
 
Mar 18, 2022 at 2:01 PM Post #5,407 of 6,195
Thanks this makes sense. I will write to the developers to learn if they have any plans to support. @gLer may also have information, as he mentioned UAPP as a useful player for an R8 user in his review of the R8 DAP
Update
New version of UAPP uploaded last night. Now when RU-6 connected to USB, and UAPP = bit perfect off, music will not play on RU-6. Only plays if Bit perfect = on in UAPP on R8. At least it’s now consistent!

I will still write to the developers. R8 has been out a long time and by now they should support it.
 
Mar 19, 2022 at 2:31 PM Post #5,408 of 6,195
Update
New version of UAPP uploaded last night. Now when RU-6 connected to USB, and UAPP = bit perfect off, music will not play on RU-6. Only plays if Bit perfect = on in UAPP on R8. At least it’s now consistent!

I will still write to the developers. R8 has been out a long time and by now they should support it.
Ok another update. Following the link @m-i-c-k-e-y left, I emailed EXTREAMSD and their customer service tech Davy rapidly emailed me back (within the hour). He stated that R8 -IS- supported though the document on their website listing supported devices did not list it. We tried some tweaks, the most important of which was to turn UAPP Internal Hires Audio setting for UPSAMPLE = off. This eliminated the flag ‘hires dac not found or set up’ and it appeared that when but perfect = off playback was occurring (playback timer progressed showing time from beginning of the track), but no audible sound played via the R8’s 3.5/4.4 PO. Davy asked me to uninstall/reinstall UAPP.

That fixed it!
I was worried that I may not have access to all my account info, add-on apps, and TIDAL subscription in UAPP, but info was automatically restored (so data must have been been retained by UAPP or Google Play Store)

I did have to turn Upsample =off. At first I did not and got the same old message “ 'Failed to find or set up hires DAC!” But having interacted with Davy I checked that and it was “on” — so I turned it “off” then everything worked perfectly. All other settings were as installed.

I can now toggle Bit perfect on/ off. When on, all playback behaves perfectly- R8 unfolds MQA to 768 KHz (direct =384 KHz in UAPP), and non-MQA to 705 KHz (direct 44 KHz)

When bit perfect =off, MQA plays at 48 KHz, and non MQA at 44 KHz, and I can use PEQ for non MQA songs.

KUDOS to Davy at EXTREAMSD - I rarely encounter this level of responsiveness - especially on the weekend! If I have any additional problems I am confident that EXTREAMSD is there to help and won’t hesitate to ask again. But I will hesitate to tweak settings on my own!
 
Last edited:
Mar 19, 2022 at 4:11 PM Post #5,409 of 6,195
Good for you bro!

Yeah @Davy Wentzler is a good guy. We helped each other out thru the years.
 
Mar 20, 2022 at 1:53 PM Post #5,410 of 6,195
Hi there! I can’t remotely control my m3x and uapp from my iphone :frowning2: it used to work with mconnect on my iphone but it’s not working anymore.

I select “start upnp renderer” in the uapp (on my m3x) then I go to mconnect on my iphone and refresh the browse section but it’s not seeing uapp at all.

Could someone help me please???
 
Mar 23, 2022 at 4:55 PM Post #5,411 of 6,195
Hello, I've bought this great App last night to use it on my Android phone, the Xiaomi Poco F2 pro, together with Qobuz. I am accessing Qobuz from within UAPP but the interface is different. When I am searching for an artist, I am not getting the same results as to when I am searching on the Qobuz App from my phone or my laptop. Is there some setting I need to set for this to work? Because it makes UAPP almost unusable for me. I am searching for an artist, and instead of seeing all of their albums etc, I am presented with Songs that contain the name of the artist, and some of their albums, randomly. What should I do?

Thank you
 
Last edited:
Mar 23, 2022 at 5:04 PM Post #5,412 of 6,195
I've heard that Tidal updated their app to overcome the limitations with the Android systems and DAC access. Is it still worth using UAPP with an LG v20 playing Tidal with the internal DAC? Or, is the Tidal app fine on it's own? Thanks.
 
Mar 23, 2022 at 8:14 PM Post #5,413 of 6,195
I've heard that Tidal updated their app to overcome the limitations with the Android systems and DAC access. Is it still worth using UAPP with an LG v20 playing Tidal with the internal DAC? Or, is the Tidal app fine on it's own? Thanks.
Tidal only made their app bypass the mixer when playing MQA I believe; for CD-quality files UAPP still is the answer.
 
Mar 24, 2022 at 12:30 AM Post #5,414 of 6,195
Hello everyone!

I just downloaded UAPP and am loving it so far. I am using an old Samsung S7 Edge running Android 8.0.0 in conjunction with my Hugo 2.

UAPP is doing a great job of feeding my Hi-Rez files to the Hugo 2, but I am having a problem with the built-in Qobuz functionality: the Hi-Res files are playing at a maximum of 44.1/16 bit. (I have the settings on max sound quality within UAPP.)

Can anyone provide some guidance as to how I can "unlock" Hi-Res streaming for Qobuz wihin UAPP?

Thanks so much!
 
Mar 24, 2022 at 2:09 AM Post #5,415 of 6,195
Hello, I've bought this great App last night to use it on my Android phone, the Xiaomi Poco F2 pro, together with Qobuz. I am accessing Qobuz from within UAPP but the interface is different. When I am searching for an artist, I am not getting the same results as to when I am searching on the Qobuz App from my phone or my laptop. Is there some setting I need to set for this to work? Because it makes UAPP almost unusable for me. I am searching for an artist, and instead of seeing all of their albums etc, I am presented with Songs that contain the name of the artist, and some of their albums, randomly. What should I do?

Thank you
I also access through QoBuz, and while the top part of the screen lists individual songs, below that are all of the albums by the artist. You man need to press the search "enter" key to load them fully.
 

Users who are viewing this thread

Back
Top