1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

DX200=Affordable High End Audio. Dual ES9028Pro dacs. AMP1, AMP3, AMP5, AMP7 & AMP8 ***Firmware support now up for AMP9***

Discussion in 'Portable Source Gear' started by paul - ibasso, Dec 17, 2015.
  1. ngd3
    Edit. Disregard, it started working just now for some reason

    20190705_102415.jpg
     
    Last edited: Jul 5, 2019
  2. singleended5863
    I have most cables with 4.4 (Angie II/PW05, Phantom/Eros II 8wire, Spartan/Ares II 8wire) and DX200TI and DX220 (will be sent back to ibasso soon) and amp9. So my chance is only listening to DX200TI and amp9 and it is a fabulous combination I gave impressions back in this thread.
     
  3. singleended5863
    That is what I got with DX200TI and DX220 but I didn’t give up by using the Android tool within the FW update link and successfully updated.
     
  4. gr8soundz
    Exact same thing happened to me updating a DX150. Make sure the correct zip file (might have the word 'full' in filename) is on the root of your sd card and not in a folder.

    Also try restarting the player. You may still have to press 'Upgrade' a few times but it worked for me after rebooting.
     
  5. highfell
    Am just listening to AMP9 now.

    Initial impressions within the first hour.

    1. Sounds glorious, Very mellifluous. Bass is so strong, but the vocals (mids & trebles) are also lovely. Analogue sounding yes, but no mudiness.
    2. No issues with volume playing into Sennheiser HD600, Mezes 99 (wow the bass is very pervasive) and my Shure SE846. The Amp9 plays all of these plenty loud enough on low gain.
    3. No hiss heard on any of the above head phones

    Very very happy. I was expecting to be like the sound from other reviews but the Amp exceeds all expectations.

    Just want to keep on listening.........
     
  6. highfell
    After unboxing and fitting the AMP9, I got a shock as I didn’t hear any sound coming from it to begin with. I think I must have kept my DX200 on by mistake and I assume it needs to be rebooted to recognise the new AMP9.

    I had a horrible thought that maybe it was broken but all well now though.
     
  7. Rayzilla
    I haven't done an update in like forever but my DX200 will not start. I get a DX200 sign and then the screen just goes black/off. When plugged in with USB-C, a quick push of the power button will show that it is half charged. Holding the power button down will get me to the DX200 sign and then it turns off again and repeats if I hold it down.

    The last time I used it as a DAC only. Then the above happened the next time I tried to turn it on. In one of the attempts, I did manage to get it to stay on and so I switched it back to pure Mango mode and it has only turned off every time since.

    Any help appreciated.
     
  8. immortalsoul
    It happened the same to me when I first tried to install the firmware. You have to install the first version of the Android 8.0, and only after that you install the latest version of the firmware. Good luck!
     
  9. Paul - iBasso
    If you haven't updated to Android 8.1 Oreo, you will need to use the Android Tool and load the USB/DAC driver from our download site to your computer. The Android Tool Beta download will work fine as it has the tool and a .img firmware you will need. The instructions are with the download. Once you have updated to 8.1, you can then update directly to the latest firmware.
     
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
     
    http://www.ibasso.com/
  10. kalo86
    Hi @Paul - iBasso,

    Can you clarify the situation about the DX220 and the installation of third parties applications as the Neutron music player? Thanks
     
  11. Paul - iBasso
    With our software you will need to side load/use an APK. I know that Lurker0 has an app that will allow use of other ways to load apps.
     
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
     
    http://www.ibasso.com/
  12. kalo86
    To sideload an APK file is not a problem. I wonder if the Neutron app requires the google account manager on the Android system in order to recognize the license because I use Neutron on my smartphone without problems (smartphone with Google services).
     
  13. Rayzilla
    Thanks for the reply Paul. Just to confirm, I can do this even though I can't get the DX200 to start? So the first thing I need to do is update to Android 8.1 Oreo even though I am on a very old version?

    Thanks.
     
  14. Pictograms
    You can definitely do this even if the DX200 doesn’t start, you will have to follow the instructions in the download though. Not difficult just A it different.
     
  15. fuhransahis
    You'll need to install the Lurker add-on which enables Google Play Services (and hence license verification - I use it to verify my UAPP license).
     
    kalo86 likes this.

Share This Page