1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

AP80 - Hidizs next portable Hi-Res music player

Discussion in 'Portable Source Gear' started by IryxBRO, Apr 24, 2018.
First
 
Back
147 148 149 150 151 152 153 154 155 156
158 159 160 161 162 163 164 165 166 167
Next
 
Last
  1. abitdeef
    I guess I’m so old school that I expect released items to be solid in functionality and future firmware updates only for ‘extras’. Obscure bugs I can kind of understand, but if someone play tested this, well it shouldn’t have passed.
     
    Sougouk, mono-type and AndySocial like this.
  2. toear
    Any chance they could put some kind of software lock on the unit? I find the unit gets turned on and off too easily... Especially in my pocket. Otherwise an awesome sounding dap...
     
  3. dannytang
    Any chance you can post an example of a playlist you imported? I can't seem to get mine to work.
     
  4. AndySocial
    Did you get the playlist_data directory created by the AP80? Based on the conversation about the Hiby R3 (same OS), you can't create that directory yourself - the device has to make it by saving at least one playlist on the device.

    Otherwise, it's just the settings I showed above. Here's one playlist that I've loaded. It imports fine into the database when I hit the "load playlist" option in the menu, while also working perfectly from the file browser menu.

    ../Music/lovelytheband/broken/01 lovelytheband - broken.mp3
    ../Music/Foster The People/Sacred Hearts Club/03 Foster The People - Sit Next to Me.mp3
    ../Music/Panic! At The Disco/Pray For The Wicked/04 Panic! At The Disco - High Hopes.mp3
    ../Music/Imagine Dragons/Natural/01 Imagine Dragons - Natural.mp3
    ../Music/Weezer/Africa/01 Weezer - Africa.mp3
    ../Music/Marshmello & Bastille/Happier/01 Marshmello - Happier.mp3
    ../Music/The Interrupters/Fight the Good Fight/03 The Interrupters - She's Kerosene.mp3
    ../Music/Young the Giant/Mirror Master/01 Young the Giant - Superposition.mp3
    ../Music/Badflower/Ghost/01 Badflower - Ghost.mp3
    ../Music/Portugal. The Man/Woodstock/04 Portugal. The Man - Feel It Still.mp3
    ../Music/The Smashing Pumpkins/Silvery Sometimes (Ghosts)/01 The Smashing Pumpkin - Silvery Sometimes (Ghosts).mp3
    ../Music/Bad Religion/My Sanity/01 Bad Religion - My Sanity.mp3
    ../Music/Billie Eilish/you should see me in a crown/01 Billie Eilish - you should see me in a crown.mp3

     
  5. dannytang
    Thanks for the example!

    I created the directory myself. The problem I have is, even when create a playlist on the AP80 and then save it, it doesn't create the directory and corresponding m3u file. Is there something I'm missing? This is my first non-iPod/iOS DAP in years, so I have some learning to do.
     
  6. AndySocial
    Here's the sequence I did to get the directory to show up (may have to delete your manually-created directory first):
    1. In the Playlist menu (lines and music note in the player), create new playlist. Use tiny keyboard to name it something, with much frustration.
    2. In the Playlist menu, save playlist. Select format from the list of ONE possible format, for reasons.
    3. In Files menu (folder icon), navigate to the Micro SD Card, then to the playlist_data directory.
    4. See new M3U file I just saved.
    5. Load playlists from MediaMonkey with the settings shown earlier.
    6. In the Playlist menu, select Load Playlist
    And then it has worked ever since, even though I have long since deleted the device-generated M3U playlist and its database entry.
     
  7. Music Enthusiast
    Hi, I just found the time to photograph the hardware issue I have HIdizs AP80 broken button.JPG with the AP80's skip forward button. Just posting it here in case anyone else comes across hardware problems
     
  8. UrbanMana

    Thanks for the help, I got to the point where I populated the device created playlist list with my m3u files, loaded them, but there's a 0 showing up next to them and even though it shows the track names, when I click on them it says that the file cannot be found. The link between the M3u and the track is broken somehow, thoughts?
     
  9. AndySocial
    I'm stumped. Once you create one M3U list on the player, it should allow you to load playlists in that same directory. Are the file paths relative and with Linux file separators? The relative path thing is essential; I'm not sure about the file separators, but Linux style definitely works.
     
  10. dannytang
    The problem I'm having here is that I can see the playlist in the Files Menu, but there's no directory on the SD card? And when create the directory myself and put m3u files in it, the AP80 can see and load them but show 0 songs on the list... so I'm not sure if this is all an issue of macOS (even though I've tried 2 computers) or the beta firmware that came loaded on my AP80.
     
  11. AndySocial
    Just to be clear, did you delete the directory you created, THEN had the AP80 create an M3U via the "save playlist" option? That seems to be the special sauce. It's a needlessly complex dance, considering I could just drop an M3U list onto my Rio Volt in 2000...
     
  12. dannytang
    Yes. I even tried reformating the card and resetting the AP80 back to factory settings... The AP80 sees the playlist it's saved in "TF:/playlist_data", but the directory and, as a result, the playlist file doesn't show up in macOS when the AP80 is plugged in as a mass storage device or when I put the micro SD card into the computer.
     
  13. AndySocial
    Magic Mac problem? I'm at the end of my troubleshooting list. Maybe someday the actual manufacturer might chime in. Hahahahahaha
     
  14. dannytang
    Thanks for your help! And yes, hopefully, they'll chime in...
     
  15. dannytang
    So I booted up a Windows XP VM and installed a ex-fat driver and lo and behold... the directory is there... put in a playlist and the AP80 is able to load it! This is so weird because macOS still can't see the directory, not even when I look for hidden files. Wonder what's going on here... In any case, at least it's working now, just need to boot up windows every time i want to update my playlists I guess.
     
    AndySocial likes this.
First
 
Back
147 148 149 150 151 152 153 154 155 156
158 159 160 161 162 163 164 165 166 167
Next
 
Last

Share This Page