xDuoo X2 - small lossless player with microSD and OLED!

Discussion in 'Portable Source Gear' started by redfx, Jan 3, 2015.
  1. stienz
    I only got my xDuoo X2 for 2 weeks and it is already broken. It won't boot, no matter what I try. I installed Rockbox as soon as the device arrived. Tried charging it, resetting it. Holding the on/off (and several others) for a long time. It is just dead. Any advice on what to do? Should I just install the normal firmware? Send it back?
     
  2. fredhubbard2
     
     
    you did what now ? um think you mean xDuoo X3 , the X2 cannot be rockboxed.
     
    go to the rockbox X3 thread, several solutions are posted there. you don't need to install normal firmware, its now dual boot , just switch on w/ hold and stock FW will load.
     
  3. stienz

    I'm sorry, you are right, will try more when I get home, thanks.
     
  4. EMC2
    So now that X2 has been in production for several years, has the durability of this product improved, or are there still many instances of it bricking? I sold mine last year and bought a Colorfly C3 mainly because I was worried that my x2 would eventually brick. Otherwise, I was quite pleased with it.
     
  5. fredhubbard2

    I've got 3 X2's. Never had a problem.
     
  6. rikk009
    I have never seen such issues. I have used mine very roughly and it's as good as new functionally only battery has depleted, I guess that's normal after 2 years of usage.
     
  7. voxdub

    I've had mine over a year and still as good as the first day, in fact I've just ordered 503450 1000mah battery to put in it to extend play time.
     
  8. eyan
    I've had my xDuoo X2 for about a month now. I have an Onkyo E700M and E300M that I use with the DAP.
     
    One really annoying thing about the X2 is that it lists directories sorted by the timestamp of the directory in descending order. I hoped it would at least display the directories in alphabetical order.
     
    If you want the directory listings (Menu [button] -> Folder) to be listed in alphabetical order, create a new (temporary) directory on the CF card. Move all of your existing top level folders to that directory. Then move all of the directories back to the top level. Delete the temporary directory you created. Ta-daaa!
     
    Leaving this here since 1) I can't seem to create a new thread. If i do can, I'm dumb enough not to find it. :) 2) for possible searchers that are annoyed enough to look for a solution.
     
  9. fredhubbard2
     
    Or use this : http://www.anerty.net/software/file/DriveSort/?lang=en
     
    sorts SD cards alpha ... 
     
  10. Fixxxer86
    I ordered one, it will arrive next week, I hope at least that it is a worthy player like it was my sansa clip+... [​IMG]
     
  11. Fixxxer86
    Sadly, death on arrival... Just powered on one time and never more. Anyone with the same problem?
     
    :/
     
  12. redfx
    With memory card?
     
  13. Fixxxer86
     
    It's strange...
     
    I'll explain the sequence:
     
    - First time booted up (without microsd card), so it didn't detect any disc and then turned off automatically.
    - A couple of hours later I tried with a 32gb microsd class 10 card, and it didn't boot up anymore. I tried everything (connect to pc, charge, reset, etc. and nothing happend)
    - Today I've got a torx screwdriver in my work and opened it (I left the microsd in my home) Disconnected the battery, and connected again, and it booted up again. After a couple of tries it didn't turn on anymore. So I opened it again, disconected the battery, pluged the micro usb cable (it said battery full  without the battery in it - *weird*), and pluged in the battery again. Then I left it charging till it said it was full. I tried to turn on and off a couple of times, it worked like 6 or 7 times, and then... not anymore again... I heard a "click sound" when it worked every time I turned it on and off.
     
    So... I can ask to take the torx screwdriver to my home and do some further inspections (with and without the microsd card in it)... I guess that the battery may be the problem :/
     
    Cya :)
     
  14. Fixxxer86
    Well... Now it's working just fine. I don't know what I did to make it happen, but just unplugg and plug again the battery with the microsd card in it.
     
    It sounds really good compared to other portable music players that I had (like sansa clip+). It has more power too. Only problem so far is that it does some *hiss* noise, not really a big problem, but when the song has a quiet part it bother me somehow. Anyway, I'm happy with it :)
     
    If anyone knows if it is possible to get rid off the hiss sound it would be amazing. Thanks!
     
    Cya [​IMG]
     
  15. rikk009
    It has high output power so it will hiss but only with low impedance high sensitivity IEMs. Or you will have to put more resistors in between your IEMs and the DAP like this http://www.ebay.com/itm/Etymotic-ER4P-to-ER4S-3-5MM-plug-resistor-adaptor-/272584006783?hash=item3f7745dc7f:g:zOgAAOSwH3NXnX3c 
     

Share This Page