1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iDSD micro Black Label. Tour details (page 147). Release info (page 153).

253 254 255 256 257 258 259 260 261 262
264 265 266 267 268 269 270 271 272 273
  1. Roscoeiii
    I've got the perfect fix for you: Contact iFi support!
  2. davesday
    I had but I wanted to reach out to learn of any workarounds from the community and discuss about it?
  3. notorious4163
    Hi Guys,

    New owner of iMicro DSD Black Label and boy is it amazing, however the imbalance/unbalance sound is just insanely annoying. I don’t usually listen to my music a lot at low/mid volumes however it is clearly imbalanced (left ear is louder).

    Is there a solution to this problem? I’ve already returned and exchanged the product at Audio46 (NYC) and it’s just as bad.

    Does it bother anyone else this much? Im on the verge of returning this amp because of this.

    USING the Campfire Atlas, does anyone recommend the settings to fix this?
  4. Roscoeiii
    What did iFi support have to say? They are better qualified to answer it than us bozos.
  5. Jearly410
    Have you tried the iematch switch?
  6. notorious4163
    of course, imbalanced at all levels. some less than others but still imbalanced and so annoying. I tried all the modes every combination
    Last edited by a moderator: Jul 17, 2018
  7. davesday
    Thats pretty common according to what I read/learned about the product. What power mode are you on? If you are on Normal and you are listening at very low volumes where the pot is at 9 o'clock and lower, the volume pot does not have sufficient range for the volume you desire. Turn it down a notch to Eco and you may have more range with the pot. If you are already on Eco, then try Jearly410's suggestion with the iematch switches.

    If your volume pot is above 9 o'clock or higher and you're getting non-match volume, then I'm not sure what else is the issue. I'm listening at about 10 o'clock on Eco mode, iematch off, bit-perfect, + polarity and there are no issues with volume balance. Are you listening on the Atlas? Does the problem persist or just temporarily?
    Jearly410 and cardeli22 like this.
  8. davesday
    Just replying over my own issue posted a few days back. I found a workaround and am thinking this could help out users here and promote positive discussion.
    The problem (pops/clicks switch to/from DSD including pausing DSD playback) has gone away if I flashed Firmware 5.20. Obviously this is on the same setup as mentioned. The pops/clicks are now reduced significantly to a mere 'bump' in the sound. Flashing back to Firmware 5.30 brings back the loud pops/clicks and it was very loud/bad on the CA Atlas. Unfortunately pops/clicks with turning on/off are still there and I suspect this is by design (which I understand).

    iFi Audio thinks it is player related which I also agreed. This is because the problem did not occur with playback on PC using AIMP. However I did not have the same setup because I was using the RCA line outs to speaker. So I will need to revisit this.

    But if the problem was addressed or improved on Firmware 5.20, the question is why did it not carry forward to Firmware 5.30. The firmware release notes mentioned quite a few things and I am going through it with iFi. While I don't listen to any MQA content at the moment, I am interested to find out if there are any other enhancements implemented on Firmware 5.30 that could lead to better sound quality or product experience over Firmware 5.20 (no matter how small).
  9. notorious4163
    So, the channel imbalance is around 9/9;30 at all levels unless if put on Eco/Off

    so my choices are for the least channel imbalance is 1) Eco/Off 2) Normal/High Sensitivity

    Most channel imbalance 1) Normal/Off (Which is what I like to keep it at because of the volume but the other two mentioned also works. So last question is which has better sound quality? 1) Eco/Off or 2) Normal/High Sensitivity for the Atlas's (Usually listen to 12 or above so I know being picky)
    Last edited: Jul 16, 2018
  10. davesday
    The channel imbalance with respect to volume (if we are referring to the same thing) only happens if the micro iDSD BL's volume is brought down to very low levels. This can also happen if the volume pot is turned down very low (usually 9 o'clock and below). Not sure if this is by design or a limitation as a result of the design choices.

    But in my opinion, this is due to the range available to the volume pot (how much adjustment you have per degree of turn, if that makes sense). E.g. if you operate the iDSD BL at Normal mode for a very sensitive IEM, you would find yourself turning the volume very low for comfortable listening. You enter the region where the problem is reported. So it is better to operate the iDSD BL at Eco mode for such sensitive IEMs so you don't have to turn the volume pot so low. As a result you don't enter into the region where this problem exist. E.g. on Eco mode you may turn the volume pot to 12 o'clock for the same volume as in Normal mode but with volume pot at 9 o'clock.

    I don't believe there are differences in quality whether iDSD BL is on Eco/Normal/Turbo. They should not affect the tonality of your IEM of choice. You should choose the power modes depending on how sensitive or efficient your IEMs are. However I do notice that on some IEM/headphones, playing around with the iematch may/may not expand the dynamic range of your setup. This is a kind to enlarging a picture on PC/phone so you could spot finer/smaller details that you would otherwise miss. The changes are small though. Now this is just my understanding on the subject which may be inaccurate but I'll let other more experience members chime in.

    The iDSD BL has many settings so it is best to discover what is the nicest combination and enjoy the fun of doing that. Then share it and see what others may say.
    Jearly410 likes this.
  11. Jearly410
    Great answer. Keeping the knob pointed at 12 and adjusting the power mode/iematch to get a good listening volume is an easy way to do it. Your iem does not require much power to begin with, and dynamic driver iems do not have drastic changes in sound when the impedence changes (unless it changes to a much higher value.) learn the sound of the Atlas first, then fine tune the ifi bl. Tip rolling will have a bigger change on what you hear than the dac settings and polarity.
    davesday likes this.
  12. technobear
    I do wish iFi Audio hadn't labelled the power/gain switch Eco/Normal/Turbo. It's highly misleading and causes some audiophiles to believe they should be using 'Normal' for best sound and that 'Eco' is somehow substandard in the name of power saving. This is all nonsense. If they had labelled it Low/Medium/High or Normal/High/Turbo we wouldn't have any of these types of posts because people would just use the appropriate setting for their headphone (which is definitely the lowest setting for the Atlas at 105 dB/mW).
  13. superuser1
    Not really rocket science to figure that out.
  14. jmills8
    I go by my ears and not by my thinking.
    superuser1 likes this.
  15. bden59
    Anyone can recommend good USB A/A extension cable($50-100)? Stock blue cable is not the best as I understand.
253 254 255 256 257 258 259 260 261 262
264 265 266 267 268 269 270 271 272 273

Share This Page