1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX90 Bug Thread - Post Any Firmware Bugs/Issues Here

Discussion in 'Portable Source Gear' started by wolfen68, Apr 20, 2014.
First
 
Back
46 47 48 49 50 51 52 53 54 55
57
Next
 
Last
  1. Alpha Floor
    I second this request. Also have a false contact on the phone out; the right channel goes silent at times...
     
  2. Guppy_
    I tried using the device as DAC, failed miserably on windows 10, now windows 10 says "usb device not recognized", tried uninstalling drivers with not success, even tried in another computer, same jazz. Any ideas?
     
  3. Guppy_

    Can't even use the batch tool if I get USB device not recognized :/ This in rockbox and mango

    and if I try volume up + inserting cable, the player just goes in a black screen nothing shows up in device manager. I have to remove battery to get it to boot up.

    Could be perhaps by usb port has gone faulty? anyone know of how I could test to see if that is the actual issue? THe dx90 charges when hooked up to pc.
     
    Last edited: Jun 21, 2017
  4. NymPHONOmaniac
    I don't know if it's what you mean, I was searching to open it and find it on the DX50 mod thread, very easy and no risky, I open it cause my gain switch was making strange static noise and behavior, inside was a little dusty and now i've been able to blow more accurately and gain switch is back to normal hourray!

    I copy-paste the very simple tutorial here:

    Take out battery.
    Unscrew 7 screws that are highlighted:
    [​IMG]

    Next, slide those parts marked with red and blue in opposite directions:
    [​IMG]
    Now You should get plastic frame that holds battery, out of the rest DX50 body and should have easy access to jack solder pins.
     
    Last edited: Jun 26, 2017
  5. scribable
    I'm suddenly having a problem with my DX90. I was playing mono hi-res recordings and listening using the headphone jack when I noticed that the imaging was skewed to the left. The right channel is softer, for some reason. When I plugged my headphones into the line out, the imbalance doesn't occur (though the sound obviously doesn't suit the headphones the way that the headphone jack does). A factory reset on the device did not rectify the balance problem.

    I then jiggled it somewhat and the sound reoriented correctly, which was both a relief and dismaying. The plug seems well built and I don't treat it roughly at all, so I didn't see this coming. I'd very much like to have this fixed. How shall I proceed? Would the above diagram apply to this issue? I could potentially have a repairman gain access inside and re-solder the jack pins, or whatever needs doing.

    Thanks for whatever guidance you can offer!

    UPDATE: This got settled up a while back but I thought I'd revise the entry here in case it's of use to others. It wasn't a hardware issue with the DX90's jack after all. A repair man suggested that my headphone's jack needed some cleaning, so I gave it a good rub with a pen eraser and I haven't experienced any issues since. Just FYI.
     
    Last edited: Aug 21, 2017
  6. Namaskar
    Hi All
    This question might've been asked before (?) - I let the dx90 run out while listening to music, using FW 2.3 ... after charging it just shows 'Ready" on the display but is not going to the last song ... as well does not accept music from the sd card (it DOES show all the songs though, just not loading them). From internal memory it eventually plays (after trying a few times...), but reverts back to 'Ready" once restarted....
    Easy fix or do I need to reformat and reload all music? Thx for your help :)
     
  7. Namaskar
    Well - impatience got the better of me - removed sd card, did a factory reset, delete all data .... turns out the internal memory stays intact.... reboot, v 2.3 , all back to full functionality . Re-scanned sd card.. all's well :)
    Does anyone have a suggestion what spare quality battery to get? (Australia or ebay)
     
  8. matique
    It's 2017, realised that with mac/linux dac there is a popping sound + sound doesn't sync with video. Shame, it's a great device overall.
     
  9. lian00
    [solved] Hello, I have a message "locked" showing on the screen. And I don’t know where it’s coming from.

    Sorry, I never switched the second button :flushed:
     
    Last edited: May 31, 2018
  10. MParrott
    Has anyone seen this problem (THIS IS THE FIRST PROBLEM I HAVE HAD):

    I have a 24bit 192khz grateful dead album that will not play. It either has the song come up and stalls at 0 seconds, or automatically reboots.
     
  11. Lurker0
    The big chance that it was encoded with non-standard flac encoder. At least it was a known problem for DX80 with tracks purchased from HDTracks. You can try to re-encode these tracks, e.g. using foobar2000.
     
  12. vaggbaba
    I want to ask if anyone found any solution about the crazy ffw button at dx90.
    I have the same problem about 1 and a half year now. I have send it to Ibasso in China they said they fix it but the problem remains. Then I contact with them and said that was test it and not was doing it.
     
  13. CobraMan
    What firmware version are you using? The latest one released? If so - try going back to the prior FW to see if there is any difference.

    Speaking of FW...

    Paul - I know this is probably extreme wishful thinking on my part but any chance the bugs I identified back on page 55 in post 815 will ever be fixed and released in a FW update? I realize the DX90 has been out of production for a while and the resources are dedicated to the DX120, DX150, and developing other new products but I am sure there are many DX90's still being used out there. Still my favorite device (until I buy something more current like the DX150, R6 Pro, or M5s...) and spent some great quality time listening today - man what a device...

    Cheers,
    Tim
     
    Last edited: Sep 11, 2018
    NymPHONOmaniac likes this.
  14. vaggbaba
    Voting cobraman!!!!
    And ffw button problem
     
  15. ericf
    Hello. My DX90 won't go past the start up screen. If I connect it to the computer, the "Chaging" green ball shows 3 times and then the screen is black. I usually charge my batteries separately though. The DX90 and the sd card don't show up inside the computer.
    I have tried changing between different batteries. No difference.
    I have also mailed iBasso but haven't gotten an answer yet.
    Is my DX90 on it's last song?
    Thanks.
     
First
 
Back
46 47 48 49 50 51 52 53 54 55
57
Next
 
Last

Share This Page