1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

iBasso DX90 Bug Thread - Post Any Firmware Bugs/Issues Here

Discussion in 'Portable Source Gear' started by wolfen68, Apr 20, 2014.
First
 
Back
47 48 49 50 51 52 53 54 55 56
  1. lian00
    Hello, did you try a factory reset ? Press and hold the power button for 7 seconds to reset the DX90. Or reinstall the firmware ?
     
  2. ericf
    Thanks for the reply.
    I tried the factory reset but it just starts and gets stuck on the start up screen again.
    Since the computer doesn't recognize the player through USB (it finds two "removable disk's but can't access them), I guess I can't reinstall the firmware?
     
    Last edited: Dec 31, 2018
  3. lian00
    You are right. I hope iBasso will answer you quickly.
     
  4. CobraMan
    Couple of other ideas for you:
    1) Have you tried to boot it up without any memory card installed? Maybe give that a try if you haven't already.
    2) For reinstalling FW (any version) - suggest using the RKBatchTool as that is how I solved some of my problems with installing directly to the DX90.
    3) There is a system recovery mode that should be reachable by holding down the Power and Volume Down together - give that a try as well if nothing else works.

    Hope one of these helps - I also remember one other combination of buttons like Play/Volume Up/Power (not sure on this though and tried some searching to no avail) that has some special functions but not 100% on this one.

    I still use my DX90 as my primary device and haven't seen anything to lure me away yet. Was eyeing the R6 Pro but it appears that single ended outputs only utilize one of the two DAC's and the recent info on pricing at $800 = not for me.

    Happy New Years to all!!!

    Cheers,
    Tim
     
    Last edited: Dec 31, 2018
  5. ericf
    Thanks for all the replies.
    I tried starting without the SD card but there's no difference. If the computer doesn't recognize my DX90 I don't think I can use the RKBatchTool.
    The system recovery mode using power+volume down gets the same result as holding the power button for seven seconds. I have to remove the battery for the player to stop showing the start up screen.
    Have a Happy New Year!
     
  6. Lurker0
    It is worth to try it anyway.
     
  7. CobraMan
    I suggest trying the RKBatchTool if you haven't - start up the application first then plug the cable into the DX90 from it being off. See if it shows up in the tool and allow you to load/reload the firmware.

    I experienced some problems early on with failed FW updates, etc and it was suggested to use the tool and I have ever since.

    Good Luck and if I think of anything else I will let you know. Maybe Lurker0 can provide some ideas as well - he is an established guru for sure!

    Cheers,
    Tim
     
  8. CobraMan
    Thought of one other thing to check - just in case the batteries aren't making good contact and that is resulting in your DX90 not powering up - take a pencil eraser and rub the contact areas inside the DX90 to clean them and ensure a good contact. Could also wipe with a contact cleaning solution but don't use anything abrasive.

    Let us know if you make any progress or have any luck getting it up and running again.

    Cheers,
    Tim
     
  9. ericf
    Thanks again. I tried to connect with RKbatchtool. I followed the instructions at
    https://androidmtk.com/use-rockchip-batch-tool
    but it wouldn't work. Pressing the volume up button didn't make anything happen so I tried both power and volume up at the same time, and: Success!
    The player showed up, I updated the firmware (2.5.1), and am now able to play my favourite music on the DX90 again.
    Whew! That was a few hoops too many to jump through for me.
    Thanks a lot!
    Happy New Year!
     
    shane55 and hakuzen like this.
  10. CobraMan
    Happy to hear your DX90 is up and running! Good way to start 2019...

    Cheers,
    Tim
     
First
 
Back
47 48 49 50 51 52 53 54 55 56

Share This Page