1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5iii Custom Kernel and Scripts | 2016MHz CPU | 20% RAM increase | Undervolting | New DAC drivers | and much more

Discussion in 'Portable Source Gear' started by jkbuha, May 3, 2019.
First
 
Back
1 2 3 4 5 6 7
9 10 11 12 13 14 15 16
Next
 
Last
  1. WitzyZed
    If app is not successfully installed, you may have to uninstall your existing FiiO Music app, the version # is identical (1.1.0) to that found in OFW 1.2.4., but it is a fix nonetheless.
     
  2. illi4
    Thanks, I will try again, but I have already tried this and the new version of the app did not help unfortunately
     
  3. lookingforowls
    Whats the pause issue you are discussing ?
     
  4. WitzyZed
    When hitting the lock screen / power button, people were saying FiiO music (exclusively?) in Pure Music Mode would pause playback. And it was dependent on the output used too? Like maybe 3.5 headphone output was unaffected, and 2.5mm headphone output was, I know users said line out was. I wasn't able to repeat the issue myself even when it was brought up. But FiiO posted a new(?) .apk of FiiO Music 1.1.0, the same version number that came with firmware 1.2.4. But that fixed the issue for that particular user, and I wasn't able to repeat it again, either.

    Context begins here:
    https://www.head-fi.org/threads/fii...dual-card-slot.828402/page-1005#post-14996848
     
    Last edited: Jun 22, 2019
  5. illi4
    In my case the issue is (both android and pure music, any output):
    - Start playback in Fiio music (any version), press pause with the screen shut down
    - Wait for more than ~ 30 seconds, press play
    - The screen lights on, the music stutters, and the other track starts playing

    I have changed all the firmwares and all the kernels and nothing seems to help. Also tried various SD cards and only copying some of my music (not all).

    UPD: Tried with OMNIA Music Player - it also lights up the screen after a long pause, but at least it can resume playing the same track. It's a pity that button fast forward doesn't work on it, though
     
    Last edited: Jun 22, 2019
  6. WitzyZed
    My X5III has FW (Fidelizer) 1.2.4, custom kernel 3.2, using 1.1.0 apk of FiiO Music shared on the forum, in pure music mode, using 3.5mm headphone output. I had a song playing, I turned off the screen, paused the song, started stopwatch, around 40 seconds I hit play, screen lit up, and within two seconds the song resumed from where it was paused. There was no switching to "other" songs.
     
  7. jkbuha
    Dear Head-Fi community

    After weeks of tweaking and optimisation, prispewnic and I are pleased to announce Version 3.3 of the X5iii modded kernel. As can be seen from the changelog below, this release is a pure performance release; ie: tweaks, enhancements and maximum optimisation.

    Changelog

    Version 3.3
    New: Enabled ARM ARCH_POWER feature
    New: Disabled Gentle_Fair_Sleepers (much faster)
    New: Enabled cache wakeup preemption
    New: Forced memory overcommit for better performance
    New: Ignore all ICMP echo requests
    New: Enable TCP low latency
    New: Removed noatime and nodiratime to improve ext4 and sys filesystem performance (much faster)
    New: Added asynchronous filesystem calls (much faster)
    New: Enable TCP reuse read mostly algorithm
    New: Enable TCP sysctl recycle algorithm
    New: Disable TCP slow start after idle
    Enhanced: Optimised SLUB memory allocator
    Enhanced: Reduced Mini Memory Map to from 32k to 0
    Enhanced: Reduced Max Block Dev size from 128 to 32
    Enhanced: Increased Max Queue length from 128 to 1024
    Enhanced: Tuned kernel fair scheduler workload parameters
    Enhanced: Increased memory threshold compaction from 500 to 800
    Enhanced: Reduced dirty write back interval
    Enhanced: Increased sysctl read interval for reduced latency
    Enhanced: Optimise TCP sack/fack/dsack read requests
    Enhanced: Optimise TCP memory pressure
    Enhanced: Optimise TCP proto packet length algorithm
    Enhanced: Added options for disabling and restoring stock player FiiO Music
    Fix: Minor AROMA Bugfixes

    Download and install as usual from the following link:

    http://bit.ly/FiiOX5iiiV33

    Thanks and Rants

    Again, massive thanks to prispewnic's product features, suggestions and testing, and the great community of beta testers on Head-Fi and 4PDA.
    Thanks also to @FiiO for releasing the first GPL of the source code back in June - now waiting on you to help us support the X7/M11 in the same way as the X5.

    As always, any queries, comments etc - please shout.
     
    Last edited: Jun 25, 2019
    biteme02, srbungle, MinnieOne and 2 others like this.
  8. MinnieOne
    Updated just now and for some reason it shows 3.2 kernal optimization message. Also in setting it shows me "Tue May 28 13:29:52 BST 2019".

    I know I did the update because I selected the auto load to Power Amp for the first time I've used that and that worked fine, so what could have gone wrong here?

    NEVER MIND, I realized I had the leave previous Kernel check box on.
     
    Last edited: Jun 25, 2019
  9. nekromantik
    delete
     
    Last edited: Jun 25, 2019
  10. Focalor
    Hi,

    I had the same issue several times and is not "fiio music" related but rather firmware update related.
    I Did the following to resolve the issue:
    • Find FiioMusic folder via ES Explorer and remove folder
    • Go to TWRP and Clean Cache and Dalvik.
    • Reboot and reconfigure FiioMusic app
    Hope this help you resolve your issue :)
     
  11. nekromantik
    im not finding this firmware to be stable.
    2 or 3 times out of 5 when turning on the device it gets suck on the fiio boot logo and then turns off after a few mins.
    Only way to get it to boot is recovery mode and flash old kernel
     
    MacPac likes this.
  12. WitzyZed
    The kernel hasn’t been unstable or causing any boot problems for me. Of the ten or more times I’ve turned this thing on since yesterday morning, not one time did it hang on booting.
     
    eddy1963 likes this.
  13. MacPac
    +1

    Only boot first time... then any reeboot freeze in "welcome" boot logo and then go off after few time
    Now on v3.2 again (no problem with 3.2)
     
  14. nekromantik
    glad its not only me!
    I used same settings in aroma as 3.2 also nothing changed
     
  15. SteveUK
    And another one here - same symptoms. I finally installed 3.3 with the lower speed version rather than balanced that I'd used with 3.2 and it seems ok now.
     
First
 
Back
1 2 3 4 5 6 7
9 10 11 12 13 14 15 16
Next
 
Last

Share This Page