1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5 3rd gen || 2x AKM 4490 || Balanced Out || DSD || DXD | DTS | Android || Dual Card Slot

Discussion in 'Portable Source Gear' started by xloud, Dec 8, 2016.
First
 
Back
955 956 957 958 959 960 961 962 963 964
966 967 968 969 970 971 972 973 974 975
Next
 
Last
  1. jkbuha
    Reboot to twrp recovery and manually wipe cache/dalvik. Reboot and let me know how it goes.
     
  2. Brooko Contributor
    Let it run through - takes a while the first time. After that reboot and it'll work normally.
     
  3. calmdown
    Sorry if if was already asked before, but the thread got too big to search... So, please could anyone help me? I did a giant mistake of uninstall google services and now some of my apps stoped to work. But I don't know how reinstall services again. Already tried format X5III but services keep out. Tried to download it on some websites but services does nothing, only crashes and close itself forever. Please anyone. Sry for noob question, but I must fix this mess. Thanks
     
  4. ElKabong
    I tried that too,only to end up re flashing the firmware, it ended up being faster than the other supposed methods.
     
    calmdown likes this.
  5. WitzyZed
    Hopefully this proves useful as a reference for those installing stock or custom firmware (the Fidelizer Purist ROMs by WindowsX), and kernel+scripts (jkbuha & prispewnic from 4PDA).

    Many have already done this successfully even with some of the instructions focused or scattered on different pages of the thread.

    Links to anything you need are provided within. This set of instructions goes for anyone with a windows home computer. Best of luck!

    Going forward, please keep any of your precious microSD cards removed from your player, and be aware anything on your player’s internal storage is going to be wiped.
    -this should be obvious, but let’s continue

    Grab the 1.2.4 purist rom as well as the FiiO firmware upgrade tool from this link:
    https://www.fidelizer-audio.com/fiio-x5iii-purist-rom-version-1-2-4-released/

    Whether or not you're installing custom firmware, I stand by using the firmware upgrade tool to reinstall the stock update.img that comes with it, then installing firmware 1.2.4 variant afterwards.
    -If going Stock route, Once stock 1.2.1 is reinstalled, install the X5-ota-1.2.4.zip found here: http://m.fiio.net:8000/forum.php?mod=viewthread&tid=44018&extra=page=1 via the technical support application. Then perform a factory data reset (in the Settings App) w/ internal storage wipe.
    -If going Fidelizer route, Once stock 1.2.1 is reinstalled, repeat steps but replace the update.img as described below

    Begin by installing the latest usb drivers:
    http://fiio-file.fiio.net/FiiO_USB_DAC_Driver-V4.47.0.zip

    Then run the RKDriverInstall exe from the firmware upgrade tool folder.

    Fidelizer Step Only: Delete or remove the ‘update’ disc image file from the firmware upgrade tool folder, and replace it with the ‘update’ disc image extracted from WindowsXPurist1.2.4 zip. The purist disc image will be the smaller of the two.

    Hold down the “Previous Track” rocker button (the one closest to the volume dial) with your player powered down and connect the micro USB cable from your computer to your player.
    -You should have heard a connection chime, and your player's screen should remain off. The player is now in the "bootloader" mode

    Right click on the firmware upgrade tool exe in the firmware upgrade tool folder and run as administrator.

    With ‘√ Device Connected’ showing, click the green ‘Upgrade Now’ button ONLY ONCE. Wait patiently.
    -The progress bar will move along, and in the process you will hear several connection chimes.
    -STOCK: It is done when your player has booted up to the language selection screen.
    -FIDELIZER: It is done when you see the white battery icon on your player's screen, and the blue LED power indicator illuminated.
    -Hold down your player's power button and allow it to boot up/initialize, etc.

    From the settings app, scroll to 'System', then hit 'Factory data reset', scroll down and check the 'Erase internal storage' box, hit the grey 'RESET DEVICE' button.
    -Let this do its thing and wait for the player to reboot.
    -You can disconnect USB from player at this time.

    - END OF FIRMWARE STEPS -
    ******************************************************************************************************

    Next we've got to install the TWRP (Custom Recovery) loader.
    -found here: https://www.androidfilehost.com/?fid=1395089523397899882
    -unzip this to your desktop or wherever.

    Power off your player again, and put it in bootloader mode by connecting to USB holding down the previous track button.

    Open AndroidTool.exe from the loader folder.
    - 'One Loader Device Found' should be displayed.
    -Make sure that checkbox #2 'boot.img' & #3 'Image\recovery_twrp.img' are checked.

    Press 'Run' and wait until the loader operation is completed.

    Go to 'Advanced Function' and click "Reset Device".
    -You should have heard a connection chime, and your player is released to a powered off and charging state, like when you installed the Fidelizer firmware.
    -Go ahead and disconnect your player from USB cable.

    Power on your player, allow it to boot up/initialize, etc.

    Download the kernel+optimization scripts by jkbuha.
    -links hosted by jkbuha found here (3.32 is latest): https://androidfilehost.com/?fid=6006931924117916490

    Download SuperSU (root).
    -found here: https://www.mediafire.com/download/ix18pf9gjg09jy4

    It is recommended at this point to turn off the lock screen, changed under Settings app, Device, Security, then Screen Security, set screen lock to none.
    Also in Settings app, Device, Display, Sleep After, set to 10 or 30 minutes.
    -this will help to make sure you don't miss vital prompts down the line confirming successful kernel optimizations.
    -once successful feel free to set these back to your preferred options.

    Plug USB back into your player, and mount its internal storage.
    -Without being too verbose, you should see the green android guy and a "turn on usb storage" button and click ok
    -Once you see the internal storage as a volume on your computer, you're going to want to drag the two zips to an easy to access location, like the 'Download' folder on the X5's internal storage.
    -Once that's copied go ahead and safely eject / unmount the X5 volume from your computer
    -Click "turn off usb storage" button on your X5
    -Power down your X5

    To enter TWRP custom recovery, power off your player then simultaneously hold down the following three buttons:
    -Play/Pause (Remain pressed until you see blue TWRP splash screen)
    -Previous Track (Remain pressed until you see blue TWRP splash screen)
    -Power (Release when FiiO ‘Welcome’ logo appears)

    You should now be at the home page in TWRP

    Press 'Install'
    -navigate to sdcard/Downloads
    -select the SuperSU zip
    -swipe to install
    -then hit 'wipe dalvik/cache'

    Go back home in TWRP
    -Go to advanced 'Fix Permissions' then 'Reboot System' (do not check any SE Linux options here)
    -If done right you should not see the 'It appears your device is not rooted, would you like to install SuperSU' notice.

    Let your player reboot and initialize, etc.

    Re-enter TWRP Recovery

    Press 'Install'
    -navigate to sdcard/Downloads
    -Select the jkbuha 3.32 multi zip
    -swipe to install
    -AROMA installer should begin, go through prompts (preferably custom install)
    -Select 1416, 1704, or 2016 speed, recommended to begin with 1416 for stability and move up from there, if your device can handle them.
    -once this is done installing your player will automatically reboot.

    Depending on the number of applications installed on your device, this app optimization step can take up to 5 minutes or so, but stay vigilant.
    -once you get to home screen observe bottom of the display for prompts for user to reboot device.
    -these typically show up within 1-2 minutes.
    -if user does not manually reboot (hold down power button, reboot) scripts will countdown to an automatic reboot of player (done in about 15-20 minutes)

    Upon reboot observe bottom of the display for "Kernel 3.3: All Optimizations Done"

    At this point you should have the Fidelizer 1.2.4 firmware (if applied) and the latest kernel, scripts, boot optimizations, etc. installed.

    However you may remember we added the SuperSU (root) zip to your downloads folder on the X5.

    So again enter TWRP recovery by doing the play/pause, previous track and power button combination from above.


    With root access, you are going to want to install greenify, kernel adiutor, as well as an application like Titanium Backup Pro (about $6 on google play store) because with that, you can freeze applications (like google play services or google services framework) or delete unnecessary applications (like es file explorer, animated wallpapers, alternative language keyboards, fiio market app, email & exchange apps, stock browser)

    If you get a permissions error during AROMA installer process, install kernel version 2.8 first, this will properly set up init.d scripts. Once you get optimizations done prompt with this kernel version, proceed with the 3.32 installer again.
     
    Last edited: Aug 15, 2019
  6. calmdown
    Where I can get instructions to re flash it just to get stock rom back (and no custom roms mentioned on last pages)? Thank you in advanced.
     
  7. WitzyZed
    Have you tried using the technical support application to reinstall this? http://x5pack.fiio.net/1.2.1/X5-ota-1.2.2.zip
     
    calmdown likes this.
  8. calmdown
  9. MinnieOne
    You can also follow this, happened to me so I know it works.

    :
    "In this case, you'll need to run use the Firmware Upgrade tool to burn the firmware. The upgrade tool package can be downloaded from this link: https://www.dropbox.com/s/k96kq9xjzwtb86v/FW1.1.7.rar?dl=0

    You need to run the Firmware Upgrade tool on a Windows computer, and please follow the instruction (available in the package) to operate."
     
    calmdown likes this.
  10. MinnieOne
    Thanks for doing this, finally something to follow along with. I'll probably pass on this for now because with the newest music app I'm pretty satisfied.
     
  11. Famazon
    It still freezes on boot screen "Fiio smart hi-res DAP" and it running already for one hour...
     
  12. jkbuha
    No worries, we'll get this fixed. PM me with your boot log (adb logcat) and I'll take a look at what's going on
     
  13. p0k3m0n
    I answer myself:
    1) root is not problem, Magisk works almost fine. Almost, because after rooting You must recover original boot partition. Root still works after this.
    2) none, beacuse EQ do not works on Fiio in Spotify. NOT ANY. Fiio imho fu..k up something with audio stack, and EQ cannot be run as system wide. And I know, this is Spotify fault too, but Fiio either. Eg for LG exist workaround with their DAC, but on Fiio nothing works (even deep_buffer remover). So we have semi-pro audio device without working EQ - "great" invention.
    3) who cares. China simply cannot understand how write good Android code. Low level quality of development. 0.22, 1.22 or 10.22 - the same sh..
     
    Last edited: Feb 11, 2019
  14. Persco
    I really wish someone could do this for Mac instructions. The ones on Fidelizer don't work (tried it six ways from Sunday and it never works) and jkbuha's Mac install is very difficult too.
     
  15. jkbuha
    Unfortunately MacOS isn't really supported in China, hence why all the Rockchip toolsets are (mostly) Windows-based.

    There exist command-line based tools for macOS, such as the ones I use (rkflashtool), but I haven't found any binaries, and have only been able to get them working by compiling them from source code. If you're on Mojave as well I'll be able to send you my binaries and you might be able to get them to work, but they're command-line based, so you'll need to be comfortable with using Terminal and bash and knowing where your files are.
     
First
 
Back
955 956 957 958 959 960 961 962 963 964
966 967 968 969 970 971 972 973 974 975
Next
 
Last

Share This Page