1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5 3rd gen || 2x AKM 4490 || Balanced Out || DSD || DXD | DTS | Android || Dual Card Slot

Discussion in 'Portable Source Gear' started by xloud, Dec 8, 2016.
First
 
Back
953 954 955 956 957 958 959 960 961 962
964 965 966 967 968 969 970 971 972 973
Next
 
Last
  1. jkbuha
    Hasn't happened before. Have you rebooted at least once since you've installed the kernel?
     
  2. Ghost Of Lundy

    I will say I appreciate what you are doing but I thought you should know I had to roll back to previous version as I tried to use Neutron and it crashed after playing a couple songs and other apps Stuttered (Onkyo HF player). I rebooted all night at work and when I rolled back to the previous kernel everything worked as it should.
     
  3. jkbuha
    Could you do the following:

    1) Install 2.5 via TWRP as per usual
    2) Manually clean cache and kernel cache from TWRP
    3) Reboot, leave player for 30 mins for scripts to run fully.
    4) Reboot
     
  4. Ghost Of Lundy

    Ooops.

    Wasn’t aware I had to do that.

    I’m new here.

    Not at home right now but will surely do that later.
     
  5. nekromantik
    is root the only method of installing twrp?
     
  6. WitzyZed
    Root isn’t needed to install TWRP, I know the earliest instructions mentioned needing to use kingroot or w/e, but I’ve installed TWRP on a clean install of either stock 1.2.1 (now 1.2.2) or fidelizer 1.2.1, using just the TWRP installer tool.

    https://www.mediafire.com/download/5vv0bz9wvypbnqv

    You do still need to get the kernel zip from jkbuhas latest post: https://www.androidfilehost.com/?fid=11410963190603915883

    Once you have TWRP and the new kernel installed and you do want root for certain applications you can install this zip in TWRP

    https://www.mediafire.com/download/1ch3om94ugjlvjm
     
    Last edited: Feb 6, 2019
    tichyztech likes this.
  7. ghosthost
    Thought I had; possibly not... of course now I definitely have since it crashed. Behavior remained similar; multitasking seems to interrupt audio playback, but I'll give it a fuller test this evening and report back.
     
    Last edited: Feb 6, 2019
  8. nekromantik
    Yeah I tried that and it does nothing.
    Im on Fidilizer 1.2.2
    Even though it looks like its flashed twrp it has has stock recovery.
     
  9. WitzyZed
    Hm. Wasn’t aware of the new Fidelizer update. But define “does nothing”.
    Just for superstitious reasons, it shouldn’t need this but I do it anyway, run the loader like five times in a row. Then reset the device. Then enter recovery with power play and previous buttons, releasing power with welcome screen and play and previous once you see the blue TWRP screen.
     
  10. nekromantik
    Nothing as in it shows it flashing but then no twrp.
    I will re try and delete the folder and re download and try again.
    The new 1.2.2 Fidilizer came out today. Announced on twitter :)
     
  11. WitzyZed
    Well I just used the firmware tool to install 1.2.2 Fidelizer, did a factory data reset w/internal storage wipe. Then used the TWRP installer tool, ran the loader 5x, reset device, let it boot up, powered down, then booted into TWRP with no issues.
     
  12. jkbuha
    No worries. Follow the 4 steps I outlined above and let me know how it goes.
     
  13. ElKabong
    3.0.101+, is this the newest kernal?
    Flashed another package that was linked in one of the threads, i was having all sorts of trouble getting twrp installed.
    I used the flash tool with this newer zip file and all was good, went into settings and seen that your kernal was installed as well.
     
  14. jkbuha
    All my (and Fiio's) kernels will always be based on the 3.0.101+ SDK for Android 5.1.1. Rockchip stopped supporting this chipset a while back, and frankly it's not worth trying to upgrade the kernel to newer versions of Linux or Android given the hardware limitations. Optimised properly, 5.1.1 works really well on this player, as can be evidenced from the latest modded kernel and run-time scripts.

    The latest build version can be determined from the compile date below the build version, which should be Feb 2019.

    More pertinently, the windows loader install version has worked for you, which means you can now flash using TWRP for any future updates, including V2.5.

    On a related note, if anyone here can contact the moderators it will be really useful to get all this new info regarding the kernel and installation procedure up on the first page.
     
  15. gazzington
    Without reading all these pages, what kernels should I install and how do you do it?
     
First
 
Back
953 954 955 956 957 958 959 960 961 962
964 965 966 967 968 969 970 971 972 973
Next
 
Last

Share This Page