1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

DX220 A new view to your music. * Latest Firmware: 1.15.233 Local * Link for User Guide 1st Page. AMP9 Now available! And DC01.

Discussion in 'Portable Source Gear' started by Paul - iBasso, Jan 23, 2019.
466 467 468 469 470 471 472 473 474 475
477 478 479 480 481 482 483 484 485 486
  1. Paulo Abreu
    Just for the record, I use Mango OS exclusively and my DX229 never freezed. In first two weeks I let it to burn often with burning cable, sometimes +24 hours? and never hanged
    The only "strange" thing it happened was after a FW upgrade (I think the 1st upgrade) it went dark and it took some tries with power button for a few seconds to make it wake. A factory reset after that and never again, even after later upgrades.
    My 2 cents
    Last edited: Jul 30, 2019
  2. CobraMan
    Only available in Android Mode - go to Settings/Audio Settings/Volume Wheel Control - select On/Off. Not available in Mango Mode under current FW.

    quodjo105 likes this.
  3. quodjo105
  4. Paul - iBasso
    We are looking into the shutting down. We have 3 DX220 that play all the time but haven't duplicated this but will continue to investigate. For those with the problem, has anyone used the Android Tool and .img firmware to wipe the DX220 to do a fresh factory firmware install? After doing that you would then update directly to the latest firmware. The USB/DAC Driver for Windows also has be be installed on the computer.

    Android Tool:


    .img firmware for use with the Android Tool for DX22:
    Android Tool:

    Last edited: Jul 31, 2019
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
    Whitigir likes this.
  5. Paul - iBasso
    For anyone wanting a different language you can install via an APK, for example:

    Chinese can be done this way.

    And for the second question here: Use File manager to access LAN.

    1. How do I get Chinese writing input on DX220

    2. How can make dx220 see my NAS disk on my LAN (wifi)
    iBasso Stay updated on iBasso at their sponsor page on Head-Fi.
  6. gto88
    I should refine my 2nd question, I wanted the network disk be mounted, so DX220 can
    see is as if it was local.
    I tried many app, none can do that includes file manager, so I gave up.
  7. fokta
    My TPU case is arrived...
    perfect fit, except on the volume wheel, need to champer the edge to make the wheel smooth rotating....
    Can't use the temper glass that comes with it, due to the crack on my front edge screen... :triportsad:
    And the back Temper glass is not meant for DX220, what I mean, if you put it on, it also cover the AmP, so if you want to remove/change amp, u need to take off the back temper glass... #foreheadclap
    Last edited: Jul 30, 2019
  8. aaf evo
    I ordered mine from Taobao last week and they haven’t even shipped yet. :frowning2:
  9. artpiggo
    Use neutron. You can add NAS as source via various ways.

    Whitigir likes this.
  10. singleended5863
    How did you order it? Any English link to order?
  11. kazekai
    Hi Paul, thanks for the recommendation. I will be trying this and will update here on how it goes.
  12. aaf evo
    Google chrome translate and then google translator lol, took me about 30 mins
  13. panasonicst60
    Nice. Mine is coming in soon...I think
    fokta likes this.
  14. edwardsean
    I tried this fix tonight and then updated to 1.12.149 and installed Lurker. After about 2 hours I got a glitch again. I rarely get a shut down. For me, the system just stops playing, freezes, and in about 2-3 seconds, brings me back to an earlier track. Everything is fine after that and can go a long time before it happens again.

    I've tried to note any pattern or antecedent, but it seems random.

    Nevertheless, I just finished a new version of the amp8EXmod, sourced by information from Vince's brain, and the sound of the 228EX is just leveling me with gorgeousness. So, in all honesty, I presently can't seem to find the will to care about a glitch here and there.
  15. kazekai
    Seems like you have an additional glitch - rewinding tracks. Maybe this is due to the lurker's mod?

    Mine is stock firmware and I encounter the sudden shutdown glitch. Done what Paul suggested and so far okay. Fingers crossed!
466 467 468 469 470 471 472 473 474 475
477 478 479 480 481 482 483 484 485 486

Share This Page