1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Chord Mojo issue solutions thread.

Discussion in 'Portable Source Gear' started by greenbow, Nov 25, 2015.
Tags:
First
 
Back
55 56 57 58 59 60 61 62 63 64
66 67
Next
 
Last
  1. Olafcx
    I ended up using a magnetic usb cable and glueing the connector to the mojo to solve the problem. Sharing as a useful semi-fix. :)
     
    xtr4 likes this.
  2. Olafcx
    EF798EB5-704D-4959-835E-A980C4AC6FF3.jpeg
     
    xtr4 likes this.
  3. meffisto
    Just bought a Mojo.
    It looks like a big joke!
    I try to listen music on tidal on my P30 pro => big interference, no way to listen anything if the mojo is next to the phone... so tried with my samsung phone => same! with or without any usb cable...

    You say "mobile joy", not for me.. i just hope i can use it as desktop DAC, or i just send it back.
     
  4. _daRK
    I use it irregularly with my Samsung GS7 and don't encounter any interference.
     
  5. Deftone
    No problems here with Sony Xperia 10
     
  6. max232
    Marbles.
     
  7. vonBurg
    Hey lads! Just bought a Mojo but instead of getting the Apple CCK cable, I would like to get a Micro USB to Type C cable to connect the Mojo directly to the iPhone or iPad Pro, for sure I am not the first one with this question but... any suggestion?? (I guess quality matters...) thanks!!!
     
  8. mathi8vadhanan
    No Type-C for iPhone. For iPad Pro, you can get the Shanling L2 for Fiio CL06
     
  9. simonm
    Can someone please help me with advice on getting my (Chord) Mojo fixed? :beyersmile:

    One of the headphone ports is intermittently cutting out and losing (I think) a channel of audio. The other is fine. So the unit is still very much functional for single-person use, but it's nonetheless something that I'd still like to get fixed. I'm guessing it's a physical connection issue between the jack and the board and is therefore, hopefully, a fairly simple fix. Needless to say, the unit is out of its 1-year warranty, and though I asked the retailer if they could contact Chord on my behalf about options for repair, they either didn't do so, didn't hear back from Chord, or didn't get back to me about said options. So I'm reaching out here instead.

    Is this something that's likely to be simple to fix for an (audio) electrical repair technician? If so, are there any in Sydney (or Australia) that someone can recommend? Ideally, I wouldn't have to ship the unit back to England because that would probably be a month or two round-trip, in addition to more expensive shipping. But I would do so if that's the only (or best) option.

    Many thanks for any assistance or advice.
     
    Last edited: Jun 28, 2019
  10. TheTrace
    Get out before it's too late imo. You could end up like the prior post or worse, me (out of warranty).
     
  11. miketlse
    You can search this and the mojo thread, because a few owners have had this type of issue. I think some were able to diy replace the socket, but others contacted support@chordelectronics.co.uk and got things sorted out.
     
  12. simonm
    Thanks, I'll contact them. I think it still helps to have my voice added to the pool though.
     
  13. miketlse
    It has been a few weeks since you posted - did you contact Chord support, and get a helpful response?
     
  14. ok3wire
    I’m suddenly having a strange volume issue with my Mojo. My standard mobile rig for the last two years has been an iPhone (now XS Max) with camera connector kit hooked up to the Mojo powering a pair of Shure SE530 IEMs. For 99% of my listening, the volume balls never have to go much beyond cherry red to provide sufficient volume, even on airplanes.

    Last night, however, when plugging everything together, I suddenly found that my standard catalog of lossless CD rips to iTunes were barely audible at the normal volume setting. I had to crank the volume all the way up to where the balls were an icy blue color to get anywhere close to a normal listening level - and I only did that for a second, knowing that something isn’t right. The sound quality itself doesn’t seem to be affected, meaning channel separation is normal and there’s no static or popping. The sound volume is just tremendously reduced.

    I’m on the road at the moment, so I don’t have the ability to swap out any components, but there’s nothing at this point to indicate an issue with anything else in the listening chain. Of course I double checked that all the connections were secure, plugged the headphones into both of the output jacks, completely powered off the iPhone and made sure the Mojo was on a full charge, all to no avail. Any ideas what might be up?
     
  15. captblaze
    that can be frustrating especially while travelling. Have you tried increasing the phone volume? I know it sounds basic, but many time you need full output at the source
     
    Deftone likes this.
First
 
Back
55 56 57 58 59 60 61 62 63 64
66 67
Next
 
Last

Share This Page