Xonar Essense stx Random LOUD high pitched Ringing Noise?

Discussion in 'Computer Audio' started by waverider69, May 29, 2010.
First
 
Back
14 15 16 17 18 19 20 21 22 23
25
Next
 
Last
  1. bcschmerker4
    The problem is a hardware incompatibility of the C-Media® CMI8788 with the Vista audio stack; C-Media released a new driver 8.2.1.1025 (which MaxedTech® used for the UNi™ XONAR® Audio Software Release 1.92) for Microsoft® Windows® 10.0.14393.893 and up and it still gets the random 6 kHz scream, a problem that ASUSTeK engineers still haven't managed to reproduce (and they've been trying since 2007).

    I've used my own STX in ubuntu® 16.04.2-LTS for the past year with no issues; the Advanced LinUX Sound Architecture Project has a basic audio stack that's as hardware-friendly as the NT audio stack used in Windows NT through 5.2 XP. I haven't a repeat of the 6 kXz scream issue with a Creative Laboratories® SB1550 that has taken the STX' place in my ASUS® CM1630-06 (which runs Windows 10.0.15063.413 as of 17 June 2017).
     
  2. scrahn
    Got myself a Sound blaster Z. I really can't tell the difference in sound quality (perhaps my ears are damaged from the 3 xonar screeches?), and I've not had any screeches yet. The Xonar is going into my linux box once I set it up in a few months for work.
     
  3. justtesting
    From the uni xonar support comments, could be worth checking:
     
  4. Sanctuary

    Dunno if it will help with the issue (I haven't had it happen for about six months now, but I always prepare for it anyway), but it definitely did something to the overall sound, and it's not a placebo effect either. Everything just sounds "better" now.
     
  5. evvil
    OK I'm back. I've solved the problem for me to 100%. I use the i5 4670K, MSI-Z87-G43 Motherboard, MSI GTX 980 Ti 6G, Asus Xonar STX II. The Problem only appears when HPET in Bios is enabled. I disable it, skip around in Youtube Videos, no way to trigger it. I enable it again in Bios and that happens:

    PLS LOWER VOLUME BEFORE KLICKING
    Volume was 18/100. The Video was filmed with my old smartphone but you can clearly hear the how loud it is.

     
    Last edited: Aug 23, 2017
    justtesting likes this.
  6. bcschmerker4
    Looks as though ye found the clue that escaped ASUSTeK support. The High Precision Event Timer must have some sort of mutual interference with the Vista audio stack. HPET is not accessible in Setup for my CM1630-06. (I don't run HPET in the Hot Rod gPC™ anyways, as it triggers known hardware bugs in the Advanced Micro Devices® SB700 southbridge, besides interfering with disquette controller timing in the ITC® 8718 super I/O.)
     
  7. justtesting
    Interesting, in the past @wimderammelaere had the opposite conclusion on his system (post). He had to force Windows to use it all the time via /set useplatformclock true (so it's 14.3KHz all the time), but at the time when I was using the DX under the same setting it didn't eliminate the occurrence on that system. Never tried it disabled on bios, because some racing sims make use of it.
    Using WinTimerTester, what is the frequency now reported (that you found scream free)?
     
    Last edited: Aug 25, 2017
  8. mindbomb
    The noise always plays at full volume regardless of your volume settings afaik. The gain setting (headphone impedance setting) can lower the volume, so setting that low is a good idea. I'm currently back on my xonar dx, testing to see if hifi mode with gx off helps prevent this issue. I think this issue has something to do with the latency becoming too high, and I think these settings will help lower it.
     
  9. justtesting
    Hi-fi mode + GX off (even disabled startup exes related to it) didn't solve it. It was my main setting during years, until the noise became recurrent in W10 without a change to it.
     
  10. evvil
    same here. I use hifi mode most of the time. To me as I said before the ultimate solution was to disable hpet in bios. slow but steady the permanent inner tension decreases.
     
  11. wimderammelaere
    @justtesting

    You missed a newer post of me about this issue. The issue was finally solved for me by protecting buggy software with emet and/or configuring the backend of the software.
    Winamp should only be used with classicpro skins and firefox should be used with the skia backend.

    It seems that some race conditions in buggy software cause memory corruption in the memory space of the soundcard.
    Tweaks with the HPET timer just reduced the reoccurence of the issue on my intel-based computer. This might be the opposite on AMD or other computers.
    Probably it is caused by the addition of direct2d 1.1 to windows in combination with faulty usage of the api.
    The soundcard was released before direct2d 1.1 was commonly used, so they might have missed the bug for their older xonar soundcards.

    I haven't had an issue with the sound on Windows 7 (32-bit) since I switched firefox to the skia backend and kept my list of buggy software emet-protected.

    List of buggy software according to me:
    -old versions of skype
    -icq
    -trillian
    -winamp with modern skins (classic and classicpro skins are ok), wasabi backend is too buggy
    -adobe flash player
    -firefox
    -java applet plugin
    So always use emet on these software. Winamp will randomly shutdown as a consequence with EMET protection, if you use modern skins.

    Maybe there are other sofware that have issues on Windows 10. I only tested my fix on Windows 7.
    EMET has been discontinued by Microsoft and Windows 10 does sometimes disable unsupported software, so the EMET fix might not work (now or in the future) for Windows 10.
     
    Last edited: Aug 28, 2017
    justtesting likes this.
  12. Aray
    just wanna say i havent had this problem on windows 10 ever since i switched back to ASUS' own drivers (was using unified drivers before)

    i believe its been about a year now
     
  13. mindbomb
    I basically gave up on this. I will reiterate though, the spdif output does not have this issue. So you can still use xonars as a source for external dacs.
     
  14. wimderammelaere
    @mindbomb Basically this issue is now mostly solved for me. With Firefox Quantum Edition (https://blog.mozilla.org/blog/2017/11/14/introducing-firefox-quantum/) and the skia settings, the issue is finally gone. I only had this issue with old Firefox (Gecko engine) + Video DownloadHelper last week. The handling of hls streams by video downloadhelper is now handled by open-sourced software of this company (https://github.com/mi-g/vdhcoapp). This seems to solve the issue for this extension.
    So basically the problem occurs only if you have buggy software installed.

    I diagnose bad software as follows:
    If a program crashes with emet protection, I consider it buggy and you should find an alternative (or disable the buggy functionality) or get another soundcard.

    @Aray I guess you are just lucky, as the drivers of Asus probably reserve another memory space, than the unified drivers. I guess having more ram, might also reduce the occurence.
     
    Last edited: Nov 21, 2017
  15. ValentineMichaelSmith
    Have noticed something else to add to the loud white noise issue. I thought at first the noise issue was confined to my headphones attached to the STX ii sound card. However, the issue randomly surfaces when I use my Asus VK278 monitor coupled with the AMD HiDef audio device as the default sound device. The monitor speakers randomly produce the same loud white noise as my headphones - usually when the system is shutting down. Turning the monitor off cancels the noise.

    I also use a Vizio E55-E1 4K TV as a PC monitor. I have not heard the screeching through the Vizio's speakers when using the TV as the default playback device. I have Windows 10 64 bit OS, MSI RX480 8GB video card, most recent AMD drivers, etc.

    The Asus and Vizio evidence (one with occasional white noise, one without), would seem to indicate that this noise issue is a Windows 10 problem, as other posters have already stated. It certainly isn't ONLY an STXii problem in my case, because the AMD Hi Def audio device is driving the TV and Monitor, which bypasses the STXii card and driver. I often wonder why Asus hasn't updated the STX ii driver since 09-09-2015 - do they know something we don't and aren't telling? Also tried the Xonar drivers, same problem.

    Lastly, some users have stated that they have to reboot their PC to get rid of the white noise problem. Have discovered 2 alternative ways of dealing with this:

    1) If the noise is active, in the Xonar Essence STX Audio Center, choose an alternative output not attached to any output device. For instance, I don't have any external speakers attached to the sound card, so switching to the "2 speakers" analog out option eliminates the noise output.
    2) In the STX Audio Center, I leave the output set to 2 speakers until ready to use the headphones. That way the noise won't damage my cans or annoy me while not in use.
     
    Last edited: Dec 19, 2017
First
 
Back
14 15 16 17 18 19 20 21 22 23
25
Next
 
Last

Share This Page