Windows 10 Schiit MODI Drivers?

Discussion in 'Computer Audio' started by donunus, Jul 29, 2015.
  1. Chikolad
    I wonder if a USB regenerator like the Wyrd or the Uptone Audio REGEN (that also supplies its own power) might solve that. But they're rather expensive solutions compared with the price of the Modi.
     
  2. rmullins08
    I've got no issues with the Modi on windows 10.  Took a little while after the first upgrade for everything to start working.
     
  3. donunus
    its intermittent with my windows 10 but it was totally fine with windows 7 and slightly worse with windows 8.
     
  4. NorthernDragon
    If your laptop is powered by an Intel Skylake CPU, there are NO USB 2.0 drivers for it, nor will there ever be, unless Intel decides to change the architecture and microcode of the chips. Or, until hell freezes over, take your choice. Intel has arbitrarily abandoned USB 2.0
     
  5. donunus
    This laptop is about a year old or so with an i3 processor. Probably not a Skylake
     
  6. donunus
    I give up. It works with my other laptops so its not damaged either. This is very weird.
     
  7. NorthernDragon
    Could it be that the Modi 2 and Modi Optical are powered by a wall wart,and the original Modi draws its power from the USB port? Maybe that's why it works with a powered hub.
     
  8. donunus
    It doesn't even work with the powered hub unless connected to another non-powered hub at the same time. That stopped working too.
     
  9. donunus
    And then when used with another computer everything is fine. What a mystery
     
  10. mesamitch
    I am having the same exact problem everything was fine it worked for about 2 weeks when I installed windows 10 now all of a sudden windows 10 can't find it in device manager or playback devices

    I am more then sure it's a Windows 10 problem because I know my buddy can't use some microphone he has because windows 10 can't find it

    I think it's a Windows 10 issue with 1.1 stuff

    Did you contact Schiit about it yet? Because I am having the same issue and I don't want to look like a pest with Schiit lol because I have to send back my valhalla 2 today because the low gain setting is not working on that either
     
  11. mesamitch
    I also seen some post on reddit about this issue too
     
  12. donunus
    I have talked to schiit already and tried all their suggestions but it seems hopeless now
     
  13. mesamitch
    Hey dude! i just got mine to work!
    i am hoping it stays working 
     
    the problem with mine was that windows 10 for some strange reason?? and i don't know why installed the wrong chipset drivers for my mother board manually 
     
    so i installed the correct chipset drivers for my mother board and everything is working perfectly fine now
    hope it keeps working
     
     
    so give it a try i don't know if you tried this already are not
    but i hope i helped you out buddy
     
  14. mesamitch
    okay i lied, i guess it was just working last night for some reason i guess?
    lol
     
  15. donunus
    on and off like mine
     

Share This Page