Windows 10 Schiit MODI Drivers?

Discussion in 'Computer Audio' started by donunus, Jul 29, 2015.
  1. CFlux
    I had the exact same problem mine didn't work right after installing 10. Messed arround with it some, it came back and worked for a few months then just died after last nights update. The usb on my machine has been really funny since going to win10 so I'm wondering if the modi death is just a side-effect.
     
  2. mesamitch
    Okay so I found a fix, but it's annoying and i dont know if you guys play video games but every time I boot into Windows now it never works


    But for some strange reason every time I launch counter strike global offensive game it fixes the issue and everything becomes found again in play back devices it actually cuts the sound out of my sound card and goes to modi automatically
     
  3. donunus
    tired of it. The modi is either going to someone that can use it or the garbage can. What a waste. I mean of course we can blame windows but since my laptop is more expensive than the modi then reality sets in and what do you think will get replaced... hmmmm
     
  4. asilker
    Mine works great with foobar2000 using both direct sound and WASAPI.

    If you need a good home for your modi, PM me :)
     
  5. Tuco1965
    I just came across this thread. My Modi hasn't been connected to my laptop since upgrading to Windows 10 this summer. I'll give it a try tonight. Usually I just use my iPad into the Modi. Now I'm curious.

    Ok I just tried the Modi both directly connected to my pc and also through my powered hub. No issues at all. I do not use USB3 ports because they don't work with my Dacs.
     
  6. vnmslsrbms
    I use Windows 7 at work and it's not installing the driver.  I tried the older driver 1.03, 1.16, and even the windows 10 one.  None worked.  Says access denied when trying to install it.  Tried all kinds of fixes, even malware.  At home Windows 10 it works perfectly with the Schiit windows 10 driver.  Unbelievably frustrating!
     
  7. vnmslsrbms
    Nevermind.  The easiest solution that I missed was at the bottom of their driver page. After you extract the drivers, make sure to select that folder and choose properties, advanced, and make sure it's not encrypted.  It's that easy.  
     
  8. voicemaster
    I am having the same exact problem with my modi 2 too. I bought wyrd to see if it fix the issue, but it doesn't. I am using an MSI AIO pc. It came with Win7 and the problem started happening after I update to Win10. I tried using modi 2 with my surface pro 2 which still have Win8.1 in it and it worked perfectly fine. I am completely running out of ideas to fix this situation. Anyone can recommend a DAC that goes well with my Cavalli LC and not too expensive either. I am using my FiiO E10 with the LC right now.
     
  9. OmegaHyperion
    I had the same problem with my Modi (gen1), the source engine seems to fix it though, note that every source based game i have tried so far fixes it. (Garrys mod and Half life 2)
     
  10. G Tone
    Having the same issue-Windows 10 - Modi.
     
    Never had a problem until updating to windows 10-says it can not recognize USB device.I have a pair of JBL USB powered speakers and they work just fine through USB 2.0.
     
    It seems like the Modi had worked on USB 3.0 recently,but did sound right with windows 7.
     
    Any ideas?
     
  11. w7west
    New surface pro 4 here. Device uses the latest gen Intel processor win10 and USB3.0.
     
    Doesn't even know that I plug in my modi2.
     
    I have heard that the jdslabs ODAC works with the new chipsets/USB3.0 because the dac uses the usb1.0 driver. Seems like new devices have usb3 ports but only USB 1 and USB 3 drivers...
     
  12. SirIsaac
    I'm wanting to buy a Modi 2 Uber but I've read this issue in a few different forums now. It's starting to put me off. I don't want to buy something and just hope it works or hope it stays working, what kind of BS is that.
     
    Does anyone know if this is only an issue with the modi or do other schiit dacs, like the Bitfrost, do this as well?
     
  13. G Tone
    For what it is worth,I finally got frustrated and purchased a Modi 2 from Schiit.The Modi 2 has a switch on the back that puts it into "expert mode" labeled E.In this position the Modi uses drivers which are available from Schiit's website.I first tried it on my laptop running windows 10,and it worked ok,but not seamlessly.Hooked it up to a desktop running Windows 8 and works like a charm.
     
    Since it is working with my desktop I haven't tried it with my laptop again because I just got it last week,and haven't had the time,but I will check it out and let you know.I'm not a computer wiz,but I seriously believe that Microsoft "gave" many people windows 10 as merely a Beta test,and these USB issues have not been resolved. 
     
  14. NorthernDragon

    The latest generation Intel CPUs don't work with USB 2. It's not a Windows problem, it's actually hardwired into all Intel chips since Skylake. This is probably the source of these problems.
     
  15. NorthernDragon
    More on Skylake and USB 2:

    http://www.makeuseof.com/tag/windows-7-wont-work-intels-current-next-gen-cpus/

    http://arstechnica.com/information-technology/2016/01/skylake-users-given-18-months-to-upgrade-to-windows-10/
     

Share This Page