Windows 10 Schiit MODI Drivers?

Discussion in 'Computer Audio' started by donunus, Jul 29, 2015.
  1. luigisaMa
    This is an interesting thread.  My modi stopped working one day and I just assumed it was dead, but after reading this thread it seems it might be correlated with me uping to windows10..I'll try and play around with it once I get home to see if I can get it to work again.
     
  2. luigisaMa
    I was able to get it to work by simply changing the USB port that it was connected to.  I actually had a similar problem with another USB soundcard and when I switched USBs it worked properly.  Unfortunately with laptops you don't have as many options when it comes to the number of ports you can try.  If it matters the ports I used to get it to work was a USB 3.0 with charging.
     
  3. SirIsaac
    I've been doing some research regarding this and it seems it is directly a windows issue. Windows does not natively support usb 2 audio only usb 1 audio. For usb 2 audio to work in windows "properly" you need to install drivers. This is apparently is not an issue in Linux, as linux natively supports usb audio 2. I recently purchased a modi and once it's arrived I'll do some testing,in windows and linux, and report the results.
     
  4. SirIsaac
    That's great news. I've found early implementations of usb 3.0 to be flaky like that, with many devices. If your laptop is newer it's probably related to the usb audio 2 windows driver issue. Schiit does have drivers on their site. If the problem returns I'd recommend completely removing any trace of the old driver and reinstall the driver from the schiit site as per their instructions.  
     
  5. WhiteKnite
    Had this same issue with my Modi.  Had to connect through a non-powered USB hub and then windows found it automatically.  But... it shows a maximum of 24/48 instead of 24/96 under the settings.  This thing is proving to be way more trouble than it is worth...
     
  6. mattlach
    All of these issues make me happy I am using the Toslink input on mine.
     
  7. beezneezy
    I am having the exact same issues...Kinda sucks, as I have no other way to use this product.  Guess I will be looking to buy another DAC (from a different company).
     
  8. WhiteKnite
    Ok so I found I could get it to work 80-90% of the time if I connect at just the right time during the windows loading screen. For me that time is between when my keyboard leds flash, about 3/4 of the way through the loading process. It has worked normally a few times since the latest Windows update but I've only rebooted twice and unplugged it once so not getting my hopes up that it is fixed. Nope just a fluke. Working (or NOT working) same as before now.


    I guess I jinxed it... after using that trick for a couple weeks now connecting during the windows boot screen it isn't working at all now :mad:

    ... And now the trick is working again. I'm so done with this thing. Shopping around for something that actually works reliably.
     
  9. jimmybull
    I don't necessarily think this is a windows 10 issue. I have been experiencing the same problem with a windows 2008 server dell PC and a macbook pro. Have to pull and plug, restart system to get modi recognized for a while until recently it stopped working totally.
    Then I tried with another windows 10 pc and was never able to get it work. 
    Guess I have to stick with the toslink now.
     
  10. MOCAMBO
    Just wanted to chime in, I've been hit by this error just this morning after being forced to restart my PC for a Win 10 update. I've read through this entire thread, I don't know what to do now. I'm so sad .
     
  11. compile
    I'm really sorry to bring this back up, but this has happened to me 2 times in the past month. The only way I was able to fix it, was formatting my PC and re-installing Win10. I work from home, when using my on-board is trash. Has anyone been able to resolve this?
     
  12. WhiteKnite
    I resolved it by putting my modi in a drawer and forgetting about it.
     
  13. oAmadeuso
    Mines just stopped working after being fine for ages.

    Thought a clean driver install would fix it so uninstalled the drivers and now can't install them.
    Just get the annoying message that the CMEDIA USB 2.0 Audio device does not exist.

    Windows 10, not updated.

    Light comes on when I plug the cable in but just can't get the drivers to see the thing.

    Going to try a powered hub when I get one but it's worked fine without one up until now.
     
  14. damstr
    Does it show up in device manager at all?
     
  15. CT007
    Got my Modi Multibit & Jotunheim basic today, and I had no ****ing luck installing the USB on Windows 7... Until I read a suggestion by 'Rex Aeterna' - INSTALL THE ALTERNATE DRIVERS(v1.03)!! Boom; installed. Let's see if it stays installed...

    So far, I'm not noticing much difference over my Essence STX. Less sibilance/harshness, slightly more clarity & detail, maybe. Prolly should try a Valhalla 2 instead of the Jot.
     
    Last edited: Oct 31, 2017

Share This Page