Rockbox Xduoo X3

Discussion in 'Portable Source Gear' started by red71rum, Apr 3, 2016.
  1. Slater
    <micros SD1> IS the 2nd card slot when viewing under file browsing.

    It doesn't say anything for the 1st card. In other words, when browsing in files it goes like this:

    ----------------------------
    <micros SD1> (this is the 2nd card contents)
    .rockbox (this is the .rockbox folder from 1st card)
    music (this is the music folder from the 1st card)
    blah blah (this is a folder from the 1st card)
    ----------------------------
     
    mgh24 likes this.
  2. Slater
    https://www.head-fi.org/threads/rockbox-xduoo-x3.803844/page-128#post-13788066
     
  3. rikk009
    Unknown USB device
     
  4. EmPathWalker
    That's kind of 'normal'. This Rockbox port has never worked properly in that way. I've always had to use a card reader to put files on cards.

    In your position, I'd try formatting the card again, with something like the ridgecrop fat32 format GUI app.

    http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm
     
  5. rikk009
    The DAP doesn't wake up, nothing on screen. When hooked up to a charger the battery should heat a little bit to know that it's charging but is cold.

    Edit: My cards are formatted via Sd Formatter.
     
    Last edited: Oct 20, 2017
  6. EmPathWalker
    When I've used SD Formatter it always does EXFAT for cards bigger than 32gig.
     
  7. mgh24
    Thank you.

    Problem was that I was unable to select <microSD1>. This morning I was able to get it selected by pressing the play/pause button. Don't know why I was having so much trouble before!

    So the only problem I was actually having, was getting the <microSD1> selected.

    Thanks for the help, much appreciated.
     
  8. Slater
    Glad to help. Let us know if you have any more questions or problems. Enjoy!
     
  9. mbwilson111
    Happy you were able to figure it out. Great little player.
     
  10. rikk009
    Update: Just had a hunch that player might be working since there is no power on indicator and the hunch came true. The device is powering on, the display is dead. So now have to find a display to replace. Any help would be appreciated. Thank you.
     
  11. user name 123

    I have figured out the problem with rockbox not seeing my 128 gb pny micro sd card.

    First, I had to do a low-level format with http://hddguru.com/software/HDD-LLF-Low-Level-Format-Tool/
    Then, I had to format with guiformat.

    Apparently, there were some traces of exfat on my micro sd card even after a full format with guiformat.exe.
     
  12. bilditup1
    I was initially having the same problem ("no partition found") with a 200GB SanDisk card that had been used without issue before. The *only* thing that worked was using guiformat, but setting the sector size to 64 KiB, *not* 4 KiB, or any other size for that matter. (This was the case, btw, on both the X3 and a Clip Zip.)
    Meanwhile, I'm having two other issues, which do not seem to have been addressed (yes, I searched the thread, and yes, I'm using the latest available firmware from xvortex's site). One is a problem playing Opus files that it seems like RB tried patching in its last release, but still lingers on some of my newer encoded files. For example, on a ~180kbps file, playback happens for 00:00-00:01, then skip to 00:04 and continues from there. On some very low bitrate files (e.g. encoded from audiobooks) the issue is even worse - it'll skip to 00:02, and then all the way to 00:06 or 00:07. This appears to be happening with my most recently encoded files using opustools 0.1.10 (the build that ships with foobar2000's encoder pack), but not with all of them. I have not isolated the differences between the files that work and files that don't as yet, but will update the thread once I do. This happens on my Clip Zip as well, so my guess is this is not specific to Xvortex's port, and I'll be crossposting at Rockbox.org.
    (ED: This appears to happen with embedded artwork, and not even large artwork at that - just 50-60kb. The forum thread at rockbox.org is here, and I'll be filing a bug report after uh, getting some sleep...)
    The second issue is more severe, though, and specific to the XDuoo X3. Sometimes, when scrolling down using the left arrow key, the player will randomly select the currently-highlighted file/folder/option, as if I pressed the big round play key. Sometimes, pressing the key acts as the pause button, as well. This does not occur in the stock FW. Not sure if there's some sensitivity setting or something that I can adjust, but it's absolutely maddening. Has anybody else been experiencing this? I tried searching the thread but nothing came up, and the search term to use is not obvious.
     
    Last edited: Oct 28, 2017
  13. bilditup1
    Re the embedded artwork issue, it appears that the largest an embedded jpeg file can be before the skipping symptoms manifest in Rockbox is 45.6KiB. (I haven't actually confirmed that, but 45.8KiB definitely doesn't work. 45.7KiB might, but it's hard to generated jpgs of arbitrary size. In any case, 45.6KiB definitely works.)

    It appears I'm not the only one having the second issue, where the next button sometimes acts as select or play:
    http://forums.rockbox.org/index.php/topic,51139.msg239982.html#msg239982
    But it doesn't look like he ever reported it here, or like anybody else is having this issue.
     
  14. tschall
    I bricked my first X3 by installing the bootloader. I bought a second one and now after the boot-logo "ROCKbox" appears, the message says:"*PANIC* TLB refill handler at 0x80E06468! [0xDEADBEEF]".
    After pressing the power button it starts from beginning > bootloop."
    I read the 130 sites here but nothing helped.
    I tried 2 SD-cards, several formating in Fat32 and 3 different .rockbox versions, including the actual rockbox-full-d898b8c-170609.
    What can I do to solve the problem?
    Thanks.
     
  15. shapeshifter
    You probably should have read the manual created by rockbox port author: http://xvtx.ru/rockbox/manual.htm
     
    Last edited: Nov 1, 2017

Share This Page