Rockbox Xduoo X3

Discussion in 'Portable Source Gear' started by red71rum, Apr 3, 2016.
  1. tschall
    @shapeshifter
    I have read the installation manual, including "For first time installation" step 1 to 7.
    But the result is: PANIC* TLB refill handler at 0x80E06468! [0xDEADBEEF].
    Any other hints?
     
  2. shapeshifter
    How have you formatted your cards ?
     
  3. shapeshifter
    If you could try to format using those tools:
    gui tool http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm
    or simply using command line http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm
    Gui version will show you how your card is formatted .
    You have to be sure that used card are formated properly (allocation unit size 4096). Proper formating card is crucial to get rockbox on the x3 installed.
    If you have properly formatted cards , and the problem stil persist you have to use second method described in the manual . Using USBBurnTool works even the device has problems with proper booting.
     
    Last edited: Nov 1, 2017
  4. Slater
    Also try a low level format before the fat32 format. Someone had a problem a page or 2 back, and that turned out to be the problem.
     
  5. tschall
    Rockbox is running!
    Strange - I tried for the 9th time the "normal" installation and now it worked, but I don't know why. I did the same as the other times.
    Thank you very much for your help!
     
    Last edited: Nov 1, 2017
  6. BigDave
    with allocation unit size on a formatted sdcard, do you need to have it at 4096?
     
  7. mbwilson111
    Yes..4096
     
  8. My Little Phony
    *** problem: can't boot stock sw after rockbox installation ***

    Hi everyone,

    i got a problem with my new X3 player. It won't boot the stock software after the rockbox installation. Rockbox is working perfectly and immediately starts (installed on a 32GB FAT32 micro-sd card using the rockbox-vortex manual). When i want to use the dual-boot system to start the stock software i do it exactly like written in the rockbox-vortex manual. I set the lock-button to „on“ and switch on the X3. The Xduoo Logo appears and i set the lock-button to „off“.

    What happens: Nothing further. The Xduoo Logo just stays on the screen like its frozen. The UI don't show up. I waited for about 15 minutes. Still no change. I tried pressing buttons, set the lock to on and off. Nothing. It was not possible to switch off the device via button so i used the reset hole. I tried to boot the stock sw several times, tried to quickly release the lock-button after the Logo showed up, even waiting a bit before releasing it did nothing to solve the problem.

    I did not find a solution in one of the long forum threads.

    With best regards

    MLP
     
  9. EmPathWalker
    My X3 now fails to boot the stock firmware too but it used to do it ok. I haven't changed anything or even updated rockbox since last year. I also have to use the reset hole after trying to boot the stock firmware before I can get it to boot rockbox again.

    I've given up on Xduoo players. It's a shame because the X3 sounds good when it works and could have been a giant killer.
     
  10. charleski
    Before giving up entirely it might be an idea to reflash the rockbox bootloader. You'll need to follow the instructions given in the "For first time manual installation" section at the bottom of the manual page. A few months ago I had a weird error in which my X3 was failing to boot properly and reflashing the bootloader solved it.
     
    Last edited: Nov 9, 2017
  11. Slater
    Yup, that's what I would do.

    It's not worth the OP getting triggered and writing off xduoo and the X3 just because the crappy stock firmware won't load anymore. The ONLY thing it's good for is loading music via USB, and even that is 10xs slower than just putting the media card in a USB reader.

    Rockbox on the X3 is the bomb, and I've never looked back.
     
  12. Sh1twagon_GRUBS
    It is pretty slick! Although the display is excessively dim and small. They should have just had like an illuminated STN display so its easily readable in bright sunlight.

    I also have a Lotoo PAW5000 and it's pretty nice, but it's interface is not quite so well thought out like rockbox is.
     
  13. Slater
    Here is the fix for the dim screen that is hard to read in the sunlight. It is very easy to do, and only costs a few dollars: https://www.head-fi.org/threads/rockbox-xduoo-x3.803844/page-101#post_13376076

    (Click for larger photo view)
    Comparison.jpg
     
  14. itman
    Hi guys, I have a question about the battery. I bought last week an x3 from amazon germany to replace my sansa clip plus. I don't know which type of battery i have.I get only 3-4 hours out of it. The device gets warm during playing.It gets very hot during charging
    I noticed that when i charge it for about 1 hour rockbox shows me 100% of load and than slowly goes down till it reaches 15 or 20%. Is this normal?`
     
    Last edited: Nov 13, 2017
  15. mbwilson111
    I get 10 hours playing Flac files.
     

Share This Page