1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Meridian Explorer² Impressions Thread

Discussion in 'Portable Headphone Amps' started by click, Dec 22, 2014.
Tags:
First
 
Back
53 54 55 56 57 58 59 60 61 62
64 65 66
Next
 
Last
  1. TadMorose
    I'm using mine with Schiit Magni 3. Huge improvement in sound.
     
  2. snatex
    How do you connect the Meridian to the Schiit? What interconnect do you use? What source and headphones have you tried with this setup?
     
  3. TheSnafu
    I use Explorer2 with my speaker system: Tidal + Asus laptop (passive cooling+SSD) -> Meridian -> Copland CTA301 mkII -> poweramps + speakers
    Explorer improves sound close to cd-quality (vs Copland CDA822) just like any decent DAC would do ( + it has MQA, made it difference or not ).

    Imo Meridian is very, very good in that purpose. i tested it against Marantz HD1 and Project Pre Box S2 Digital and didn't see reason to update.
    My problem with Explorer2 is that updating it to next level is going to be in 2k€ price range (looking for Denafrips Pontus or something similar).

    Works very well with my Oppo PM3's too :L3000:
     
  4. TadMorose
    I use this interconnect to connect Meridian to the Schiit:

    https://www.amazon.ca/gp/product/B00LM2Y2U4/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

    Source is my HP laptop with Tidal as well as foobar2000 with ASIO plugin.

    Headphones are Sennheiser HD-280 Pro and HIFIMAN HE-400i.
     
  5. Lifted Andreas
    Please keep this forum in English only so everyone can understand.

    Thank you.
     
    Last edited: Sep 27, 2018
  6. Dan Fuentes
    Que?
     
    Dman23 likes this.
  7. Left Channel
    Apparently that was spam, and has been deleted by a mod. You can help by removing the link from your quote.

    ¿Como? :)
     
    Lifted Andreas likes this.
  8. kkl10
    Got the ME2 today. Connected to my mini PC, I'm getting extremely low volume from the HP-out to my 300 ohms GMP 400 (just slightly more hard to drive than the HD6xxs but not too different). And I don't mean it gets loud, just not very much; I mean there's barely any sound at all even with volume settings at max...

    PC runs Manjaro linux, checked all settings to make sure that everything is ok. Not usure if there's some specific configuration I have to do for this one... Line out to my amp is working fine...

    Not sure what's going on... Anyone knows what might be the issue? Do I need to update the firmware or something?

    I'm tempted to connect the GMP directly to the line-out at this point...

    EDIT: OK first impressions of the sound. Better line-out than onboard. As expected, there's a small improvement by powering the device with a battery instead of the PC USB bus (slightly cleaner and clearer).
     
    Last edited: Oct 10, 2018
  9. BobSmith8901
    Not sure if this may help: Did you install the Meridian Explorer2 driver that also installs the little Meridian USB Control Panel in the system tray (not sure that's possible with your Linux install...?--there should be a little black icon with a white "M" in there...if your ME2 is connected it should have a volume control, see if that might make a difference.

    Edit: Just to make sure you have things set up right: In my setup I have the USB out from my PC going into the ME2 USB, then line out from ME2 to my Magni2U, then listening out of the headphone jack on the Magni2. Not sure if you had a similar setup and might be listening out the headphone jack on the ME2 itself.
     
    Last edited: Oct 11, 2018
  10. kkl10
    I don't think there are any drivers or software for Linux... only for Windows and Mac.
     
  11. BobSmith8901
    Maybe that's the issue with the volume. Looking on the Meridian OS requirements it says Linux kernel 2.6.37 or later, not sure how that applies in your case. Note: I edited my earlier post (a second time to make it clear I am listening out the headphone out of the MAGNI2U (my bad...) but I have the feeling you've got yours installed correctly config-wise.
     
    Last edited: Oct 11, 2018
  12. kkl10
    This is my setup.

    From ME2 HP jack: PC USB (with and without battery) - ME2 HP out - GMP 400 (extremely low volume no matter what)

    Using line out: PC USB (with and without battery)- ME2 line out - SMSL TPAxx HP jack - GMP 400

    The jack of my headphone is too large, so I can't have the headphone jack and line out populated at the same time on the ME2. When I connect the headphone directly to the ME2, I need to remove the line out cable first... and vice versa.
     
    Last edited: Oct 11, 2018
  13. kkl10
    No prob. Running hardened kernel 4.12 somethings somethings. Don't expect that to be the issue, but can try with a slightly more recent one just to be sure.

    Thanks for trying to help.
     
    Last edited: Oct 11, 2018
  14. BobSmith8901
    Sorry about that.

    I guess if you've tried both of the standard configs it must be some other incompatibility. Good luck and I'm really curious now as to what the problem is!
     
    Last edited: Oct 11, 2018
  15. kkl10
    Just noticed that the lights don't change when I play different sampling rates. I followed these instructions to set up bit-perfect audio stream in DeaDBeef. Not entirely sure this works, but I wonder if this might be related...
     
    Last edited: Oct 11, 2018
First
 
Back
53 54 55 56 57 58 59 60 61 62
64 65 66
Next
 
Last

Share This Page