Geek Pulse: Geek desktop DAC/AMP by Light Harmonics

  1. tmaxx123
    Really appreciate the tips! The ifi seems like the easy choice but I’ll keep researching. I don’t like to settle :)
     
  2. Narayan23
    I feel the same about my XFI, it does DSD really well, a pleasure to listen to.
     
  3. tmaxx123
    You don’t happen to use a lps or any aftermarket power supply do you?
     
  4. Narayan23
    I don´t use any external power supply, the only tweaks I´ve done are disconnecting the power leg of my Lightning USB cable when listening to music and using Fidelizer in extremist mode, both gave noticeable albeit not life changing improvements.
    Power supplies are a different world, one I will probably have to discover sooner or later to see if the sound quality improvements warrant the investment.
     
    tmaxx123 likes this.
  5. m-i-c-k-e-y
    It's just a $50 investment (iFi iPower 12V). Buy it and say Happy New Year!

    USB regen/reclocks work. If you find a deal, take it also.

    Of the two, what's more immediate is the first.

    If you have the two pronged usb Lighting cable 2.0, attach the power leg (USB cable with black band) to your USB battery pack (cellphone), and the data leg (no black band) to your computer.
     
    Last edited: Dec 29, 2017
    tmaxx123 and spyder1 like this.
  6. m-i-c-k-e-y
    [​IMG]

    Happy New Year!
     
    Narayan23, tmaxx123 and stuck limo like this.
  7. stuck limo
    Thanks man! That pic makes me laugh. You too! (and everyone else)
     
    Last edited: Dec 29, 2017
  8. Laseng
    Today, it's 50 months since the Geek Pulse campaign started.

    Is there anyone who still believe that we will get our pulse, or any of the other things we have backed?

    We can still hope, but I have stopped to believe.
     
    Last edited: Dec 29, 2017
  9. miceblue
    Welp, I think my X Infinity's USB input is dead. I plug in headphones and all I hear is a brrrrrrrrrrr sound and no audio plays back. Flashed the latest version of the firmware, reinstalled the latest Windows drivers, nothing. Turned off/on the unit, nothing. Tried using it with OS X, nothing. Restarted all computers and tried plugging it in, nothing. Tried a different USB cable, nothing. Tried other USB ports, nothing.

    Plug in my PS4 via TOSLINK, and magically it works.
     
  10. m-i-c-k-e-y
    Mice, try usb via OTG on your smartphone if it works.
     
  11. miceblue
    I don't have a USB type C to male USB B cable unfortunately.
     
  12. m-i-c-k-e-y
    Even Type C OTG (USB A) + Printer Cable?
     
  13. miceblue
    I used to have one but it broke.
     
  14. tmaxx123
    Wow that sucks! What do you think may have caused it? Or was it Just random failure?
     
  15. miceblue
    Seems like just a random failure. It was working just fine last week. :/
     

Share This Page