FiiO X7 Mk II 2GB RAM + 64GB ROM + ESS9028 PRO + Balanced + DSD + BT 4.1 aptX + Dual mSD + Dual Band WiFi + Opt Out
Jun 8, 2018 at 3:22 AM Post #4,636 of 6,161

JaviAl

100+ Head-Fier
Joined
Nov 4, 2014
Posts
324
Likes
102
Location
Madrid, SPAIN
I report again a bug with all playlists with repeated songs:

Playing a M3U8 playlist in FiiO Music with repeated songs, in the second iteration of the repeated song, continues to play like if it is in the first iteration of that song, beeing playing continuesly in a loop.

Example: Consider a playlist like this:

1. First Song
2. Second Song
3. Third Song
4. Fourth Song
5. Fifth Song
6. Sixth Song
7. Third Song <----- (Repeated)
8. Seventh Song
9. Eighth Song

After the 7 Position (Third Song repeated) continues playing to the 4 position (Fourth Song) and when reaches the 7 position again, return to the 4 position again continuesly in a loop. Never reaches the 8 position (Eighth Song)

Also, when i manually press the second repeated song in the playlist in order to play it, the marked song playing now is the first repeated song, never the second repeated song even if i press it manually.
 
Last edited:
Jun 8, 2018 at 6:51 AM Post #4,637 of 6,161

Llermo

New Head-Fier
Joined
Dec 19, 2016
Posts
26
Likes
5
Location
Barcelona
Problem so


Dear friend,

The FiiO Music player starts to order songs alphabetically from which category? Would you mind to reset the data base from settings of the FiiO Music and rescan your media library to see if it helps?

Best regards
Dear friend,

The FiiO Music player starts to order songs alphabetically from which category? Would you mind to reset the data base from settings of the FiiO Music and rescan your media library to see if it helps?

Best regards

Problem solved!!

Thanks
 
Jun 9, 2018 at 2:21 PM Post #4,639 of 6,161

Shane D

Headphoneus Supremus
Joined
Aug 29, 2009
Posts
3,260
Likes
2,598
Location
Halifax, NS
I was starting to read this thread from scratch, as I always do when I am interested in a product. I just took a quick shot to the end to ask a question and found all these bug concerns. I would think that a year after the launch a product would be pretty stable, but I guess that is not the case? I would like to upgrade my DAP, but i am not interested in "buggy". I was spoiled for years with my iPod. I then moved to Sony which is also great, although I do have a problem with my playlists not keeping their chosen order. I am interested in a great music player with a good amount of power. I don't care about WiFi, Bluetooth or using it as a DAC/transport with my computer. I just want to load tunes and plug in my headphones (Grado GH2 and Sony MDR Z7).

Should I just stick with Sony and get a higher end model? I like the look of the Fiio's, the specs of the Fiio's and the fact that the owner interacts on these forums. But I have zero interest in dealing with problems and always waiting for the next "fix".

Thanks for any feedback.

Shane D
 
Jun 9, 2018 at 3:07 PM Post #4,640 of 6,161

majo123

Headphoneus Supremus
Joined
Jan 1, 2016
Posts
5,673
Likes
10,049
I am interested in a great music player with a good amount of power. I don't care about WiFi, Bluetooth or using it as a DAC/transport with my computer. I just want to load tunes and plug in my headphones (Grado GH2 and Sony MDR Z7)

I only realy use the x7ii as you are requiring, it's a fantastic sounding device and although there may be minor bugs I have come across none in the usage your requiring.
I would not expect it to have the same smoothness of operation as an iPod or sony device though but it's still more than responsive and runs pretty sweet, in the time I have had mine it has been pretty flawless to be fair.
 
Jun 9, 2018 at 3:14 PM Post #4,641 of 6,161

Shane D

Headphoneus Supremus
Joined
Aug 29, 2009
Posts
3,260
Likes
2,598
Location
Halifax, NS
I only realy use the x7ii as you are requiring, it's a fantastic sounding device and although there may be minor bugs I have come across none in the usage your requiring.
I would not expect it to have the same smoothness of operation as an iPod or sony device though but it's still more than responsive and runs pretty sweet, in the time I have had mine it has been pretty flawless to be fair.

That is what I am looking for. I just want a high quality player. Load it up, press play and bask in the wonderful sound.:)

Someone just posted that his playlists are disappearing. That is not good.

Do you use playlists? If so, do you use iTunes?

Thanks for the input!

Shane D
 
Jun 9, 2018 at 3:24 PM Post #4,642 of 6,161

majo123

Headphoneus Supremus
Joined
Jan 1, 2016
Posts
5,673
Likes
10,049
That is what I am looking for. I just want a high quality player. Load it up, press play and bask in the wonderful sound.:)

Someone just posted that his playlists are disappearing. That is not good.

Do you use playlists? If so, do you use iTunes?

Thanks for the input!

Shane D

I dont use playlists so I can't realy comment on that one and I mostly just play from file.
I own a few daps and mojo and owned previous x7 gen1, as I posted recently I was sceptical of x7ii after owning gen1 not that it was exceptionally bad it just didn't live upto the hype for me.
x7ii is much superior in everyway and i honestly am very pleased with it fiio did a great job on this one.
 
Jun 9, 2018 at 3:59 PM Post #4,643 of 6,161

Shane D

Headphoneus Supremus
Joined
Aug 29, 2009
Posts
3,260
Likes
2,598
Location
Halifax, NS
I dont use playlists so I can't realy comment on that one and I mostly just play from file.
I own a few daps and mojo and owned previous x7 gen1, as I posted recently I was sceptical of x7ii after owning gen1 not that it was exceptionally bad it just didn't live upto the hype for me.
x7ii is much superior in everyway and i honestly am very pleased with it fiio did a great job on this one.

If you don't use playlists, how do you organize your music? By song? By album? By folder?
 
Jun 9, 2018 at 4:07 PM Post #4,645 of 6,161

Shane D

Headphoneus Supremus
Joined
Aug 29, 2009
Posts
3,260
Likes
2,598
Location
Halifax, NS
By folder or album.
I don't stream either (a bit old school) so I can't comment on the x7ii in this regard.

I also don't stream and have no interest.
I have just shy of 6,000 songs (I just added two albums today - Dave Matthews and Shinedown.
I use playlists to organize the music by decade.

Shane D
 
Jun 9, 2018 at 4:13 PM Post #4,646 of 6,161

majo123

Headphoneus Supremus
Joined
Jan 1, 2016
Posts
5,673
Likes
10,049
I also don't stream and have no interest.
I have just shy of 6,000 songs (I just added two albums today - Dave Matthews and Shinedown.
I use playlists to organize the music by decade.

Shane D

I'm sure there are others that can give you a better insight on playlists on the x7ii but for audio alone I'm sure you would be pretty pleased.
 
Jun 9, 2018 at 4:14 PM Post #4,647 of 6,161

Shane D

Headphoneus Supremus
Joined
Aug 29, 2009
Posts
3,260
Likes
2,598
Location
Halifax, NS
I'm sure there are others that can give you a better insight on playlists on the x7ii but for audio alone I'm sure you would be pretty pleased.

Thanks for the feedback.

Shane D
 
Jun 11, 2018 at 4:27 AM Post #4,650 of 6,161

Chrono251

New Head-Fier
Joined
Jan 14, 2012
Posts
47
Likes
19
Hi!
I don't know what happened, but I loaded about 50 new flac files using the USB Storage mode as usual (I always copied the files using the USB cable connected to the X7ii in Storage mode).

The problem is that now I cannot play anything:
- Initially the Fiio Music app froze every time I tried to open the SD card. The X7ii froze as well when trying to shutdown (on the "shutting down..." screen) and I had to restart it by "forced shutdown".
- After some restarts I finally managed to make Fiio Music scan the folder and find the new tracks. But I cannot play flac files for longer than 4 seconds (the bar and timer continues to go forward, but there is no audio) and mp3s don't play at all (yes, I have a few remaining files in that format). This happens for all files, including those that were already in the SD card and that could be played with no issues before.
- The issue is there also with other apps: I tried Hiby music player and the same happened.
- I tried to remove and reinstall the SD card in the slot, but there was no difference. In settings the SD card is shown properly.

What do I have to do? Do I have to format the SD card again and copy the library again (I hope not... it's going to take a long time). @FiiO

Thank you for your help!
 
Last edited:

Users who are viewing this thread

Top