1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Fiio X5 3rd gen || 2x AKM 4490 || Balanced Out || DSD || DXD | DTS | Android || Dual Card Slot

Discussion in 'Portable Source Gear' started by xloud, Dec 8, 2016.
First
 
Back
948 949 950 951 952 953 954 955 956 957
959 960 961 962 963 964 965 966 967 968
Next
 
Last
  1. jkbuha
    Hi all - @FiiO have finally officially released v1.2.2 of their firmware. Download here: http://x5pack.fiio.net/1.2.1/X5-ota-1.2.2.zip and install using the traditional way via Tech Support

    My kernel works quite well on it (you'll need to re-install the kernel zip via TWRP), but Fidelizer's ROM doesn't (yet) allow upgrade to it - so if you're on his ROM you'll need to reflash 1.2.1 base and upgrade the normal way.

    @FiiO - as you've removed Viper4FX support, could you let us know if it's possible to now install third-party audio plugins ourselves?
     
  2. gazzington
    Has viper been taken off these. I was considering buying one because of the viper eq.
     
  3. takwing1hk
    this is what FIiO said:

    2. The agreement of cooperation between FiiO and ViPER's Audio has expired, so we're afraid that the new version of FiiO Music will no longer have the embedded ViPER Effect plugin. However, we've been working hard on the dynamic EQ and will try our best to develop more audio effects.
    If you have purchased the ViPER Effects and would like to continue using it, you may download the apk file of the old version, copy it to the player, and then install it through ES File Explorer (this will overwrite the new version). If you have any other questions, please kindly contact us (email: support@fiio.com, Facebook: FiiOAudio).
     
    jkbuha likes this.
  4. west0ne
    I wonder if you could just install V4A on a rooted X5 3rd Gen.
     
    jkbuha likes this.
  5. WitzyZed
    There is a thread on the FiiO forum that details just that http://www.fiio.me/forum.php?mod=viewthread&tid=41935&highlight=V4A

    But if you've already got TWRP installed on your player and just flash the SuperSU zip referenced around page 919-923 ? of this head-fi thread then you can skip anything involving kingroot.

    *Edit* I've not done this, so YMMV
     
    Last edited: Jan 29, 2019
    jkbuha likes this.
  6. jkbuha
    I had tried to install v4a the very first time I got the FiiO, in fact my first post on this forum was to that effect (pun unintended).

    However, whilst it installed successfully I never got v4a effects to work system wide. It comes down to how audio_policy and audio_effects in /system are set up.

    Now that FiiO have released the latest (final?) version without viper, that could have changed. If anyone who's got the vanilla version running could try and install it and report back...
     
  7. takwing1hk
    I have flashed the vanilla 1.2.1 firmware, then upgraded to 1.2.2 and played songs for an hour or os.
    Then I installed jkbuha's kernel and played songs for another hour.

    Everything works and I do not aware of any temperature difference after installing the kernel.
     
    jkbuha likes this.
  8. WitzyZed
    Currently formatting to 1.2.2, kernel isn't far off *taps fingers in anticipation*. So you'd say the crashing issues on the beta firmware are nixed? I don't mean the "pure music" vs "android mode" crashes. I was having constant crashes playing music in the FiiO music app from that one just in android mode. FiiO forum users were saying it was because of background threads working on the album artwork getting indexed or w/e.
     
  9. takwing1hk
    I do not encounter any crash on the musica app
     
  10. kakkun
    Yesterday, I updated the kernel to jkbuha's latest version (2.4, I think)
    I just got the 1.2.2 OTA today. When I go to install it through the Tech Support app, the device automatically reboots to TWRP and tries to flash it from there, but it fails.
    I've confirmed through the settings that my device is still on 1.2.1.

    Any ideas about what I could do? Also, I'm not too knowledgeable about customizing stuff on Android. Let me know if there's any info I've left out.
     
  11. spanner43
    this is exactly were i am at
     
  12. WitzyZed
    You need to perform a factory data reset (erase everything option checked, so do remove your storage just in case) then confirm that the kernel rolls back to non jkbuha. Then perform OTA install of 1.2.2. after that you can use the Android tool exe to reflash boot.img and TWRP recovery, do the same steps as before to install the 2.4 kernel zip in TWRP.
     
  13. battosai
    The X5iii cannot update itself if a custom recovery is installed like twrp. So reflash 1.2.1 using fiio's tool then update to 1.2.2 from the update option
     
    spanner43 and WitzyZed like this.
  14. WitzyZed
    Yes you are correct the recovery image is the issue ! I have had the fiio firmware tool (http://fiio-firmware.fiio.net/X5III Firmware Upgrade Tool with FW1.2.1.zip) come bundled with diagnostic apps on the 1.2.1 rom so do a factory data reset prior to OTA update once that stock 1.2.1 is installed. They have carried over into installs of newer ROMs in my experience.
     
  15. tyox86
    thanks for the respon,

    actually it is now solved with FW 1.2.2.

    this is what I do :
    1. I'm on fidelizer 1.2.1 with custom kernel 2.1
    2. Go back to stock recovery with AndroidTool (choose no. 3 only)
    3. Install update 1.2.2 via ota
    4. Install twrp+custom kernel 2.4 (follow page 956 instruction no. 1)
    5. done
     
First
 
Back
948 949 950 951 952 953 954 955 956 957
959 960 961 962 963 964 965 966 967 968
Next
 
Last

Share This Page