1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

DX220 A new view to your music. * Latest Firmware: 1.15.233 Local * Link for User Guide 1st Page. AMP9 Now available! And DC01.

Discussion in 'Portable Source Gear' started by Paul - iBasso, Jan 23, 2019.
First
 
Back
423 424 425 426 427 428 429 430 431 432
434 435 436 437 438 439 440 441 442 443
Next
 
Last
  1. fokta
    IMG-20190715-WA0011.jpg IMG-20190715-WA0010.jpg IMG-20190715-WA0009.jpg
    @ddmt

    He had a some...
     
    Whitigir likes this.
  2. alan_g
    good stuff
     
  3. Whitigir
    Thanks!, just pmed him ...hope he has one for me lol!
     
  4. aaf evo
    DX229 -> 1950s -> A18t ... this will make my incredibly long journey from Houston, TX to Singapore go by quicker :) time to get lost in the 81592370-D496-4EDD-B84D-DE195D50A6FF.jpeg music !
     
    ddmt, Whitigir and SteveOliver like this.
  5. arijitroy2
    Heard 1950s with A18T is a killer combo, how do you find them?
     
  6. aaf evo
    Incredible man, best cable I have experienced. Although it should be for the price! I have posted my thoughts I believe in the PW Audio thread.
     
  7. arijitroy2
    Nice!! Had my eyes on that cable, the price whoosh! Plus wanted a silver one.
     
  8. Jouho
    Hey guys, I'm having a problem with mine. I was listening to music at work and it just stopped. It's charged enough to turn on (maybe around 60%) but when I turn it on, the iBasso loading screen comes up but then it just says 'See You' and turns right back off.

    Please help :frowning2:
     
  9. SteveOliver
    First thing I would do is put it on charge, its possible you were enjoying the music so much you didn't notice the charge drop to zero percent.

    This is a major problem with great DAP's like the DX220.
     
  10. Jouho
    I don't think so, but I'll let it sit and charge. The charge screen is normal and I can click the power button to show the 'charging' icon in the center of the screen. But when I try to turn it on it just turns right back off - doesn't fully boot up.

    I hope it's not broken.
     
  11. twister6 Contributor
    I just received dx220 miter case. Will post more info later when I take some pictures.
     
    aaf evo and SteveOliver like this.
  12. SteveOliver
    So do I, its also worth removing the uSD card and powering it up. Also if you have swapped the Amp recently try reseating it, as a last resort perhaps even try powering it on without an amp.
     
  13. Jester0fTortuga
    Just trying to gauge listening levels. Folks with Amp9 and IT04, what’s your usual volume level (at high gain preferably)?
     
    KLJ1992 likes this.
  14. Jouho
    Super weird. I let it sit for a short bit (like... 8 minutes) then tried again and it came right back up. Charged to 71% or so then it jumped to 75%.

    No idea what happened - just glitched out and then corrected itself? Hopefully it's fine..
     
  15. ddmt
    Yeah I have 2 spare ones for my friends here in Indonesia. So sorry no more to sell. Unless you don't want yours @fokta ? :)
     
    Whitigir likes this.
First
 
Back
423 424 425 426 427 428 429 430 431 432
434 435 436 437 438 439 440 441 442 443
Next
 
Last

Share This Page