Chord Mojo issue solutions thread.

Discussion in 'Portable Source Gear' started by greenbow, Nov 25, 2015.
Tags:
  1. Superfrag
    Damn. It seems to be a common problem, which is troubling.
     
  2. miketlse
    I would hardly describe it as common - a handful of cases out of the 50,000+ Mojos sold.
     
  3. Superfrag
    I realise I worded that badly, I meant it's not a one time ultra rare problem that just happened to me, it seems be a rare recurring problem happening to a couple of people. Considering the Mojo is just two years old in the market, I have a feeling more people will have this problem in the coming years. Doesn't sound like it's a cheap repair either.
     
  4. x RELIC x Contributor
    The other person that posted needing the USB repair clearly stated that the USB was damaged by applying too much pressure while in a bag / backpack. Your issue seems different and I’m not sure that the conclusion is conclusive that the USB has been jostled from the board.

    Is your USB input physically moved from its factory position? It could also be that the Mojo USB input is dirty or one of the contacts in the USB input is broken, which might explain why it registers power but not data. Have you tried cleaning it with electrical cleaner like Deoxit?
     
  5. Superfrag
    Ah okay. I saw some posts earlier as well, (skimming through this thread). Anyway it’s the nature of electronics, failures are going to happen.

    I haven’t done anything to try and fix it, been busy with other things. I don’t have the tool needed to open this up and take a look, but tonight I plan to stop by the hardware store, get a can of compressed air (need one in general anyway) and the necessary tool.

    Also regarding your comment about registering power but not data, the Mojo has a separate MicroUSB input for charging and data. The input for charging works fine, the input for data does not seem to work at all.

    Chord has redirected me to http://www.georgemeyer-av.com/, and I’ve already sent an email to them, hopefully I’ll get a reply soon.
     
  6. miketlse
    It sounds like you are already on the path to finding the solution.
    After following this thread for two years, I know that @Mojo ideas will often go the extra mile to sort out user issues.
    So don't lose hope, and hopefully everything can get sorted out soon. :relaxed:
     
    Superfrag likes this.
  7. miketlse
    This potential ambiguity, is why a photograph could be useful evidence/context, before sending the mojo back to chord. :smiley:
     
  8. x RELIC x Contributor
    Yes, of course I know there is both a data and a power USB port. The data port also has a 5V power pin and this is what tells the Mojo to switch to USB priority input, which your Mojo does when the data USB input overrides the optical input (you can read the quote from the designer below).


    Anyway, glad you’re on your way to getting it fixed.
     
    Last edited: Nov 9, 2017
  9. Superfrag
    Ah, I understand you now. So the Mojo actually detects the USB cord being plugged in, since the sound from the optical input gets cut off as soon as I plug the cable in the data port.

    Makes the problem even more weird.. it’s able to detect a cable being plugged in, but the MBP doesn’t detect the Mojo, and the Mojo power ball goes off as well (volume balls stay lit up)
     
  10. x RELIC x Contributor
    Yes, it could be a simple thing like hair or lint that is interfering with the data pins which is why it overrides the optical input but doesn’t play / transmit data. Cleaning the input is the first step and much quicker than sending it out is one suggestion, and you’d be surprised how often it happens. Worth a shot.

    :)
     
    Last edited: Nov 9, 2017
  11. lukedss
    I am on to my third now, each of them the connection failed. Three in 2 years. I am probably going to get the ha-2 instead. The portability inconvenience and the reliability is just not worth it
     
  12. miketlse
    Beware if you are an iPhone user - the ha-2 was iPhone compatible, but one of the OS
    10 updates stopped the MFI compatability working. I have seen no mention of whether this bug was ever cured.
     
  13. Signo
    Mojo is a great product.....when it works. I'm on my 2nd Mojo which has just failed (only just out of warranty) and when I called Chord they told me they wanted another £200 to fix it. The worst thing is, I'm English and live in Kent where Mojo is made and I was kind of proud to tell people that when they asked about my Mojo - now I'm not so keen.
     
    Last edited: Nov 10, 2017
  14. adamsmarbles
    After changing my ways ie using mojo less turning it off more, i forgot to put the power connection on, and the battery died in 1 hour!

    This is the worse designed dac on earth!!!!!!!!

    If i was Chord I would create an upgrade program for Mojo 1 allowing them to operate without the battery, or in addition too!

    Will they. NO

    A company that doesnt care about its products or service, is no company worth a damn.

    I regret purchasing this, and am ashamed i was duped into it.
     
    Last edited: Nov 10, 2017
  15. MBit
    I found this quote while looking for some thoughts on battery drainage. Can somebody point me in the direction of said discussion? I tried the search but no success so far...

    I am a bit disappointed by the Mojo's battery life. It needs to be measured yet but my estimate is around 4-5 hours. That's about half of what other people get out of it. I use the Mojo with Sony MDR-1A headphones, they have an impedance of 48. Listening level is mostly between "red" and "yellow". Sources are mostly FiiO X3II (via coax) or Google Chormecast Audio (via optical).

    Any thoughts would be greatly appreciated! Thanks!
     

Share This Page