Chord Mojo issue solutions thread.

Discussion in 'Portable Source Gear' started by greenbow, Nov 25, 2015.
Tags:
  1. swesko
    so is the noise floor present on USB out only or is it dependant of IEMs you use?i have an old vinyl like background noise on all the tracks i play be it on tidal or my local flac library. I'm using my S8 USB out to mojo with Westone w60
     
  2. mathi8vadhanan
    This is from KaiserTone. https://www.cyberfort.jp/for-iPhone/eng/kaisertone.html
    Onkyo HF is also crowd favorite.
     
  3. sharagan13
    Hi guys,

    Could you please check, if this behaviour is to be seen on your Mojos as well? Thanks, just want to make sure, that this is not an issue of this particular device.
     
  4. jsbisquert
    Hello all,

    I bought my Mojo about one year ago but I haven´t enjoyed it because I have a big issue. I used it with my mobile OnePlus 3t and the APP is USB Audio Player Pro. My problem is the APP cut off every now and then. I have never listen more than 15 minute in a row. It is annoying. I have downloaded another APP, Onkyo with same results.
    I have been told it could be an android problem something related to the kernel. I have no idea.

    I think the problem could be the cable. I bought the cable box by Chord for the Mojo but this box doesn´t contains the wire I need. My mobile has a USB 2.0 c port. I have looked fro a good cable to connect it but I can´t find it, I bought a cheap adaptor. What cable do you use to connect the Mojo to your new mobile?

    I haven´t connect it to my computer because I use it as portable but I would like toe check it with Windows 10. which software do you use to listen hi resolution music?


    Any advice will be very welcome because I am desperate to enjoy this great sound.
     
  5. miketlse
    A lot depends if you want a cheap or expensive cable.
    I use the 30cm version of this cable http://forzaaudioworks.com/en/product.php?id_product=98 . I can't fault it, but some posters baulk at the idea of paying more than $5 on ebay.

    There is also this cable produced by Shanling. https://www.head-fi.org/threads/sha...th-4-0-aptx-dsd.816385/page-197#post-13754758
     
    Last edited: Oct 25, 2017
  6. Superfrag
    My Chord Mojo stopped working using the micro USB input. The MBP does not detect it at all. It still works with the PS4 using an optical cable. I tried multiple cables. The same cables successfully charge the Mojo.

    Has this happened to anyone else? Is there a way for me to fix this, or will I have to get it repaired?
     
  7. janchadley
    It's probably a repair. I had this happen to my ifi idsd bl, as well. Sent it in to ifi, they fixed it and sent it back in about 10 days. Since the repair, the usb connection is much more solid and consistent. USB devices are not really designed for use with a portable amp that well yet. I've had issues, quirks or and/or intermittent issues with usb connections in my audio rig on multiple devices over the last few years. But, when it works, its worth it.

    I recommend that you contact Chord to set up a repair case.
     
  8. Superfrag
    Damn, I was hoping that's not the case.. oh well. Let's see what Chord says. Sucks that it's out of warranty.
     
  9. janchadley
    Did you try it with other devices yet? Sometimes its the dap that has the usb fussiness. For example, when I had the Pioneer XDP-100R, I would have to click "ok" to switch to usb mode every time I plugged the dac/amp in. Additionally, it would only play files on the device through the usb but not play streaming audio from google play or Tidal. However, when i used the 3.5mm out, both onboard files and streaming worked. I know that the Mojo does not have a 3.5mm input, which sucks, but these are just examples of how fussy usb be can be on both ends of the portable audio chain.
     
  10. Superfrag
    I haven't tried USB input with other devices, mainly cause I don't have any other device other than my MBP to use with the Mojo. Like I mentioned initially, the USB input port seems to be the problem, since optical input works just fine with the PS4, charging works fine with the same micro USB cables.
     
  11. miketlse
    There are occasional reports of this issue, sometimes caused by usb plugs or adapters causing the socket to come away from the circuit board. I think the most recent case required a return via the dealer, and Chord replaced the circuit board. Best option is to first PM @Matt Bartlett and let him propose the best way forward.
     
  12. Superfrag
    Another weird thing I noticed, the sound from the PS4 via optical input actually gets cut off when I plug the microUSB cable in. Even though the input does not work, the Macbook does not recognise the Mojo, the Mojo knows that the microUSB input port is being used. (Mojo doesn't have an input selector, instead it gives preference to USB first, then the other two)
     
  13. Superfrag
    I assume opening the Mojo up and seeing if I can fix it myself isn’t advisable? (Warranty has expired)
     
  14. miketlse
    You can open it up if you want, then post a picture on the main mojo thread. The last person with a socket problem posted a picture, and it was clear that the socket had pulled away from the circuit board, with quite a bit of force (probably 3 or 4 months ago). You may be luckier with your problem.
     
    Superfrag likes this.
  15. DrumSeb
    I got the same problem a few months ago. Lucky me it was under warranty.. They have to replace the board, it took over 3 weeks to replace it.
     

Share This Page