Audio-gd USB-32 Firmware, Drivers, and Feedback Thread

Discussion in 'Computer Audio' started by petercraig, Nov 26, 2012.
Tags:
  1. desik
    Hi guys, don't know if this was discussed before.
     
    I have an Audio-GD DI2014, Win7. I cannot change the digital volume from Windows. Asked Kingwa, he said that volume change firmware was old and they didn't keep it. This sound strange to me. How can Windows volume have anything to do with firmware? The bigger problem is that now I cannot use system-wide EQ like Equalizer APO either. Without it LCD-X are completely not fun.
     
    Was anyone able to make digital volume work?
     
  2. desik
    Hi, I have the same issue. Did you find a solution?
     
    The bigger problem is that global EQ software like EqualizerAPO also doesn't work. I spent some days equalizing my LCD-X and it sounds so much better. Would be silly to give up DI2014 because of this.
     
    I also tried to use a virtual sound card software, like VB-CABLE to cheat the driver. Same result. If I change volume from windows there's no effect.
     
  3. norrest
    I dont like windows! 
    With linux and mpd sound better! 
    DIY
    So are have some one new firmware? !!
     
  4. Doomed
    Hey today arrived my audio-gd nfb-11 but i got issues with driver instal on windows 10, it says instal driver fail, error code: 0x0, 0x0 i googled a little bit and it looks like i should have disable driver signature enforcement, i think i have done it but it still fails to instal drivers on my win 10, any1 got suggestion? i got 2014 version of nfb-11 i think.
     
  5. Mahdi8
    Skip the via installer if you still have that extract the driver and manually select the driver from device manager
     
  6. Alucard-
    Well I have a nfb-10es2 from 2013 I bought second hand. Drivers were always a pain to install but I manually force installed it on my old z68 motherboard on win 7 64bit, and it was fine after for years, besides the odd power cycle. Last year I upgraded to Skylake with a new Gigabyte z170x gaming 5 board, it's suppose to have a special usb dac port. It always pissed me off I could never get it to work over usb properly. It would play a bit and stop or freeze or blue screen.

    I tried the other Audiotrak Dr DAC 3 compatible drivers, worked a bit better but still couldn't consistently play a whole song in foobar without crapping out. So I ended giving up and settling for optical out from my onboard for a year since it just worked. I thought it may have been due to my 2600k to 6700k old windows 7 system swap without reinstalling but I was wrong. I flash the DACv2 firmware and installed the latest 2014V3 drivers without issue. Everything seems to be working good now. I should have flashed the firmware earlier, but I blamed my 2011 win 7 install.

    It sounds alot cleaner and detailed now. Maybe the special dac usb port helped too. I was getting tempted to get the NFB-28.38 for the 9038pro. Thanks for uploading the firmware.
     
  7. svfoo123
     
  8. svfoo123
    I have a NFB 28 and windows will not install the driver. I have tried manually installing it and it does not work. When I try to update the firmware the NFB does not show up to update. Has anyone else has similar issues? I have contacted KINGWA about sending the unit back to China.
     
  9. KneelJung
    I'm having trouble installing nfb 15 drivers on a new computer. Emailed Kingwa prior to purchase with SN#, and he told me to use drivers for units shipped between 26 May and 14 August 2014 (2014 V3).
    Keep getting error message. Spent a good amount of time with Acer tech yesterday, and he told me it was a software issue with Microsoft. Spent about an hour with Microsoft tech,and he couldn't resolve issue either. Scheduled a call back for today with a higher level tech. Tech did call, but decided he needed to do some research. Still hasn't called back. Anyway tried installing drivers again on my own with unit unconnected. Didn't get error message, but it wouldn't let me click finish. Said drivers connected successfully, but just got that little circle spinning, and spinning, and spinning. Waiting for a response from Kingwa too.
     
  10. KneelJung
    I cant get drivers for NFB 15 to install on new computer. Going from Windows 7 on a Compaq to Windows 10 on an Acer. Successfully downloaded the drivers twice on the Compaq. Once when I received the NFB 15 new, and once when I had to reset the Compaq back to factory. Not sure what the issues are now. Anyway as I stated in the post above emailed Kingwa prior to purchase, and he emailed back with drivers to use based on serial number of unit. Clicking through the wizard gets me to a point where a box pops up attempting to initialize, then another box pops up that says installed components none...failed to install components. clicking next from that box gets me to the finish screen that has a note that says:

    One of components aren't installed successfully to system. Check Log File.

    I have no idea where log file is or what I'm looking for. Anyone have any suggestions.
     
  11. Errymoose
    Hi guys.

    I have a NFB-1 purchased in June 2014. I was using it on optical, but I want to install the USB drivers.
    I downloaded the original package they sent me and the drivers report that it has installed, the devices is listed in windows as 'SPDIF Interface' and when it is the active device, no sound at all.

    No idea what's gone wrong. Fantastic dac, just really wish they could sort out drivers so i didn't have to spend hours on this...


    EDIT: I can hear the power supply click as I start playing sound and it gets a signal, but there's nothing coming out. Definitely seems like not a cable/device issue. Just shoddy drivers...
     
    Last edited: Nov 3, 2017
  12. McNubbins
    I just installed the Windows 10 Fall Creators Update... Can you see where this is going?

    My NFB-1 (2014 edition using VIA USB interface) wasn't recognized at first. Then after a reboot Windows saw it again, but it didn't work. It would only output a soft static hiss.

    Tried to tell Windows to reinstall the VIA USB driver and that didn't seem to work, because it thought it had the best driver already installed.

    I went into Device Manager, manually uninstalled the audio-gd device and rebooted with the DAC off. When Windows was fully loaded, I turned on the DAC and it was recognized perfectly, as if nothing ever happened.

    So yeah, it's the ol' turn-it-off-and-on-again.

    Just like my brother in frustration Errymoose, I love the DAC but I'm really disappointed with how it seems to interact with Windows. Honestly, I'm inclined to blame Microsoft more than Audio-gd when I hear about driverless Linux and Mac solutions just working properly without a fuss.

    Out of curiosity (I'm not in the market for another DAC), is anybody using an Amanero-equipped Audio-gd DAC that has experience with the old VIA solution? I'm curious to hear if Windows plays any nicer with it.
     

Share This Page