1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

New desktop USB DAC&AMP - FiiO K3 (E30),384K/32b,DSD DOP,typeC

Discussion in 'Computer Audio' started by demond, Jul 3, 2018.
First
 
Back
4 5 6 7 8 9 10 11 12 13
  1. wigglepuff
    sorry double post.
     
    Last edited: Apr 11, 2019
  2. wigglepuff
    changing the panel options to Visible doesn't do anything for me, its still blank except for the status which shows no usb device detected, its like the fiio driver cant detect my unit even in usb 1 mode. The clicking and popping is very audible and extremely annoying.

    I already tried everything written on the installation instructions on fiio website for windows 7, nothing works.

    people planning to buy the k3 beware this thing has some serious problems like the topping dx3 pro. no point having a nice hardware that wont work because of stupid firmware and drivers.
     
    Last edited: Apr 11, 2019
  3. harryyeo
    As a noob to IEMs, I'm loving the K3 on my Win 7 with F9 Pro so far. :ksc75smile:
     
    Last edited: Apr 12, 2019
    crabdog likes this.
  4. Brooko Contributor
    I'd suggest seeing if you can test some more. My K3 works with both a Win7 (older) and Win 10 (newer) machine. 1.1 works out of the box. Installing the 4.47 USB driver was flawless. Once installed, switch to USB 2, replug, instantly recognised. No issues here with either machine.

    Suspect your issue could be the K3, or maybe even somthing to do with your PC/laptop issue.
     
  5. ObjectVoice
    [ I'm crazy about Fiio stuff in general but I have to say that so far I'm regretting upgrading to the K3 from the E10k. The E10k just worked perfectly all the time and I never had to think about it beyond admiring the sound quality it gave me. The K3 seems to be a constant headache with Windows 10 to the point where - and this is no real hardship, of course - I'm using my Q5 as a desktop DAC instead of the K3 because the Q5 just works. The K3 constantly seems to be reporting driver issues via red LED or not getting noticed by the PC at all. Continually having to return to it, replug it, try different USB ports etc is leading to me wishing I hadn't sold the E10k so quickly. ]

    Actually, scratch this. I need to go back and read the manual and understand how the thing is supposed to function before I start saying it's not working. I had it totally wrong about the function of the red led for a start.
     
    Last edited: Apr 15, 2019
  6. DarKu
    I'm listening for K3 on Windows 10 for more than a month and didn't had any issues you are experiencing.

    I actually just posted my detailed K3 review
    I compared it also to the E10K that I have besides me as well.
    All in all K3 is a clear upgrade to E10K especially if balanced out is being used.
     
  7. MariusAB
    Using k3 with windows10 long time 3 months and didn't had any of your problem. Just plugged, installed drivers and that's all. Nothing to do more. So possibly your unit is faulty
     
First
 
Back
4 5 6 7 8 9 10 11 12 13

Share This Page