Monoprice Monolith Liquid Spark - By Alex Cavalli
post-14921396
Post #331 of 450

PlantsmanTX

500+ Head-Fier
Joined
Jan 18, 2013
Messages
524
Reaction score
539
Location
Texas
Joined
Jan 18, 2013
Location
Texas
Posts
524
Likes
539
This was mainly what my issue was with various headphones/cables:



Mainly sound slightly distorted and being cut out, like you get with bad connection, or broken input jacks. I'm not sure I was experiencing "severe distortion" though, so the return may have been warranted.

Are you getting a replacement?
The distortion I experienced was something like a really bad PA system, and then some, LOL. Yes, I'm getting a replacement.
 
     Share This Post       
post-14938492
Post #332 of 450

superfrognyc

100+ Head-Fier
Joined
Jun 27, 2011
Messages
218
Reaction score
23
Joined
Jun 27, 2011
Posts
218
Likes
23
I bought both Monoprice Cavalli units the Liquid Spark and Liquid Platinum, they both sound wonderful that "Cavalli" sound is very addictive!
Sadly after a couple of days, I started to have multiple problems with the Liquid Spark intermittently I have sometime mono sound, some noise/static with some files, and the unit just goes off and back on a few time. I have returned the unit to Amazon and I hope the new one will be trouble free.
As for the Platinum, I just experienced sparks when I connected the power adapter to the unit I sincerely hope this is nothing :expressionless: I going to read more about this on Head-fi forum and see if there cause for concern.

So far the sound of both units is fabulous but the manufacturing from Monoprice might be a problem, we shall see.
 
     Share This Post       
  • Like
Reactions: PlantsmanTX
post-14938494
Post #333 of 450

Rattle

100+ Head-Fier
Joined
Nov 29, 2007
Messages
424
Reaction score
196
Location
NH
Joined
Nov 29, 2007
Location
NH
Posts
424
Likes
196
I bought both Monoprice Cavalli units the Liquid Spark and Liquid Platinum, they both sound wonderful that "Cavalli" sound is very addictive!
Sadly after a couple of days, I started to have multiple problems with the Liquid Spark intermittently I have sometime mono sound, some noise/static with some files, and the unit just goes off and back on a few time. I have returned the unit to Amazon and I hope the new one will be trouble free.
As for the Platinum, I just experienced sparks when I connected the power adapter to the unit I sincerely hope this is nothing :expressionless: I going to read more about this on Head-fi forum and see if there cause for concern.

So far the sound of both units is fabulous but the manufacturing from Monoprice might be a problem, we shall see.
Did you have the smps plugged in when you plugged the amp end into the amp ? Always make sure there's no power going through an smps when you plug it into the amp.
 
     Share This Post       
  • Like
Reactions: PlantsmanTX
post-14938517
Post #334 of 450

superfrognyc

100+ Head-Fier
Joined
Jun 27, 2011
Messages
218
Reaction score
23
Joined
Jun 27, 2011
Posts
218
Likes
23
Did you have the smps plugged in when you plugged the amp end into the amp ? Always make sure there's no power going through an smps when you plug it into the amp.
I'm not sure, but I might have done exactly that :frowning2:
From now on I will make sure the smps is not plugged to the wall before I connect it to the Platinum.
Thanks!
 
     Share This Post       
post-14938520
Post #335 of 450

Rattle

100+ Head-Fier
Joined
Nov 29, 2007
Messages
424
Reaction score
196
Location
NH
Joined
Nov 29, 2007
Location
NH
Posts
424
Likes
196
I'm not sure, but I might have done exactly that :frowning2:
From now on I will make sure the smps is not plugged to the wall before I connect it to the Platinum.
Thanks!
Your welcome, hope it's ok sorry if it's not. Browse this thread @runeight and @atomicbob have posted extensively on the do's and don'ts of the amp. Particularly when it comes to power and LPS situations.
 
     Share This Post       
post-14941719
Post #337 of 450

GearMe

Headphoneus Supremus
Joined
Feb 17, 2013
Messages
3,214
Reaction score
2,059
Joined
Feb 17, 2013
Posts
3,214
Likes
2,059
Hadn't really tried iems on this amp.

Listened to several different pairs -- UE900s, IE80, RHA-t20, 1More Triple, Sony XB90EX, Havi B3 Pro 1, Shure SE215, Nuforce Primo 8, Fiio EX-1, TFZ S2, etc...works very well with a variety of them from dynamic to hybrid to multi-BA.

Quite pleased with this little amp!
 
     Share This Post       
post-14942097
Post #338 of 450

superfrognyc

100+ Head-Fier
Joined
Jun 27, 2011
Messages
218
Reaction score
23
Joined
Jun 27, 2011
Posts
218
Likes
23
Hadn't really tried iems on this amp.

Listened to several different pairs -- UE900s, IE80, RHA-t20, 1More Triple, Sony XB90EX, Havi B3 Pro 1, Shure SE215, Nuforce Primo 8, Fiio EX-1, TFZ S2, etc...works very well with a variety of them from dynamic to hybrid to multi-BA.

Quite pleased with this little amp!
I like it too the new unit is on its way hopefully I won't have any problem with this one I really want to keep the Spark as my "portable" unit!
 
     Share This Post       
post-14946939
Post #339 of 450

Sgt. Ear Ache

100+ Head-Fier
Joined
Apr 28, 2018
Messages
347
Reaction score
230
Location
canada
Joined
Apr 28, 2018
Location
canada
Posts
347
Likes
230
Just pulled the plug on a Spark. Ordered from Amazon.ca for $165cdn all in. I had been looking at the Magni3 as well but it was going to cost me more than $200cdn. I plan to use my Fiio E10k as the dac in my little chain and I'll be driving my 400i's with it. I think the 400i's sound fantastic just from the E10k, but $165 canadian dollars is a small enough hit for me to check out what some real amping might do for them...
 
     Share This Post       
  • Like
Reactions: PlantsmanTX
post-14947266
Post #340 of 450

superfrognyc

100+ Head-Fier
Joined
Jun 27, 2011
Messages
218
Reaction score
23
Joined
Jun 27, 2011
Posts
218
Likes
23
Just pulled the plug on a Spark. Ordered from Amazon.ca for $165cdn all in. I had been looking at the Magni3 as well but it was going to cost me more than $200cdn. I plan to use my Fiio E10k as the dac in my little chain and I'll be driving my 400i's with it. I think the 400i's sound fantastic just from the E10k, but $165 canadian dollars is a small enough hit for me to check out what some real amping might do for them...
I had the 400i for a couple of days, loved the look and feel of the unit and the sound was clear and dynamic but too cold and sterile for me (not to mention it was fatiguing after a while)
 
     Share This Post       
post-14947399
Post #341 of 450

Sgt. Ear Ache

100+ Head-Fier
Joined
Apr 28, 2018
Messages
347
Reaction score
230
Location
canada
Joined
Apr 28, 2018
Location
canada
Posts
347
Likes
230
I had the 400i for a couple of days, loved the look and feel of the unit and the sound was clear and dynamic but too cold and sterile for me (not to mention it was fatiguing after a while)
I don’t find them to be any of cold, sterile or fatiguing at all. They sound amazing afaic. But, to each his own! Lol...
 
     Share This Post       
post-14947429
Post #342 of 450

superfrognyc

100+ Head-Fier
Joined
Jun 27, 2011
Messages
218
Reaction score
23
Joined
Jun 27, 2011
Posts
218
Likes
23
Using Elex and LCD-X I found the 400i to be very revealing and powerful but at the end of the day, I still prefer the more mellow/darker sound from the Cavalli units (Spark and Platinum).
To each his own indeed! :)
 
     Share This Post       
post-14947456
Post #343 of 450

Sgt. Ear Ache

100+ Head-Fier
Joined
Apr 28, 2018
Messages
347
Reaction score
230
Location
canada
Joined
Apr 28, 2018
Location
canada
Posts
347
Likes
230
Using Elex and LCD-X I found the 400i to be very revealing and powerful but at the end of the day, I still prefer the more mellow/darker sound from the Cavalli units (Spark and Platinum).
To each his own indeed! :)
Oh sorry, I'm talking about the HE-400i headphones...
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top