iFi audio iDSD Signature - The saga continues!
Dec 26, 2020 at 2:45 AM Post #872 of 1,382

bflat

Headphoneus Supremus
Joined
Feb 19, 2015
Posts
3,174
Likes
1,624
Location
San Francisco
I’ve found two things - not only does it require another usb-c cable to charge but it also should be disconnected from a computer to prevent discharge even when it is off.

Really not a huge fan of how this was done.

I tried to reproduce your issue with discharge.My iDSD Sig is connected to my MacBook Pro and USB C charge port to an iFi iPower 5V power supply. I turned the iDSD Sig off for 24 hours and did not experience the discharge you described. In fact, I've only used the iDSD Sig as a desktop DAC since I got it. I do keep it powered on most of the day and turn off at night and have had no power issues at all.

Also, I had reported earlier that I was getting disruptions when connected to an iFi iGalvanic. This was during DSD playback and I didn't have my Audirvana player on exclusive access so when my MacBook produced a system sound, it caused the disruption since iDSD can't switch back to PCM quickly enough while playing DSD. However, after getting that fixed, the sound I get with iGalvanic is noticeable sharpness in the highs and mids sound a little thinner too. This is with the GTO filter. Definitely didn't like what I heard so went back to straight connection to my MacBook.
 
Last edited:
Dec 26, 2020 at 5:31 AM Post #873 of 1,382

utdeep

Headphoneus Supremus
Joined
Oct 15, 2001
Posts
1,558
Likes
155
Unplug the USB-C charge port. Even when off, my power is slowly is draining from the ifi Signature. If you have the USB-C port connected, then you are still charging the Signature.
 
Dec 26, 2020 at 12:19 PM Post #875 of 1,382

bflat

Headphoneus Supremus
Joined
Feb 19, 2015
Posts
3,174
Likes
1,624
Location
San Francisco
Unplug the USB-C charge port. Even when off, my power is slowly is draining from the ifi Signature. If you have the USB-C port connected, then you are still charging the Signature.

What was the battery level when you turned off and how long did you you leave it off? I don't think having the iDSD connected to your PC has any effect. I believe you are dealing with battery discharge when not in use. If it is pretty rapid discharge then I think you may have a defective battery. If it's something like 10% discharge over a week, then that could be normal. Really depends on the quality of the battery. I've stopped buying cheap Chinese knockoff batteries for smartphones as they tend to drain much faster than OEM both in use and idle.

If you are comparing this to the prior iDSD, it's not an apples to apples comparison since the prior design would keep charging as long as the USB port provided power. A lot of current desktop and laptop PC's keep providing USB power even when turned off. Since the new Signature design does not have power enabled on the USB port, I don't see how power is somehow flowing out of the iDSD to the PC.
 
Dec 26, 2020 at 3:15 PM Post #876 of 1,382

Sebastien Chiu

Previously known as Drunkenmunkey
Sponsor: iFi audio
Joined
Apr 24, 2016
Posts
1,478
Likes
1,402
Location
Colorado
Unplug the USB-C charge port. Even when off, my power is slowly is draining from the ifi Signature. If you have the USB-C port connected, then you are still charging the Signature.

That isn't normal. The Signature should not be draining power when it isn't being used.

Please open a support ticket and we'll get you sorted: https://support.ifi-audio.com/open.php
 
iFi audio Stay updated on iFi audio at their sponsor profile on Head-Fi.
 
https://www.facebook.com/iFiAudio/ https://twitter.com/ifiaudio https://www.instagram.com/ifiaudio/ https://ifi-audio.com/ info@ifi-audio.com
Dec 26, 2020 at 3:17 PM Post #877 of 1,382

Sebastien Chiu

Previously known as Drunkenmunkey
Sponsor: iFi audio
Joined
Apr 24, 2016
Posts
1,478
Likes
1,402
Location
Colorado
I am amazed at how many people keep asking or thinking this will charge from the input. It is seemingly the most answered question.

Thank you guys for helping the community out!

For all your information, the iFi team went on Christmas Break starting this week. We'll be trickling back into office (and working from wherever we are) starting the 4th and be up and running by the 9th.

Apologies for the slow response time until then, hope you all are enjoying the holiday season with your family and friends!
 
iFi audio Stay updated on iFi audio at their sponsor profile on Head-Fi.
 
https://www.facebook.com/iFiAudio/ https://twitter.com/ifiaudio https://www.instagram.com/ifiaudio/ https://ifi-audio.com/ info@ifi-audio.com
Dec 28, 2020 at 12:10 PM Post #878 of 1,382

qsk78

Headphoneus Supremus
Joined
Nov 30, 2013
Posts
1,547
Likes
525
Location
Russia
Santa is right on time...)
DSC_0301.jpg
 
Dec 28, 2020 at 3:01 PM Post #879 of 1,382

utdeep

Headphoneus Supremus
Joined
Oct 15, 2001
Posts
1,558
Likes
155
Dec 29, 2020 at 11:49 AM Post #880 of 1,382

aspirina750

Head-Fier
Joined
Feb 25, 2020
Posts
70
Likes
32
Location
Barcelona
Ok, this is driving me nuts... I somehow managed to discharge the whole battery but it takes quite some time for the unit to be ready to be used after plugging it in. I'm kinda used to be able to plug it in and continue to play... I might have to leave it plugged in and damn the battery life...

Edit 1: 10 min and still wont turn on
Edit 2: 20 min and nada
Edit 3: Finally 27 min!
 
Last edited:
Dec 29, 2020 at 12:45 PM Post #881 of 1,382

utdeep

Headphoneus Supremus
Joined
Oct 15, 2001
Posts
1,558
Likes
155
Same experience. It could easily have gotten all the power from newer USB-C standards if it was designed with power delivery. It’s a good thing this sounds great because the use of USB-C here is a gimmick compared to more modern devices.
 
Dec 29, 2020 at 2:58 PM Post #882 of 1,382

bflat

Headphoneus Supremus
Joined
Feb 19, 2015
Posts
3,174
Likes
1,624
Location
San Francisco
Ok, this is driving me nuts... I somehow managed to discharge the whole battery but it takes quite some time for the unit to be ready to be used after plugging it in. I'm kinda used to be able to plug it in and continue to play... I might have to leave it plugged in and damn the battery life...

Edit 1: 10 min and still wont turn on
Edit 2: 20 min and nada
Edit 3: Finally 27 min!

What is the power rating of your charger? From what you describe, it appears it's only 500 mA or lower. Per iDSD Signature spec, the USB-C charge port will take up to 1200 mA.
 
Dec 29, 2020 at 3:22 PM Post #883 of 1,382

pankar0

New Head-Fier
Joined
Feb 9, 2020
Posts
42
Likes
43
Location
Athens Greece
Hello guys I want to ask you if someone has the signature and the focal clear also.

I bought yesterday the signature and when I play in turbo gain the clear s after
12:30 o clock is clipping on the bassy tracks.
At the normal gain it's ok.

Is this ok..???
This happens because the extra power push the drivers to the limit..??
 
Dec 29, 2020 at 3:46 PM Post #884 of 1,382

bflat

Headphoneus Supremus
Joined
Feb 19, 2015
Posts
3,174
Likes
1,624
Location
San Francisco
Hello guys I want to ask you if someone has the signature and the focal clear also.

I bought yesterday the signature and when I play in turbo gain the clear s after
12:30 o clock is clipping on the bassy tracks.
At the normal gain it's ok.

Is this ok..???
This happens because the extra power push the drivers to the limit..??

At only 55 ohm input impedance, the clipping is likely the Focal Clear drivers bottoming out. There numerous posts on Focal headphone drivers clipping so you can ask in the Focal Clear forum. If 12:30 Turbo on Clear is >100 dB, then the clipping is normal since there is a built in limit on how much the drivers can move. If it's < 90 dB, then you may have defective drivers. If the clipping is on just one driver, then it's more likely a defect.
 
Dec 29, 2020 at 4:31 PM Post #885 of 1,382

Baten

Headphoneus Supremus
Joined
Sep 13, 2012
Posts
1,585
Likes
742
Hello guys I want to ask you if someone has the signature and the focal clear also.

I bought yesterday the signature and when I play in turbo gain the clear s after
12:30 o clock is clipping on the bassy tracks.
At the normal gain it's ok.
Check the iematch toggles, if it is on it will make the signature clip much much faster, only meant to be used with IEMs
 

Users who are viewing this thread

Top