Shure KSE1500 Review - Shure KSE1500 Sound Isolating Electrostatic Earphones
Nov 25, 2019 at 12:11 PM Post #4,756 of 6,059
It is more frequent than I originally thought. First red it on another forum that the KSA died on him. My KSA1200 amplifier start to behave similarly. Did the reset trick a few times but ultimately died too. I settled for a Kingsound M03 and was quite happy overall. A bit larger than the original Shure amp but found it better sounding on all aspects.

Interesting, this is the first I've heard of this. Does the KSE1500 plug directly into the M03 or do you need an adapter/customization?
 
Nov 26, 2019 at 12:45 AM Post #4,758 of 6,059
My kse 1200 amp died after ~6 months. The “hole” trick worked for some time but happened faster and faster.

The replacement works ok for 3 months, but also need to reset it couple of times.
So it seems to be a serious problem.
Do you usually charge by battery pack?
I think some battery packs are harmfull
 
Nov 26, 2019 at 4:13 AM Post #4,759 of 6,059
Don’t have a battery pack. I always charge from iphone’s original charger.

What I’ve meant by “happened faster and faster” is that it eventually died — had no choice but to replace.

And I don’t even listen to it that often: once or twice a week, max.

Most of the time I had to reset when listening on the go. And it happened only 5-7 times before it died.

Don’t think it’s widespread, though. I was the first case with such issue in Moscow service center.
 
Last edited:
Nov 26, 2019 at 5:12 AM Post #4,762 of 6,059
Don’t have a battery pack. I always charge from iphone’s original charger.

What I’ve meant by “happened faster and faster” is that it eventually died — had no choice but to replace.

And I don’t even listen to it that often: once or twice a week, max.

Most of the time I had to reset when listening on the go. And it happened only 5-7 times before it died.

Don’t think it’s widespread, though. I was the first case with such issue in Moscow service center.

My 1200 just start using since May this year.
While 1500 since 2015 w/o any trouble.
Also 1500 has no reset hole (what happen if turn on but couldn't)
 
Nov 29, 2019 at 9:59 AM Post #4,763 of 6,059
20191129_230747.jpg


By connecting both 3.5 and usb line, AB comparing is possible with the use of mode selecter at bottom of the amp.
This is not first time I do this. But result is the same any time I try.

Usb mode: the sound of internal dac (CS4272).
highest purity and speed. Bass is not extend so low but tight and well controll.
Highest cleaness of mid and highs.
A bit dry mid and overal imaging lack a bit of holographic/3D.


3.5 mode: the sound of sp1000.
There's sacrifice.
Less cleaness.
Bass less tighly controll but goes to lower notes. Bass texture not as good as. Low notes seems to be one note only.
A bit coloring, less dry and be smoother mid. Lack of macro detail.
More 3D imagine.
 
Dec 6, 2019 at 4:19 PM Post #4,764 of 6,059
:astonished:My KSE1500 has a new competitor as my GoTo Set-up : a ZMF Verite Closed with ZMF copper cable

And now that I have purchased the A&K SP1000 Amp module to add power to my A&K SP1000 SS to drive better the ZMF headphone, I also use this A&K SP1000 Amp module with my IEMs, since the Amp do not only add power, but also add refinement and sound stage to the A&K DAP.

...except when I use the SHURE KSE 1500 because, for some obscure reasons, the Sp1000 Amp click and distord a lot when connected to the SHURE’s amp !! ( impedance incompatibility ???
10391850.jpg
 
Last edited:
Dec 12, 2019 at 12:56 PM Post #4,768 of 6,059
greetings

Can anyone tell me the pinout of the KSE amp like in the picture?

Which one is L+ L- R+ R- and Bias

WhatsApp Image 2019-12-12 at 19.53.04.jpeg
 
Last edited:
Dec 12, 2019 at 3:36 PM Post #4,769 of 6,059
:astonished:My KSE1500 has a new competitor as my GoTo Set-up : a ZMF Verite Closed with ZMF copper cable

And now that I have purchased the A&K SP1000 Amp module to add power to my A&K SP1000 SS to drive better the ZMF headphone, I also use this A&K SP1000 Amp module with my IEMs, since the Amp do not only add power, but also add refinement and sound stage to the A&K DAP.

...except when I use the SHURE KSE 1500 because, for some obscure reasons, the Sp1000 Amp click and distord a lot when connected to the SHURE’s amp !! ( impedance incompatibility ???
10391850.jpg
Who made you the PL cable with Viablue connectors?
 
Dec 12, 2019 at 4:06 PM Post #4,770 of 6,059
Who made you the PL cable with Viablue connectors?

I purchased the cable with the ZMF Headphone. It is an optional copper cable from ZMF. 390 $ (350$ when purchased withthe headphone)
 

Users who are viewing this thread

Back
Top