LD2++ DOA (Dead on Arrival)
Dec 12, 2006 at 8:42 PM Thread Starter Post #1 of 14

penguindude

1000+ Head-Fier
Joined
Mar 28, 2006
Posts
1,475
Likes
11
I received mine today, opened it, plugged the tubes in, ready to listen and do a review, then BAM, i could not hear any sound.

Actually, i could, but it was so tiny that i can barely detect it. I do not know what's wrong it, im guessing the volume knob on the amp is dead cause the level of sound changes (decrease/increase) if i control it through my computer. Nonetheless, even on full high, the sound is barely detectable. The pre-amp, however, works fine.

I'm sorry guys, im afraid my Ld2++ review will have to be delayed until after Christmas.
frown.gif
 
Dec 12, 2006 at 8:46 PM Post #2 of 14

PYROphonez

Headphoneus Supremus
Joined
Mar 14, 2006
Posts
1,540
Likes
11
frown.gif

Sorry to hear about that. I actually just received mine about 30 minutes ago. I'm sure you'll enjoy it once you get it replaced.

Sorry about your misfortune. Maybe the next will sound better than the one originally sent to you for some magical reason.
biggrin.gif
 
Dec 12, 2006 at 8:56 PM Post #5 of 14

PYROphonez

Headphoneus Supremus
Joined
Mar 14, 2006
Posts
1,540
Likes
11
Quote:

Originally Posted by penguindude /img/forum/go_quote.gif
I think im actually the first one to have a LD product dead on arrival.
frown.gif


"My spirit has been broken."



Not true. Somebody mentioned having a destroyed LDIII(+?) sent to them. It could have been because of customs.
E-mail Dave if you haven't already. Hopefully you can clear this up quickly, and get back to enjoying music.
 
Dec 12, 2006 at 9:00 PM Post #6 of 14

rhymesgalore

500+ Head-Fier
Joined
Oct 5, 2005
Posts
841
Likes
10
I can soooooooooooooooo understand how you feel right now!

My record of things ordered arriving broken in the last weeks is something that makes me jump out of the window:

- I'm on my third(!) iPod right now, two before where defect upon arrival
- My new grafics card for my computer: chip defect
- Pearl Jam Poster of this years Grand Rapids Concert: Some nasty bends.

And this in two weeks.... makes you think......
frown.gif
 
Dec 12, 2006 at 9:02 PM Post #7 of 14

penguindude

1000+ Head-Fier
Joined
Mar 28, 2006
Posts
1,475
Likes
11
Quote:

Originally Posted by PYROphonez /img/forum/go_quote.gif
Not true. Somebody mentioned having a destroyed LDIII(+?) sent to them. It could have been because of customs.
E-mail Dave if you haven't already. Hopefully you can clear this up quickly, and get back to enjoying music.



No it shouldnt be the customs. I live in Canada and Canadian customs agents are fairly nice people.
biggrin.gif
But seriously, i dont think it's the customs cause the outside package doesnt look damaged at all and there's no tag saying "opened by customs." Everything looks fine from the outside of Ld2++. I already sent David a message, he hasnt gotten back to me yet.
 
Dec 13, 2006 at 1:07 AM Post #8 of 14

rain_uk

100+ Head-Fier
Joined
Nov 11, 2006
Posts
291
Likes
13
Location
United Kingdom
Just caught this thread....my heart felt sorrows to go out to you PD.
Hope this gets dealt with swiftly...a 'test for the current customer suport' in effect..
 
Dec 13, 2006 at 2:22 AM Post #9 of 14

sword_yang

Member of the Trade: Little Dot
Joined
Mar 25, 2005
Posts
35
Likes
11
Quote:

Originally Posted by penguindude /img/forum/go_quote.gif
I received mine today, opened it, plugged the tubes in, ready to listen and do a review, then BAM, i could not hear any sound.

Actually, i could, but it was so tiny that i can barely detect it. I do not know what's wrong it, im guessing the volume knob on the amp is dead cause the level of sound changes (decrease/increase) if i control it through my computer. Nonetheless, even on full high, the sound is barely detectable. The pre-amp, however, works fine.

I'm sorry guys, im afraid my Ld2++ review will have to be delayed until after Christmas.
frown.gif



The photograph delivered from you see, affirm is because the conveyance is bumped what shot cause. We will send a new of to you.
 
Dec 13, 2006 at 2:29 AM Post #10 of 14

penguindude

1000+ Head-Fier
Joined
Mar 28, 2006
Posts
1,475
Likes
11
It seems that the potentiometer (aka volume knob) is damaged during shipping. David and Mr. Yang have quickly replied to my inquiry and are ready to ship me a new one. However, due to my leave for vacation, I'd only be able to get to the amp after the new year. As a result, my review for the LD2++ will also be delayed until next year.

Sorry guys.
frown.gif
 
Dec 13, 2006 at 6:27 AM Post #11 of 14

kool bubba ice

Headphoneus Supremus
Joined
Jun 16, 2006
Posts
8,547
Likes
83
Quote:

Originally Posted by penguindude /img/forum/go_quote.gif
It seems that the potentiometer (aka volume knob) is damaged during shipping. David and Mr. Yang have quickly replied to my inquiry and are ready to ship me a new one. However, due to my leave for vacation, I'd only be able to get to the amp after the new year. As a result, my review for the LD2++ will also be delayed until next year.

Sorry guys.
frown.gif



Great CS!..
 
Dec 13, 2006 at 9:35 AM Post #13 of 14

feifan

1000+ Head-Fier
Joined
Sep 10, 2006
Posts
1,337
Likes
33
Quote:

Originally Posted by penguindude /img/forum/go_quote.gif
It seems that the potentiometer (aka volume knob) is damaged during shipping. David and Mr. Yang have quickly replied to my inquiry and are ready to ship me a new one. However, due to my leave for vacation, I'd only be able to get to the amp after the new year. As a result, my review for the LD2++ will also be delayed until next year.

Sorry guys.
frown.gif



Penguindude, s__t happens. Sorry to hear about the damaged potentiometer. Any indication that it was dropped? The padding that it comes in seems close to impervious to drops, but this may be a weak spot in the packaging. Don't sweat the review -- January's coming up really fast. Well worth the wait -- the amp and the review.
 
Dec 13, 2006 at 8:23 PM Post #14 of 14

pataburd

Headphoneus Supremus
Joined
Jul 1, 2003
Posts
6,345
Likes
824
Location
Rural New York State
Quote:

Originally Posted by penguindude /img/forum/go_quote.gif
I think im actually the first one to have a LD product dead on arrival.
frown.gif


"My spirit has been broken."



My Little Dot III+ arrived DOA. I returned it for a refund, bought instead the Darkvoice 336i--and never regretted that decision for a moment. Actually, my first Darkvoice arrived DOA, too. But the replacement was worth waiting for.
cool.gif
 

Users who are viewing this thread

Top