Problem with build quality Shure SE530/E500 ?
Dec 15, 2008 at 4:51 PM Thread Starter Post #1 of 4

DwD

New Head-Fier
Joined
Dec 11, 2008
Posts
6
Likes
0
Hi Guys.
First time poster, long time reader. =)
I have a question about the build quality of the shure se530(PTH),e500(PTH)
The first pair I had was the e500, and I had to return it because of the left earplug sounded less(volume ) than the right.
The second new pair (SE530) i received had a problem with the sound on the left(again) earplug.
The sound had distortion in the higher mids / upper frequency (like piano / vocal )
I have sent the 2nd pair in and are now receiving a new pair.
I absolutely love the sound of the se530, but this is my third pair, is there a problem with the build quality on the shure IEM ?.
(I have used them without the PTH plug so it isn’t a problem there and tried different sources.)
 
Dec 15, 2008 at 5:17 PM Post #2 of 4

ClieOS

IEM Reviewer Extraordinaire
Joined
May 11, 2004
Posts
19,991
Likes
9,345
Location
Mid Johor, Malaysia
I received a lemon at first (faulty connector) and exchanged it. Never have any other problem since then.
 
Dec 15, 2008 at 5:18 PM Post #3 of 4

darkninja67

Headphoneus Supremus
Joined
Apr 15, 2005
Posts
3,252
Likes
14
my SE530s have been issue free so far. I think the big "defect" with the Shures is that the cable has issues of cracking and stuff like that.
 
Dec 15, 2008 at 9:10 PM Post #4 of 4

DwD

New Head-Fier
Joined
Dec 11, 2008
Posts
6
Likes
0
well i have been really really careful with the e500/se530, always in the box etc. if this pair is working then its a keeper , but if its not i will change to another brand.
i am just hoping that they don't brake before the warranty goes out.
they should last a couple of years?
 

Users who are viewing this thread

Top