1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Noob Question about Fiio E10

Discussion in 'Headphone Amps (full-size)' started by luniar123, Dec 19, 2011.
Tags:
  1. Luniar123
    Hey all - Just signed up to the forums. I'm not sure if this is the right place to ask for help regarding this, so if I am wrong I apologize.
     
    I recently bought my first pair of audiophile-quality headphones (sennheiser hd 598's), and was under the impression that a DAC/amp would help to boost the sound level and quality.
     
    The included instructions seem to indicate that the included usb cable is all that is required to set up the amp/DAC - but once plugged in, no windows popped up like it said it would (Fiio E10 shows up in device manager though).  Also, I can barely hear any sound through my 598's with just the usb plugged in.
     
    I tried plugging the amp from "line out" into both the audio in and out ports as well, and audio does play, but there is a very noticeable hiss that detracts heavily from the sound.
     
    Is USB the only thing supposed to be connected, and there is something I am doing wrong? Or is another cable supposed to be used?
     
    Thanks in advance for the help!
     
    PS. I understand this is a very novice question - Please do not laugh at me [​IMG]
     
    PPS. I am running on an imac 2010 edition with bootcamp.
     
  2. chicolom
    USB is all that connects to the computer.  Headphones connect to headphone plug on the amp.
     
    I don't have a Mac, but you may need to make sure the E10 is set as the playback device and the levels are turned up (in system preferences).
     

Share This Page