iBasso DX300 Qualcomm Snapdragon 660 Octa-core 6GB RAM 128GB ROM NEW Firmware 2/6/2021
Mar 3, 2021 at 9:21 AM Post #4,606 of 5,841

JamesKH

Head-Fier
Joined
Jan 17, 2016
Posts
69
Likes
44
Tried listening to this DAP at a store today with a pair of Sennheiser HD800S, using Youtube since the store's music they had on micro SD was generic test music. No sound would come out at all. If I randomly moved the volume up and down it'd suddenly kick in for a second before disappearing again.

Is this a known issue with this DAP, is it a Youtube issue, or something else? The Youtube video was also constantly stalling them speeding up, though this could be due to a bad Wifi connection, no way of knowing since I couldn't listen :/

FWIW, this was my second time testing this DAP and previously I was using several high-end headphones with zero issue using Youtube, and the HD800s I was using today worked completely fine on a Sony WM1Z as well as this other DAC/AMP combo they had, so I don't imagine its the headphones.
Could have asked the store rep for assistance.
 
Mar 3, 2021 at 9:23 AM Post #4,607 of 5,841

rde01

Head-Fier
Joined
Oct 12, 2020
Posts
87
Likes
40
Location
Belgium
Tried listening to this DAP at a store today with a pair of Sennheiser HD800S, using Youtube since the store's music they had on micro SD was generic test music. No sound would come out at all. If I randomly moved the volume up and down it'd suddenly kick in for a second before disappearing again.

Is this a known issue with this DAP, is it a Youtube issue, or something else? The Youtube video was also constantly stalling them speeding up, though this could be due to a bad Wifi connection, no way of knowing since I couldn't listen :/

FWIW, this was my second time testing this DAP and previously I was using several high-end headphones with zero issue using Youtube, and the HD800s I was using today worked completely fine on a Sony WM1Z as well as this other DAC/AMP combo they had, so I don't imagine its the headphones.
There where issues with audio/video sync issues on older firmware. So maybe that unit was not up to date. But sound kicking in and out is another problem.
Did u use a 2.5mm connector? Make sure its plugged in really well.
Ask the store if you can playback a file on local storage and see if that has issues too.

Also, do give us impressions of how the HD800S sounded on it. Can you get a decent amount of base (maybe with some eq in the mango player)
I don't think it will drive them well but who knows. Theoretically is should drive them better then a Sony WM1Z anyway.
 
Last edited:
Mar 3, 2021 at 9:53 AM Post #4,608 of 5,841

alexlevn0791

100+ Head-Fier
Joined
Jun 13, 2019
Posts
302
Likes
248
Location
USA
Guys, how would you describe the sound signature of the DX300? I want to upgrade from my DX160 (and it seems like something I'd love just in appearance and functionality alone). My daily IEM would be Thieaudio Monarch so any comments on this pairing will be appreciated!
 
Mar 3, 2021 at 10:43 AM Post #4,609 of 5,841

Infoseeker

Headphoneus Supremus
Joined
Aug 7, 2008
Posts
2,272
Likes
1,051
Location
Michigan, Detroit Metro Area (currently in Qatar)
Tried listening to this DAP at a store today with a pair of Sennheiser HD800S, using Youtube since the store's music they had on micro SD was generic test music. No sound would come out at all. If I randomly moved the volume up and down it'd suddenly kick in for a second before disappearing again.

Is this a known issue with this DAP, is it a Youtube issue, or something else? The Youtube video was also constantly stalling them speeding up, though this could be due to a bad Wifi connection, no way of knowing since I couldn't listen :/

FWIW, this was my second time testing this DAP and previously I was using several high-end headphones with zero issue using Youtube, and the HD800s I was using today worked completely fine on a Sony WM1Z as well as this other DAC/AMP combo they had, so I don't imagine its the headphones.

The device probably needed a hard reset, been on for too long. Wish there was a way to clear cache.

I sometimes get a youtube synch issue when my Dx300 device has been on for waaaaay too long without a reset. Never happened on my Dx220MAX though.

Also I've been getting Tidal to lag. And only Tidal app when the device is on for too long. I switch to any other app like UAPP/Spotify/AndroidSettings and the device runs super smooth even before a reset.
 
Last edited:
Mar 3, 2021 at 5:45 PM Post #4,610 of 5,841

tawmizzzz

500+ Head-Fier
Joined
Dec 24, 2019
Posts
562
Likes
2,528
Location
Boston, MA
Guys, how would you describe the sound signature of the DX300? I want to upgrade from my DX160 (and it seems like something I'd love just in appearance and functionality alone). My daily IEM would be Thieaudio Monarch so any comments on this pairing will be appreciated!
I'd say out of box, you get neutral warm signature with laid-back treble and very engaging dynamics in bass and lower mids. Staging width is solid meanwhile staging depth is excellent with layering.

With burn-in, it shifts closer to neutral with lower mids shifting more towards upper mids. The upper treble and sparkle starts to shine through the richness. I loved my DX160 but this is definitely going to be an upgrade in terms of technical capabilities.

Can't comment on Monarch synergy, sorry.
 
Mar 4, 2021 at 12:26 AM Post #4,611 of 5,841

alexlevn0791

100+ Head-Fier
Joined
Jun 13, 2019
Posts
302
Likes
248
Location
USA
I'd say out of box, you get neutral warm signature with laid-back treble and very engaging dynamics in bass and lower mids. Staging width is solid meanwhile staging depth is excellent with layering.

With burn-in, it shifts closer to neutral with lower mids shifting more towards upper mids. The upper treble and sparkle starts to shine through the richness. I loved my DX160 but this is definitely going to be an upgrade in terms of technical capabilities.

Can't comment on Monarch synergy, sorry.

Thank you! Sound definitely like an upgrade I'd enjoy. I just put on an order. Can't wait!!
 
Mar 4, 2021 at 4:00 AM Post #4,612 of 5,841

Akogingu

New Head-Fier
Joined
Jan 19, 2021
Posts
23
Likes
21
Location
Tokyo, Japan
Thanks for the feedback regarding the HD800S not working right. Guessing it was likely due to being on too long and also the firmware. They told me it was specifically a demo unit, so I imagine it's been getting used for a bit now.

I only didn't ask the staff for help regarding it cuz at that point I'd been in the store for over 2hrs having them help me test stuff left and right and didn't want to annoy them further :jecklinsmile: No matter how many times I go to these places, I still haven't spent enough time A/B'ing stuff. It never ends.
 
Mar 4, 2021 at 4:26 AM Post #4,613 of 5,841

Whitigir

Headphoneus Supremus
Joined
Oct 14, 2013
Posts
22,635
Likes
20,158
Thanks for the feedback regarding the HD800S not working right. Guessing it was likely due to being on too long and also the firmware. They told me it was specifically a demo unit, so I imagine it's been getting used for a bit now.

I only didn't ask the staff for help regarding it cuz at that point I'd been in the store for over 2hrs having them help me test stuff left and right and didn't want to annoy them further :jecklinsmile: No matter how many times I go to these places, I still haven't spent enough time A/B'ing stuff. It never ends.
Long as u don’t leave with A-hole in the pocket, then you are good game
 
Mar 4, 2021 at 8:50 AM Post #4,614 of 5,841

alexlevn0791

100+ Head-Fier
Joined
Jun 13, 2019
Posts
302
Likes
248
Location
USA
So I was lucky to find out a local store supply of DX300 and went there to get one instead of ordering online. Does anyone have issues playing DSD files through UAAP on the DX300? I can't seem to make it work so wonder if there's something wrong with my device or I happen to have meddled with any important settings in UAAP. Mango player has no problem playing DSD.....
 
Mar 4, 2021 at 9:19 AM Post #4,615 of 5,841

Whitigir

Headphoneus Supremus
Joined
Oct 14, 2013
Posts
22,635
Likes
20,158
So I was lucky to find out a local store supply of DX300 and went there to get one instead of ordering online. Does anyone have issues playing DSD files through UAAP on the DX300? I can't seem to make it work so wonder if there's something wrong with my device or I happen to have meddled with any important settings in UAAP. Mango player has no problem playing DSD.....
UAPP can’t play DSD native on any of the newest players I tried, not M8, not Dx300, nor Cayin N6ii

Neutron will do with DSD to DOP enabled
 
Mar 4, 2021 at 9:50 AM Post #4,616 of 5,841

alexlevn0791

100+ Head-Fier
Joined
Jun 13, 2019
Posts
302
Likes
248
Location
USA
UAPP can’t play DSD native on any of the newest players I tried, not M8, not Dx300, nor Cayin N6ii

Neutron will do with DSD to DOP enabled

Crap...I just figured that out too. Thanks! Fortunately Mango player is fast on the DX300 so I was not too annoyed by it compared to my experience with DX160. The player itself is incredible btw. I am still exploring!
 
Mar 4, 2021 at 9:56 AM Post #4,617 of 5,841

alexlevn0791

100+ Head-Fier
Joined
Jun 13, 2019
Posts
302
Likes
248
Location
USA
20210304_201646.jpg


What a beauty and a giant! I can confirm perfect synergy with thieaudio monarch. The bass and soundstage really blows me away!
 
Mar 5, 2021 at 5:14 AM Post #4,620 of 5,841

HarlanDraka

Previously known as HarlanDraka81
Joined
Apr 19, 2011
Posts
578
Likes
310
Location
Ireland
Around 200hrs burn in and this player changed quite a lot from straight out from the box. Almost everything improved, love it.

Pretty curious which filter do majority of people like the most after burn in? I have read that Nos filter is not advised for no high res streaming (ie. Apple Music). Is that correct or just a mith?

@twister6 Waiting for your review and I hope there will be a comparison on the different filters.I prepare the popcorn :popcorn: :)
 
Last edited:

Users who are viewing this thread

Top