Help! 1 Side of V6's not working!
post-141004
Thread Starter
Post #1 of 5

nifu

New Head-Fier
Joined
Apr 19, 2002
Messages
30
Reaction score
0
Joined
Apr 19, 2002
Posts
30
Likes
0
Help me please! I got my V6's less than a month ago and today I got the Beyer pads. I put them on properly and i don't think i hit the drivers at all. They worked fine for a few hours, now the right side doesn't give out sound! For a bit the right side was blurry but now it's not on at all! Any ideas at all please help me! Thanks!
 
     Share This Post       
post-141025
Post #3 of 5

nifu

New Head-Fier
Joined
Apr 19, 2002
Messages
30
Reaction score
0
Joined
Apr 19, 2002
Posts
30
Likes
0
WHY! NO THAT IS NOT HELPFULL! PLEASE HELP!
 
     Share This Post       
post-141044
Post #4 of 5

Strogian

100+ Head-Fier
Joined
Apr 5, 2002
Messages
122
Reaction score
0
Joined
Apr 5, 2002
Posts
122
Likes
0
Quote:

Originally posted by nifu
Help me please! I got my V6's less than a month ago and today I got the Beyer pads. I put them on properly and i don't think i hit the drivers at all. They worked fine for a few hours, now the right side doesn't give out sound! For a bit the right side was blurry but now it's not on at all! Any ideas at all please help me! Thanks!


You sure they're plugged all the way in?
 
     Share This Post       
post-141071
Post #5 of 5

nifu

New Head-Fier
Joined
Apr 19, 2002
Messages
30
Reaction score
0
Joined
Apr 19, 2002
Posts
30
Likes
0
Yeah they're plugged in all the way. I opened up the inside of the drivers to see if the cords are ok and they are.

I have a question. Are the drivers very delicate?? How much contact can they take? This may be the problem when I took the old pads off and put the new ones on. Is there any way to fix a damaged driver, if that is the problem? Please help! I feel so helpless without my V6's!!!!!!
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top