Grado RA-1 + HD580 = Distortion Box!
post-150972
Thread Starter
Post #1 of 8

arnett

Consigliere
Joined
Jun 27, 2001
Messages
711
Reaction score
10
Joined
Jun 27, 2001
Posts
711
Likes
10
Well, I either have a bum unit or the RA-1 *can’t* drive the HD580s after all.

Just got my new RA-1, plugged it into my CDP via my outlaw IC’s and . . . whoa! . . . it’s distorted as hell.

The sound is okay until about the 9 o’clock position. Then only the left side becomes distorted.
I thought it was my Plainview 9 volts, but a battery switch didn’t do the trick.

The amp kind of reminds me of this distortion pedal I once had called ‘classic fuzz.’

Anyway, I’ll call Grado tomorrow and send it to them for repairs.

With the HD580s, this distortion is not normal
. . . right?

Reminds me of all those mg head reviews: “the amp has really bad hum on the left channel . . . but God, I love the sound!”

 
     Share This Post       
post-151020
Post #3 of 8

ChenaynayC

100+ Head-Fier
Joined
Dec 29, 2001
Messages
307
Reaction score
10
Joined
Dec 29, 2001
Posts
307
Likes
10
Are you sure both of your batteries are good? Mine starts to distort when batteries are low. Thought I'd ask - just in case.
 
     Share This Post       
post-151021
Post #4 of 8

ChenaynayC

100+ Head-Fier
Joined
Dec 29, 2001
Messages
307
Reaction score
10
Joined
Dec 29, 2001
Posts
307
Likes
10
Never Mind!
 
     Share This Post       
post-151024
Post #5 of 8

ninoe99

New Head-Fier
Joined
Jun 2, 2002
Messages
33
Reaction score
0
Joined
Jun 2, 2002
Posts
33
Likes
0
I am using my HD600 and RS1 with the Grado RA1. They both sound great with this amplifier even at the levels you mentioned. I've used it with a home CDP and a portable one. Though the sound is much cleaner, smoother and tighter using the home CDP, the portable with the RA1 (at the levels you mentioned) still managed to put out a very respectable sound. I am certain it's your RA-1 which can be repaired most likely free of charge at Grado Labs.

Here's my setup -
Sony DVP-NS700P/Philips CDR765/Pioneer DVL-700 - Tributaries Silver Series SC300 - Grado RA1 - Senn HD600 or Grado RS1
Sony 828K - Straight Wire portable cable - Grado RA1 - Senn HD600 or Grado RS1
 
     Share This Post       
post-151065
Post #6 of 8

arnett

Consigliere
Joined
Jun 27, 2001
Messages
711
Reaction score
10
Joined
Jun 27, 2001
Posts
711
Likes
10
Quote:

Originally posted by ChenaynayC
Are you sure both of your batteries are good? Mine starts to distort when batteries are low. Thought I'd ask - just in case.


yes. brand new energizer alkalines.
 
     Share This Post       
post-151073
Post #7 of 8

arnett

Consigliere
Joined
Jun 27, 2001
Messages
711
Reaction score
10
Joined
Jun 27, 2001
Posts
711
Likes
10
Quote:

Originally posted by ninoe99
HD600 and RS1 . . . sound great with this amplifier even at the levels you mentioned.


at 9 o'clock i get distortion. that's not even a decent listening level for me (and i listen at low levels).

i also tried deoxit. but, alas, no avail.
 
     Share This Post       
post-151189
Post #8 of 8

erix

500+ Head-Fier
Joined
Jun 25, 2001
Messages
835
Reaction score
16
Joined
Jun 25, 2001
Posts
835
Likes
16
Sounds like a bad volume pot. The pot in the Grado amps is an, um, low-cost unit, that can go out of wack if a small piece of something (sawdust? silver paint?) falls in it.

See the guts, including the pot, here.

ok,
erix
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top