FIDUE A83 impressions and discussion thread
Jun 4, 2015 at 5:26 PM Post #1,760 of 3,064

Midgetguy

Headphoneus Supremus
Joined
Aug 3, 2014
Posts
4,892
Likes
3,093
Location
Seattle, WA
  Get it get it! Lol no pressure no I just hold more confidence in the A83 over the FX850 for a few reasons after tying its younger brother.


+1 if he can get it in a day. Also, curious, confidence in what department, SQ or build quality or both? I haven't tried any of JVC's FX line, but they look like they're pretty well built and many people enjoy them.
 
Jun 4, 2015 at 5:35 PM Post #1,761 of 3,064

dnun8086

Sponsor: Trinity Audio Engineering
Joined
May 24, 2012
Posts
619
Likes
398
+1 if he can get it in a day. Also, curious, confidence in what department, SQ or build quality or both? I haven't tried any of JVC's FX line, but they look like they're pretty well built and many people enjoy them.


Well sound quality whilst not really bad didn't tickle my fancy the fx750 felt a little bloaty. Also even though the A83 aren't the best for fit they were more comfortable than the fx750. Build quality great on both and don't get me wrong sure loads of people have been more than happy with their purchase. Just adding my 2cents I feel the A83 are a bit better but that's only of the basis of trying the fx750. :) hope that clears things up.
 
Jun 6, 2015 at 2:46 AM Post #1,762 of 3,064

rovopio

Headphoneus Supremus
Joined
Jan 18, 2014
Posts
1,749
Likes
126
Somebody offered me A83 for a steep price. They said one of the driver, the Right one sounds imbalance, like a severe lack of bass.
Has anybody ever experienced any imbalance sound or lack of bass on one of their driver? If anybody here ever experienced that, can it be fixed / was it fixed by changing to another cable or cleaning the detachable cable connection a la the solution for intermittent sound issue....?
 
the price is pretty good, but without original invoice I don't know if i can succesfully claim warranty to fidue or not, and if anybody here had experience with imbalance / lack of bass, and whether or not changing cable fixes them, i'd appreciate it if you comment here...
 
cheers...
 
Jun 6, 2015 at 3:00 AM Post #1,763 of 3,064

H20Fidelity

Headphoneus Supremus
Joined
Feb 11, 2012
Posts
16,276
Likes
6,695
Somebody offered me A83 for a steep price. They said one of the driver, the Right one sounds imbalance, like a severe lack of bass.
Has anybody ever experienced any imbalance sound or lack of bass on one of their driver? If anybody here ever experienced that, can it be fixed / was it fixed by changing to another cable or cleaning the detachable cable connection a la the solution for intermittent sound issue....?

the price is pretty good, but without original invoice I don't know if i can succesfully claim warranty to fidue or not, and if anybody here had experience with imbalance / lack of bass, and whether or not changing cable fixes them, i'd appreciate it if you comment here...

cheers...


I'm guessing the dynamic driver on that side has (or is) failed. It would most certainly need a RMA. You're buying someone else's problem imo.
 
Jun 6, 2015 at 3:34 AM Post #1,764 of 3,064

Midgetguy

Headphoneus Supremus
Joined
Aug 3, 2014
Posts
4,892
Likes
3,093
Location
Seattle, WA
  Somebody offered me A83 for a steep price. They said one of the driver, the Right one sounds imbalance, like a severe lack of bass.
Has anybody ever experienced any imbalance sound or lack of bass on one of their driver? If anybody here ever experienced that, can it be fixed / was it fixed by changing to another cable or cleaning the detachable cable connection a la the solution for intermittent sound issue....?
 
the price is pretty good, but without original invoice I don't know if i can succesfully claim warranty to fidue or not, and if anybody here had experience with imbalance / lack of bass, and whether or not changing cable fixes them, i'd appreciate it if you comment here...
 
cheers...


Yeah, I'm with @H20Fidelity, probably not worth trying that. I got mine used too, but I could easily tell it was quite a recent one and it was LNIB. Came completely in packaging, the only thing that indicated it was used was that the little sticker dot was cut to open the package, pristine otherwise. So when mine failed, I was able to give Michael at Fidue full serial numbers and codes from the box and now he's just waiting for another shipment to come in so he can fulfill my RMA. Great customer service, just an unfortunate time for mine to cut out since it happened to coincide with when his US guy was outta stock and he didn't have any on hand either.
 
Jun 7, 2015 at 5:20 AM Post #1,766 of 3,064

garcsa

Member of the Trade: Mandarines IEM Memory Foam Eartips
Joined
Mar 23, 2011
Posts
909
Likes
179
Hi there,
as mentioned in this thread before, I have similar connector problems ...  This is my first mmcx iem, so tried  just with stock cable (meantime ordered another one), the problem is that the dynamic driver works perfectly, but the balanced ones just when I push in the connector with slight  force . I thought there is some crossover issue. Checked under microscope (
smile.gif
 )  but I (we) can't see any movement on the shells mmcx. 
A83 is a great iem. I think Fidue should take care about these problems....
 
Jun 8, 2015 at 12:17 PM Post #1,768 of 3,064

hrene

New Head-Fier
Joined
Apr 26, 2012
Posts
5
Likes
11
  Just got these 2 days ago, and the sound is amazing from these. But i have a problem with the left earpiece, that is when i move the cable a little the sound cuts out, this does not happened to the right earpiece. I even tried to disconnect and connect the cable but the sound still cuts out when the cable is moved.
 
I read that someone else also had some problems a few pages back. Well i guess i have too send them back for repairs.

 
 
  Are the more people that have problems with these? 

hi i got the same problem and is also left channel 
 
Jun 8, 2015 at 2:09 PM Post #1,769 of 3,064

ardacumhur

100+ Head-Fier
Joined
Aug 19, 2014
Posts
114
Likes
11
  Hi got same problem with left channel and is definitely plug fault (don't really like mmcx connectors, not the firs earphone with them giving me this issue)

 
 
   
 
hi i got the same problem and is also left channel 

 
When do you purchase your Fidues?
 
May be last batch has been fixed?
 
Jun 10, 2015 at 7:14 PM Post #1,770 of 3,064

Midgetguy

Headphoneus Supremus
Joined
Aug 3, 2014
Posts
4,892
Likes
3,093
Location
Seattle, WA
@H20Fidelity, I almost understand now what you're talking about comparing the A83 and the 1Plus2. I just got a set of 1Plus2s in a trade (not sure what version though I dunno how much that matters) and it sounds quite good. I can't compare it to the A83 yet as Michael's still dealing with the supply issues, but I'll hopefully be able to figure out what you've heard in the future when I get a set back.
 
I highly doubt these will replace my Supra 2 as my out-and-about set as the fit on those are phenomenal in addition to the fantastic sound quality. They don't sound as good as these, which are a very well-done implementation of the core idea of BA+Dynamic, but portability is easily a strong suit for the Supra 2 that the 1Plus2 cannot touch. This 1Plus2 is going to be awesome for me though since it's summer now and headphones just don't work well for me during the summer. It's just too hot to have something wrapped around my head. So while these won't accompany me on the bus and through the streets like my Supra 2, they're gonna be great for plugging into my desktop setup with all this heat around.
 

Users who are viewing this thread

Top