Wow! My stupidity never ceases to amaze me... Thought my Mini3 was dead
Nov 14, 2008 at 3:29 AM Thread Starter Post #1 of 6

aphexii

500+ Head-Fier
Joined
Oct 14, 2005
Posts
722
Likes
11
Sitting here rocking out to Sirius and notice the sound is getting kinda faint. Look over at my Mini3 and see the LED is very dim. Odd, its plugged in and been charging for the past 2 hours. I pull off the knob, face plate, take the whole unit out, inspect it with a magnifying glass.... What... Looks perfect. Put it all back together plug it back in and notice the charging light wasn't coming on. Look under the desk and realize that the wall wart was never plugged at all, I took it out the other day to make room for my external HD.

Doh!
frown.gif
 
Nov 14, 2008 at 1:46 PM Post #4 of 6

qusp

Member of the Trade: Twisted Cables
Joined
Jun 18, 2008
Posts
7,743
Likes
61
I feel ya :p
 
Nov 14, 2008 at 2:05 PM Post #5 of 6

krmathis

Head-Fi's Most Prolific Poster
Joined
Jan 13, 2004
Posts
34,761
Likes
76
Yeah, don't worry!
We all fail once in a while... Even I.
tongue.gif
 
Nov 14, 2008 at 3:34 PM Post #6 of 6

kklee

100+ Head-Fier
Joined
Jan 29, 2006
Posts
200
Likes
10
Had one of those moments this morning!

I threw all of the requisite components into the coffee maker this morning and flipped the ON switch. Only to come back a few minutes later and find that the power cord wasn't plugged in.

I needed a coffee to wake up enough to make a coffee
icon10.gif
 

Users who are viewing this thread

Top