What happened to InvisibleShield?
Feb 27, 2006 at 3:42 AM Thread Starter Post #1 of 14

Ender Wiggin

Head-Fier
Joined
Dec 26, 2004
Posts
65
Likes
0
I try going to the website and it just gives me a page with "There is no website configured at this address" in big font.

I just ordered something from them too.

Anyone know what's up?
 
Feb 27, 2006 at 4:41 AM Post #2 of 14

xluben

500+ Head-Fier
Joined
Jan 4, 2005
Posts
940
Likes
10
Hmm, very strange. I guess those 6 lifetime warranties I have under my name aren't much good if they're no longer in busisness
rolleyes.gif


Hopefully it's just technical difficulties with their website.
 
Feb 27, 2006 at 5:18 AM Post #4 of 14

rextrade

500+ Head-Fier
Joined
Jun 28, 2003
Posts
540
Likes
0
I was just about to post the same question. Looks like they may be gone. There's goes my nice lifetime warranty (was going to try to get a new one). I guess it's BSE for me now.
 
Feb 27, 2006 at 6:12 PM Post #9 of 14

EscaBoi

100+ Head-Fier
Joined
Jan 8, 2006
Posts
285
Likes
0
got a question about the application solution for those of you who have the invisible shield. Is the application solution necessary? because i'm in Canada and going to be using the USPS method of shipment
 
Apr 25, 2006 at 4:25 PM Post #11 of 14

mshan

1000+ Head-Fier
Joined
Mar 12, 2004
Posts
1,470
Likes
11
Is this considered the best protective cover for the iPod Nano?
 
Apr 25, 2006 at 5:17 PM Post #12 of 14

kiwirugby

Headphoneus Supremus
Joined
Jul 1, 2003
Posts
1,552
Likes
12
I just received this, but after reading the instructions I became concerned about the bubbles and how they go away after a couple of days. For you guys who have used this was it easy to use? Any hints about how to use it best with good results.

Sorry to bother anyone, but any suggestions would be gratefully received.

Roger
 
Apr 25, 2006 at 5:35 PM Post #14 of 14

mixxxer

Head-Fier
Joined
Apr 4, 2006
Posts
71
Likes
0
I ordered mine before I bought my Nano. When My nano arrived i set up, then removed it from the box and package, and immediately put on the shield.

Personally I think it is great. I did have an issue with installation. but it was entirely my fault. I posted this at dapreview (there are some good invisibleshield threads there in the off-topic forum) but here is what i had posted. btw - it looks beautiful, and is different than nmost nano's cuz the entire face is sleek looking...

Note : My Install went kinda bad - but it still turned out awesome.....

*
Hmmmmmm...

I try to tell myself that the install of my shield could have gone worse... but no - i don't think so.

How is this for a good start.

I am at my desk at work. I soap up the top part of the shield, fron and back - then i peel the shield of that plastic backing - and it is so slippery fromt he solution that is slips off my hand - and lands -sticky side down on the floor in my office which is civered with.. well dust and dirt and hairs and all kinds of ****.

so i had to go wash it is a sink - but it somehow got a permanent scratch on the inside of it. anywyas i just go through the install - with the hold button on. i then look at the display and it says that firewire connections are not supported lalalalal What? and the thing will not turn off.

even though now - it sits here on my desk - and i have turned the hold button off - it says it is plaugged into ac power - which it is not. on the screen is the big green CHARGED icon.... but it is running on battery.

every bit now - the scroll wheel seems to kick in cuz it lights up and starts scrolling through the menus...

now it is ... hmmm lcd turned on. blank screen . powered off. finally.

GRRR now it has turned on again saying firewire connections are not supported. i will not press the center button like it says to do cuz last time i did that it created about 5 air bubbles that came out from around the click wheel and i had to start over.

the sides took the longest. had to keep pressing them down and trying to squeeze out the liquid from the corners with my finger. they finally worked.

the back went on the easist. looks really nice. the front looks good except for that big scratch that is on the inside of the film accross the lcd.

Well it has been almost 20 minutes and this thing keeps turning on saying firewire not supported.

hmm now it says it is fully charged. now - firewire not supported. this is lame i am going home.

*

IMG_6792Small.jpg

IMG_6796Small.jpg

IMG_6795Small.jpg

IMG_6791Small.jpg
 

Users who are viewing this thread

Top