1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Question regarding bitperfect playback in Windows 10

  1. chazb11
    I've been using a Windows 10 laptop with MusicBee and FiiO's TubAudio ASIO driver to feed music to my FiiO X3ii (used as a DAC) and then line out from the X3 to a headphone amp.
    I've been concerned if I am truly getting a "bitperfect" output because the volume control in MusicBee still works and because windows is still trying to change the driver back to direct sound anytime I unplug the FiiO. To test this further I tried playing the same file from MusicBee and then again from the X3 directly (X3 as the source and the DAC). After going back and forth several times to get the volume matched it was very apparent to me that using the X3 as the source was much better sounding...which would mean no bitperfect playback was happening on my PC.
     
    Any suggestions as to what I can try to fix this? Should I maybe try Foobar? A different driver? Disable onboard sound completely? I would just use the X3 as the source all the time but I like being able to browse my music by looking at the album covers on a decent size screen.
    Any help would be much appreciated.
     
  2. chazb11
    I solved my problem but for the sake of others that may have the same problem I'll answer my own question.
     
    The hard part is finding control panel in Windows 10, which turns out to be easily done with the keyboard shortcut.
     
    1) Press WIN+X (windows key and the X key) to open the "power menu"
    2) Select "control panel" from the list
    3) Select "sound" from the control panel that opened up.
    4) Highlight the entry that represents your external DAC device. (Note: It has to be connected to show up in the list)
    5) With your device highlighted click "properties" (A new box with 4 tabs will open)
    6)On the "Levels" tab make sure the volume and L&R balance are all set to 100%
    7)On the "Enhancements" tab make sure "disable all enhancements" is checked. (This should uncheck everything else)
    8) On the "Advanced" tab make sure "allow applications to take exclusive control of this device" is unchecked! both boxes under "exclusive mode" are checked.
    9) Click 'apply" then click "OK" to close the window.
    10) Restart your computer and enjoy the greatly improved sound! (Assuming you had to change any settings above)
     
    This made a huge difference on my setup and I highly recommend you check yours! [​IMG] 
     
    Chris1975 likes this.
  3. DrKC
    Step 8 seems counter-intuitive.  With Windows Vista, 7 and 8, ALLOWING apps to take control is the way that allows for 24 bit/96/192 playback.  You might want to follow up on this as it doesn't sound right.  But then again, I know nothing about Win 10.
     
  4. chazb11
    Thanks for your reply, I see the logic of what you are saying but in this case we are not looking for hi res playback from within windows, we are looking for a "bitperfect" stream out of the USB port to an external DAC...whatever that stream may be. Allowing apps to take control puts that apps (and windows) sound mixer, EQ, etc. into the path, which means no more bitperfect stream.
     
    The above is the way I understand it but this obviously is all new to me so I will look into the matter further. I can tell you that before I changed these settings the very same music file would sound noticeably better when played directly from my FiiO X3 than when played from my PC using the same X3 as the DAC. After changing to the new settings I can tell no difference between the two.
     
    UPDATE> After further research it appears DrKC is correct regarding step 8. I have edited the original post to reflect the new information.
    (It looks like the improvement I was hearing was entirely the result of step 7, disable all enhancements.)
     

Share This Page