My Imod is stuck on frozen...
Sep 12, 2009 at 3:56 AM Thread Starter Post #1 of 4

Golden Ears

100+ Head-Fier
Joined
Feb 6, 2005
Posts
354
Likes
29
No hard rest of holding menu and center button while flipping hte power switch works...

any other suggestions?

I don't even know where to send it in for service and Vinnie R. seems to be on vacation or something.

Do I send it to Apple or redwine audio..anyone have exerience with this... 5.5 gen 80 gig
 
Sep 12, 2009 at 3:58 AM Post #2 of 4

logwed

Headphoneus Supremus
Joined
Mar 9, 2009
Posts
4,068
Likes
81
Pretty sure that you voided your warranty with the iMod. Have you reset the DAP from the computer yet?
 
Sep 12, 2009 at 12:32 PM Post #3 of 4

tnmike1

Headphoneus Supremus
Joined
Feb 23, 2006
Posts
1,894
Likes
11
had the same trouble and sent mine to Vinnie for repair. Jsut wait until he returns. He's really the only one who can do repairs. And yes, you'vfe voided the warranty
 
Sep 12, 2009 at 12:56 PM Post #4 of 4

welchie

100+ Head-Fier
Joined
May 4, 2007
Posts
250
Likes
0
I had a 4th G imod that had a battery issue. If the battery is completely drained it won't do anything. Vinnie told me to use a native apple charging cord ( the one that came with it ) and connect it to the computer overnight. He said that when it's completely drained it needs the slow trickle charge of the computer. Wall charging doesn't work until it gets enough to function. I had to ultimately have Vinnie replace the battery. He's the man though and he's really good to work with. I hope this helps. Give me more specifics as in what are the little pictures on the screen when you hook it up, etc. Let me know, Chris.
 

Users who are viewing this thread

Top