FiiO Releases the New Firmware FW1.2.1 for X5 3rd gen

Discussion in 'FiiO' started by fiio, Mar 11, 2017.
Tags:
First
 
Back
1 2
4 5
Next
 
Last
  1. AudioTransit9213
    I tried your solution. I got all the way thru an album until the very last song. So, about the same time without the issue as when I went in and manually disabled everything.

    I feel like the issue could be very easily resolved if the pure music mode supported a third party like Tidal. So, essentially just have a general setting to be able to dedicate all cpu to whichever music player you want as opposed to only working with the fiio music app.
     
    buonassi likes this.
  2. Amielcris
    Thank you, tried this but still didn't get anything. now its saying that it cant run google.gms ore something
     
    buonassi likes this.
  3. buonassi
    Supposedly there is a way to remove Google services framework with this firmware version but I don't have the cods to try it. If anyone does this please let me know.
     
  4. AudioTransit9213
    I'm not very tech savvy and completely new to all this, so forgive me if this is a stupid question...but wouldn't removing the Google services framework also eliminate the devices ability to run the apps associated with it, such as Tidal, Spotify, and other streaming services? Unless there is a difference between downloading the apps from the fiio market as opposed to thru the play store.
     
  5. Ab10
    This is strange - it suppose to bring back Google play store - Did you remove any thing earlier to customise? If yes,

    Then try Factory Data Reset - It may wipe out the Inbuilt Storage if there is any music - So backup first. If all your music resides in Micros SD then no problem....remove Micro SD Card then do the Factory Data Reset, then reflash the firmware. Hope this solves your problem.
     
  6. buonassi
    To answer your question.... or at least try: I don't believe that removing google framework prevents it from running apk files (apps). Remember that android used to be a standalone OS before google bought it. You can still install and run apps on a device without google framework. Now please don't take this as the gospel because I haven't had the guts to remove it myself, but it shouldn't affect its ability to run apps. Under security there is an option to allow installation of 3rd party apps aka "unknown sources". By removing services framework you'll lose out on all things google, like the app store, your account syncing, location tracking, etc. But you should gain back any resources that are being soaked up by it (ram, cpu overhead).

    Instead of uninstalling (which I can't find out how to do BTW, just read on the fiio release notes that it can be done) I went ahead and disabled all of these. Disabling will keep the process from launching but is easily reversed if you don't like the results:

    google account manager
    google play services
    google play store
    google services framework

    really, the key is to keep the device as clean as possible so that my Tidal runs without glitching. I don't really care about google on this device. I'm still having luck with my previous post's method. No glitching in Tidal. Though a few others have reported that it still is affected, just holds out longer until the symptoms arise.
     
  7. AudioTransit9213
    Oh I see. Yeah, I disabled all the Google stuff as well. Hopefully this will eventually be a non issue.
     
  8. buonassi
    update: with my changes described in this thread, I have yet to experience the skipping noise I call glitching. @AudioTransit9213 described the noise more succinctly by comparing it to the old portable cd players skipping sound when they encounter a bad sector or jar. Freeing up resources seems to have cured it for me, then again, I don't listen for any longer than 1 hour without having to queue up another album. Also, I love music, but can only take it in small doses (even with very smooth, non-fatiguing iems).

    Anyway - I'm hoping that @FiiO can acknowledge the issue in this firmware thread. At least let us know that you're aware of the issue that is described here:

    and here:

    Note that some of us are seeing some improvement as we free up resources, like RAM and CPU stress. But these setting changes only postpone the issue for most people. I hope our stories here help you to pinpoint the issue and institute a permanent fix in a new software release. Keep up the good work. I'm still a FiiO fan!
     
  9. FiiO
    Dear friend,

    We have tried contacting the developer of Tidal about the issue with the Tidal. But currently, we did not get the reply from them. We will keep on following the problem. Sorry for bringing inconvenience.

    Best regards
     
    FiiO Stay updated on FiiO at their sponsor page on Head-Fi.
     
    https://www.facebook.com/FiiOAUDIO https://twitter.com/FiiO_official http://www.fiio.net/fiio http://fiio.udesk.cn/im_client/?web_plugin_id=24494&group_id=47899&language=en-us
    buonassi likes this.
  10. HifiFLEX
    Dear FIIO,

    Onkyo HF Player and USB Audio Player PRO not work!?
    They did not fix the 32-bit floating point playback using the Android AudioTrack API is messed up.
    Please fix it, thanks

    Best regards

     
  11. Lord Rexter
    Just installed Onkyo HF Player v2.0.2 and the noise issue is resolved, tested with Headphone output. Will test the USB audio output and post comments.
     
  12. Lord Rexter
    Update: Tested USB output using Hi Res audio files (DSD256/128, 384/192khz FLACs) with my iFi iDSD Micro BL, the noise issue is resolved with v2.0.2.
     
  13. FiiO
    Updated. FW1.1.8
     
    FiiO Stay updated on FiiO at their sponsor page on Head-Fi.
     
    https://www.facebook.com/FiiOAUDIO https://twitter.com/FiiO_official http://www.fiio.net/fiio http://fiio.udesk.cn/im_client/?web_plugin_id=24494&group_id=47899&language=en-us
  14. HifiFLEX
    Last edited: Sep 28, 2017
  15. Yosephra
    Anyone tried FW1.1.8 ? Please share your experience.

    Thank you Fiio.
     
First
 
Back
1 2
4 5
Next
 
Last

Share This Page