Fiio E7 and Ubuntu 10.10 on Netbook-- Crackling Sounds, Please Help!
post-7604285
Thread Starter
Post #1 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
 
 
 

[size=medium]
I have recently installed Ubuntu 10.10 on a netbook (eee pc 1201ha, no graphics drivers yet for 11.04). When I tried playing music from my Fiio E7, I heard terrible crackling sounds mixed-in with the audio. Just to make sure it had nothing to do with the audio format, I tested FLAC, mp3, wma, youtube videos-all had the same crackling sounds. 
 
I admit that I know very little about Ubuntu or the way PC's handle external sound cards, but my only solution is to blame this ill-performance on the crappy hardware inside my computer and ditch the USB DAC, for now. Does anyone have any ideas what the crackling sounds are? Is this problem fixable? Any input would be greatly appreciated.
[/size]

 
     Share This Post       
post-7604330
Post #2 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
Sigh... Just realized I can hear it, even without the DAC. The crackling is just a lot quieter. I guess I can blame this crappy laptop.
 
     Share This Post       
post-7605476
Post #3 of 13

Gondee

New Head-Fier
Joined
Jun 17, 2011
Messages
22
Reaction score
0
Joined
Jun 17, 2011
Posts
22
Likes
0
I used to be a linux Geek... Did it crackle before you changed over to linux?
 
     Share This Post       
post-7605508
Post #4 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
I don't know. I installed linux partly because I did not have a windows CD, and I had been given the laptop, pre-owned 
 
     Share This Post       
post-7606535
Post #5 of 13

svenski

New Head-Fier
Joined
Apr 11, 2011
Messages
40
Reaction score
11
Joined
Apr 11, 2011
Posts
40
Likes
11
Two things you might want to look at:
1) Check that the volume controls in the audio device settings such that there is no clipping. I had this problem before when running ubuntu 10.04, albeit not using the E7 (which I hadnt purchased at the time.
2) Check the latency for the device. If set too short (in ms) it might give you crackles as the system cannot get the data stream generated in time to be sent to the E7.
 
I am now running ubuntu 11.04 on an old laptop (Dell latitude D400)with 768mb ram and pentium-M 1.3 Ghz and it works flawlessly. 
 
     Share This Post       
  • Like
Reactions: lrawrl
post-7606568
Post #6 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
I don't know how to check either of those things. I'm looking it up right now, but I wouldn't mind if you told me. 
 
Thanks.
 
 
     Share This Post       
post-7606638
Post #7 of 13
Joined
Jan 30, 2011
Messages
13,315
Reaction score
24,272
Joined
Jan 30, 2011
Posts
13,315
Likes
24,272
Just checking the obvious first ......
 
How are you connecting your E7 to the netbook?  You need to be using the netbook USB to E7, and then your headphones to the hp out on the E7.  If you're not doing it this way, then you're not using the E7's DAC.
 
If you are using netbook hp-out to E7 to your headphones, then all you're doing is amplifying the onboard dac from the netbook.  This si where your noise would be coming from.
 
FTR - I own an Asus 1015ped, running Ubuntu 11.04, and occasionally use my E7 with it when I'm traveling.  Via USB it's a very clean signal for me.
 
     Share This Post       
post-7606658
Post #8 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
I'm using a USB cable and selecting USB audio DAC from the hardware options for sound.
 
     Share This Post       
post-7606681
Post #9 of 13
Joined
Jan 30, 2011
Messages
13,315
Reaction score
24,272
Joined
Jan 30, 2011
Posts
13,315
Likes
24,272


Quote:
I'm using a USB cable and selecting USB audio DAC from the hardware options for sound.

OK - next - can you try the E7 with another PC / laptop - and see if you're still getting noise?  This would indicate possibility that the E7 is faulty.
 
Also - is this happening with all tracks you are playing?  Could the noice actually be in the particular track?
 
 
     Share This Post       
post-7606709
Post #10 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
Hmmm I guess I should have given more details- I have been using my E7 since I purchased it in October. I did experience crackling sounds on another PC and spent days troubleshooting, until I updated to windows 7 service pack 1 and the issue seemed to fix itself. On every other laptop or PC that I used it with (4 of them) the DAC worked perfectly. I can't think of any similarities between my netbook and my desktop.
 
     Share This Post       
post-7606766
Post #11 of 13
Joined
Jan 30, 2011
Messages
13,315
Reaction score
24,272
Joined
Jan 30, 2011
Posts
13,315
Likes
24,272
OK - don't think I can help much more then.  Looking at latency or possible clipping (svenski's post above) might be best bet now.  Good luck tracking it down.
 
If you get an opportunity of trying it with someone else's laptop - I'd do it just for peace of mind.
 
     Share This Post       
  • Like
Reactions: lrawrl
post-7606854
Post #12 of 13

lrawrl

New Head-Fier
Joined
Oct 28, 2010
Messages
20
Reaction score
11
Joined
Oct 28, 2010
Posts
20
Likes
11
thank you for your time, anyway, Brooko.
 
I just installed the Mediubuntu repository and added all the the plugins for low latency sound cards and USB devices. The sound quality seems different but I still hear a lot of crackling sounds.
 
     Share This Post       
post-8250150
Post #13 of 13

PhreshNEss99

New Head-Fier
Joined
Feb 8, 2012
Messages
4
Reaction score
0
Joined
Feb 8, 2012
Posts
4
Likes
0
Hiya,
 
Just a moment ago I was dealing with EXACTLY the same problem. Everytime I used the fiio as a DAC, connecting it through the USB cable, I heard this
awful crackling noise. The only thing I did to get rid of it, was configure the output from Stereo to Mono in the Sound options.
 
Hope this helps.
 
     Share This Post       

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top