AV710 on Linux, redux
Oct 16, 2005 at 9:09 AM Thread Starter Post #1 of 2

AdamWill

Headphoneus Supremus
Joined
Dec 28, 2004
Posts
1,643
Likes
25
The existing AV710 setup threads have Linux information, but it's slightly out of date, now. I thought I'd post an update.

The Linux support for the AV710's high-resolution output (i.e. using the Wolfson DAC from the rear surround channel to drive the main stereo channel instead, and plugging your amp / phones into the bottom black connector) was broken from around ALSA 1.0.5 to ALSA 1.0.9. So the first thing to do if your distro has ALSA higher than 1.0.4 but lower than 1.0.9 is to upgrade to the latest version, switch distros, or build the most recent ALSA yourself. I'm not going to cover this in detail, too complex. Mandriva 2006, SUSE 10 and Ubuntu Breezy, off the top of my head, should all have a recent enough ALSA.

Happily, the problem was resolved in ALSA 1.0.9, so once you've equipped yourself with a suitably recent distro, all you need to do is the setup. First, make sure your distro has set itself up to use the ALSA driver snd-ice1724 to support your card. This is outside the scope of this post, but most distros should do this by default. Save the attachment of this post - 'asound.state.txt' - as just asound.state , in your home directory. Then copy it to /etc (you will need root privileges to do this). Then run 'alsactl restore' (again, as root). At this point, you should get sound from the high-quality output. Tada!

A good distro will save the sound configuration when you shut down and restore it when you start up, so you shouldn't have to do this with every boot. Bad ones might not, but that's not my problem.
smily_headphones1.gif


Caveat - this config file seems to have some 'special sauce' in it. I don't know what it is, because I didn't write it (I just took the one from this forum for earlier ALSA versions and made a minor hack to make it work on later ALSA - I removed one mixer setting from it that ALSA no longer seems to accept). It doesn't have any kind of input set up, and if you use a mixer (alsamixer, gnome-alsamixer, whatever) to enable mic-in or line-in - even if you change nothing else - the high-quality output suddenly stops working. The upshot of this is that if you want to record anything, or use Skype etc, you'll have to switch your amp / phones to the regular stereo output, run a mixer, enable the input of your choice, do your stuff, then re-copy the special asound.state to /etc and re-do alsactl restore. Therefore, don't throw the special asound.state away after the first time you use it, because you'll probably want to use line-in or a microphone at some point. Keep it handy in your home directory.

If anyone has trouble with this I may try and help, but I don't read this forum too often any more and in any case I'm not the originator of any of this stuff, I just poked around until I got it working. But I'll do my best.
smily_headphones1.gif
 
Oct 16, 2005 at 9:13 AM Post #2 of 2

AdamWill

Headphoneus Supremus
Joined
Dec 28, 2004
Posts
1,643
Likes
25
Oh, I forgot to mention, another thing I discovered is that the AV710 seems a tad temperamental about changing frequency on Linux. The command-line alsamixer mixer is the only one that seems to get the driver's frequency controls correct - if you run it, and scroll all the way to the right, you'll find one setting where you can set the frequency (from 8KHz all the way to 48KHz) manually. If you find your CDs sound a bit too squeaky, or your **** videos much too deep, you might want to run alsamixer and check the frequency setting matches the frequency of the audio in whatever you're trying to play.
 

Users who are viewing this thread

Top