1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.

    Dismiss Notice

Audio clicking issue with Samsung s10+ and USB dac/amp

Discussion in 'Portable Source Gear' started by ReaperZzZ, Mar 13, 2019.
2
Next
 
Last
  1. ReaperZzZ
    Samsung s10 / s10+ users, I need your help.

    Since upgrading from my s8+, any USB dac/amp I use, the audio has a popping / clicking noise in the background of all audio every second or two. It's very noticeable .

    I've tested on a second Samsung s10+ and the issue exists there too!

    I've tried multiple dac/amp combos (ifi micro black label / ifi xdsd / Oppo HA-2), and the issue exists.

    It doesn't matter if I'm playing audio from a local source file in UAPP, a YouTube video, or Tidal. It crackles every 1-2 seconds. I've tested with multiple headphones too :/

    Ive checked my dac/amp + headphones + cables on other phones like Samsung s9 /s8, and a workmates phone with usb C and the problem isn't there. I've factory reset my phone. The issue doesn't happen with headphones straight from the headphone jack. I went to the place I bought it from (Vodafone) and they don't have any s10 I can test with.

    The issue doesn't exist with just using the headphone jack, or Bluetooth audio.

    Is there any Samsung s10 / 10+ users out there with a USB dac/amp? Does it all work okay?

    Thanks
     
  2. trenzterra
    I saw a similar thread on Reddit so out of curiosity I decided to bring my ath-m50 to my local store to test.

    I tried the fiio q1 mark ii, btr 3 as well as the ifi nano bl. Played each for about five minutes but I didn't hear any static or crackling sound. Is your S10 the exynos or SD variant? Perhaps the headphones used may have a part to play too?
     
  3. ReaperZzZ
    Mines snapdragon. I've tried it on three s10+ here in New Zealand and it happens on all of them :frowning2: I've raised the issue to Samsung who are getting their senior engineers to investigate and I'm going to send them some dump logs this weekend.

    Regarding the headphones, I tested with the following... Fostex TH900mk2, Campfire Audio Atlas, the stock Samsung s10+ (akg) headphones, Sony wi-1000x in wired mode and some crappy generic ones my partner has, and unfortunately the issue exists in all of them. So I don't think it's the headphones.
     
  4. trenzterra
    That's strange. I'm not sure why I didn't experience the issue then. Is it something quite obvious or rather subtle? It should manifest itself within 5 minutes right?

    My firmware version is the ASCA update. Has yours been updated?
     
  5. ReaperZzZ
    It's noticeable immediately .Here's a YouTube example where it's very clear. Ellie who I address in the video is the Samsung rep, and fail to me not pressing start properly in the video lol. I think the video has copyright in some countries so let me know if you can't hear the audio



    My baseband version ends in ASBA if that's what you're referring to for software version , there's no update available on my device.

    Here's what Samsung have said yesterday.
    --------
    This is to update you regarding the status of your case. We are very sorry for the delayed response. We have checked this for you and we are glad to give you the details about it.

    We appreciate your help with the ongoing tests that we are doing. As per our senior technicians, there will be a new software releasing soon for S10 series with lots of improvement. We do not have any ETA yet but likely it will be happening this April.

    For test sample, they have confirmed that they already working on an S10 so there's no need to send your unit, however, they said that you are welcome to send the DAC/AMP to us for further testing. If this is not possible, another option is for you to take the logs for us, 3 logs from each of DAC/AMP connected.
    Here's how you can capture logs:


    Log capture steps:


    1. Dialpad--*#9900#--DEBUG LEVEL DISABLED/LOW—MID, device will restart;

    2. Reproduce the issue;

    3. If issue reproduced, Dialpad--*#9900#--“RUN DUMPSTATE/LOGCAT/MODEM LOG”--OK--waiting device to generate log file-- OK, log generating completed;

    4. Dialpad--*#9900#--“COPY TO SDCARD(INCLUDE CP RAMDUMP);

    5. Apps—My files—Device storage, you can find a “log” folder;

    6. ZIP the “log’ folder, and send it to us via Google drive link;

     
  6. trenzterra
    ASCA is a more recent update. Perhaps it may have resolved the issue?
     
  7. ReaperZzZ
    Let's hope so . I'll have to wait for it to become available to my carrier :)

    If not, I'm not sure what I'll do .The issue exists on my dads s10+ as well as a friends, and I've tried too many hardware combos (which all work perfectly on s8 /s9) for it to be the hardware .

    Its annoying because its my primary music device for day to day listening to and from work and it makes music unlistenable :frowning2:
     
  8. trenzterra
    Well just checked on Reddit and it seems someone has the same issue on the ASCA firmware. Perhaps it's no harm sending the DAC in to Samsung to have a look. At least the tech support in NZ seems to know what he's talking about.. in Singapore they would just tell me to reset the phone and say that third party peripherals are not supported.

    Any idea if anyone tried an ATH-M50? That's the only combination I tried.
     
  9. ReaperZzZ
    Care to throw up the reddit link ?

    I'll take the logs they want from multiple DACs, and courier them an Oppo HA-2. If it doesn't do it with their test phone maybe they can swap me for one of theirs. It is nice to see Samsung NZ being useful
     
  10. trenzterra
    Tried again with a Xiaomi earphones and an ifi micro BL just to be doubly sure. Didn't hear any popping or crackling sound.

    Just to be sure, it intensifies in proportion to volume? Because the area I tried wasn't that quiet. But I did not pick up any hint of a static or popping sound.

    And the Reddit link which I pointed you to seems to refer to a slightly different issue - phasing distortion every 30 seconds Vs the popping sound that you hear
     
    Last edited: Apr 14, 2019
  11. Wavelength
    RZ,

    Hey pops and clicks usually indicate that the feed back pipe for the Asynchronous USB is failing. The feedback pipe is like a sample regulator so that the dac does not under or over run it's buffers. Because if it under or over runs then you get pops and clicks.

    I would try some other cables and update firmware. We are seeing some S10 problems that are a bit wacky, like reboot and crashing as well as no audio output. You can also check with Davy the author of Extreme Audio he is very knowledgeable about these things.

    Thanks,
    Gordon
     
  12. ReaperZzZ
    Hey Gordon, I've tried with multiple cables, from generic OTG cables to Shanling L2 and the issues still exist . I can then take those exact cables and plug into an s9+ and the issues disappear. I stated this in my earlier posts, and showed it in a video I posted .

    My dacs are running the latest firmware, and im waiting for the new firmware from Samsung which will be sometime this month .

    Samsung NZs senior engineers are assisting me with the issue though,, I'll keep this thread updated
     
  13. Wavelength
    RZ,

    Well it seems the S10 has a little wacky USB-C port. On the spec the HS/FS/LS are located in the center and mirror imaged on the other side so that plugging the cable in either way will work. We have some people that have cables that only work in one direction.
    We have another user who has his S10 crash which indicates a Kernel failure.
    We have a user that the S10 locks up, probably similar to above.
    I am sure they will figure it out.
    I don't have one here or I could tell you the problem in 2 minutes.
    Thanks,
    Gordon
     
  14. ReaperZzZ
    Appreciate the info :)
     
2
Next
 
Last

Share This Page