Are my Classics distorting?

  1. neonjung
    HI there, I'm new(ish) to the world of headphones and I'm noticing some unexpected results from my newly purchased LCD-2 Classics. So I'm listening to a favourite track of mine by Aphex Twin, Produk 29, and the huge bass in the track is distorting when playing at full volume. My dac and amplification are both being handled by a Focusrite Scarlett 18i8 interface, which is driving the Classics and also a pair of 600's (it has two headphone outs) that I've had for a couple of years and know quite well. On the 600's, the huge bass of the track doesn't distort when fully turned up, but on the Classics it does. Now, the 600's aren't as loud as the Classics when everything is fully turned up (no internal clipping) so I'm wondering if this has anything to do with what I'm experiencing. The Classics don't distort when I turn down the amp a little bit. I'm wondering why I'm experiencing this as the built in amp isn't amazingly powerful so it's not like I'm driving the cans too hard. Granted, it's quite loud to listen to but not insanely loud. Are my Classics possibly faulty or am I missing something else? Any thoughts or suggestions will be very much appreciated!

    Thanks,

    Tom
     
  2. ProtegeManiac Contributor
    You're more likely to run into distortion when using lower power levels since you'd run out of power or get into the point where there's still power and wont clip, but it's already piling on distortion and noise.
     
  3. neonjung
    Yeah I suspected my amp isn't sufficient to do cans like these any real justice. I just didn't expect for the 600's to not distort when using the same amplification though. I've ordered an NFB 11.28 so that should fix things and I guess if not then I'll return them.
     

Share This Page