Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0
New Posts  All Forums:Forum Nav:

The iBasso DX50 Thread - Latest firmware: 1.6.0 - Page 1097

post #16441 of 16448

What's the RMA process for them?

post #16442 of 16448

Or replace it by your own :wink_face:

http://www.szkapon.com/UploadFiles/file/201407/1415233849.pdf

 

No idea if you can trust this sellers but they are the only ones I've found:

http://www.electrodragon.com/product/10pcs-micro-sd-card-slot/

http://www.aliexpress.com/item/High-quality-tf-card-connector-microsd-card-slot-push-push-roll-with-packing/1538343872.html


Edited by cholero - Today at 12:15 am
post #16443 of 16448

I`m wondering if it really needs to be push-pull?:rolleyes:

post #16444 of 16448

Push-Pull or:

precision-tweezers-zoom.jpg

post #16445 of 16448

any info for mod fw with interface 1.6 but sound was su 1.3.3??

post #16446 of 16448

I think RSU 1.1 or 1.2 was similar but just haven`t had time to test and confirm (sorry).

I would also like to have 1.6 functions but same sound and hidden options as SU 1.3.3 :p


Edited by CoiL - Yesterday at 11:56 pm
post #16447 of 16448

I somehow managed to make it work again...

 

When I woke up this morning, I though hey, give it another try.

So pushed the SD in, and of course it was still not working. Then, I started to shake the dx50 while pushing the sd in.

I heard a click noise, and the SD port was working again!

Already did several insert/remove cycles, and it's still working!

post #16448 of 16448
Quote:
Originally Posted by Rona-chan View Post

I somehow managed to make it work again...



 



When I woke up this morning, I though hey, give it another try.



So pushed the SD in, and of course it was still not working. Then, I started to shake the dx50 while pushing the sd in.



I heard a click noise, and the SD port was working again!



Already did several insert/remove cycles, and it's still working!


 



Still I would suggest you replace if you have a chance. God know when will it happen again, and your card may stuck inside too. I did get a faulty DX50: the first few day they work fine but latter I found that the LO somehow got weird as I have to push the jack a little upward for it to work. I got it replaced and never had any issue till this date.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › The iBasso DX50 Thread - Latest firmware: 1.6.0