New Posts  All Forums:Forum Nav:

Fiio X3 Nightmare - Page 6

post #76 of 86
X3 on v3 firmware is giving problems again on my Kingston 64Gb card. Files are glitchi g when played and sometimes it won't even access the card saying "Playback failed, music not found". This is the last straw for me. I was so happy with the release of v3 firmware and it solved all my past issues but now old issues are back again. I don't have mixed file types in my card....just mp3s. It must be one of the worst experience for me with a DAP
Edited by Francisk - 8/9/14 at 10:03am
post #77 of 86

I've been using 3.0ex firmware for a long time now with few problems.  The new Led Zep (I,II & III) releases don't play well.   Other than that I have had to reset the X3 2 or 3 times.  I use a Sandisk 64gb card formatted to exfat and have had satisfactory results.

post #78 of 86

Mine is Kingston 64Gb formatted to exfat. It was working fine all along until recently. Honestly I don't think it's the micro SD card because when I plug it into my laptop to check for problems, it has 0 errors. I think the culprit is the X3. I had the same problem when I was on v2.1 firmware but after v3 things got better until a week ago.


Edited by Francisk - 8/9/14 at 8:11pm
post #79 of 86
Quote:
Originally Posted by Francisk View Post
 

Mine is Kingston 64Gb formatted to exfat. It was working fine all along until recently. Honestly I don't think it's the micro SD card because when I plug it into my laptop to check for problems, it has 0 errors. I think the culprit is the X3. I had the same problem when I was on v2.1 firmware but after v3 things got better until a week ago.

I f you are using a card formatted to exfat, then you are using beta firmare. Wouldn't it be better to file a bug report and just go back to the non-beta firmware?

post #80 of 86
Quote:
Originally Posted by tjw321 View Post
 

I f you are using a card formatted to exfat, then you are using beta firmare. Wouldn't it be better to file a bug report and just go back to the non-beta firmware?

No, I formatted it on my laptop....not on the X3 becasue X3 refuse to recognise my Kingston 64Gb card

post #81 of 86
Quote:
Originally Posted by Francisk View Post
 

No, I formatted it on my laptop....not on the X3 becasue X3 refuse to recognise my Kingston 64Gb card

Are you sure that you mean exfat and not fat32? Exfat is only usable in the beta firmware.

 

This one: http://www.head-fi.org/t/725256/fiio-x3-beta-firmware-3-00ex-available-for-download-added-beta-exfat-support


Edited by tjw321 - 8/9/14 at 8:26pm
post #82 of 86

Sorry,,,,my bad....it's fat32, not ExFat. I formatted it using an app called GUI Format I think.

post #83 of 86
Quote:
Originally Posted by Francisk View Post
 

Sorry,,,,my bad....it's fat32, not ExFat. I formatted it using an app called GUI Format I think.

If it's still glitching, it might be worth trying to format it in the X3 again. It should be possible now that you've formatted to fat32. It's kind of a pain that you can't format cards in the X3 to fat32 unless they have already been formatted to fat32 since firmware 3.0. Almost makes it pointless, other than the X3 can choose to set things like the allocation unit to be the size it likes best.

post #84 of 86

Thanks for the help tjw321, I'll do a reformat on the X3 if that's possible....and the sloooow transfer of 30+ Gbs of files all over again. If all else fails, I'm going to upgrade to the DX90 soon. As much as I love the sound of my X3 but I'll have to let it go if it continues to misbehave. I really can't put up with all the frequent freezes just playing some 320 kbps MP3s. My iPhone 4S has never once freeze playing 320 kbps MP3s. 


Edited by Francisk - 8/9/14 at 9:07pm
post #85 of 86
 

 

Quote:
Originally Posted by Francisk View Post
 

Thanks for the help tjw321, I'll do a reformat on the X3 if that's possible....and the sloooow transfer of 30+ Gbs of files all over again.

... 

I feel your pain - this is exactly what I'm doing right now:

 

post #86 of 86

LOL....just exactly what I dread most doing...transferring 30+Gbs of files 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: FiiO