Head-Fi.org › Forums › Equipment Forums › Computer Audio › Serious popping, clicking with USB DAC
New Posts  All Forums:Forum Nav:

Serious popping, clicking with USB DAC

post #1 of 56
Thread Starter 

I am using an ODAC which is hooked up to my computer directly through USB. The ODAC is connected to a Matrix M-Stage with RCA which connects to my headphones. I am using Foobar with WASAPI Event as well. I get random popping sounds when listening to music and i don't know what to do. It seems to happen most often when im doing tasks on my computer like scrolling through web pages. I had this same problem with an older Fiio E17 when i connected it to my laptop, it would click and pop mostly on Youtube, but not my media players weirdly. When I connected the E17 and ODAC to another PC there were no clicks or pops during playback. Because of this I believe it's my laptop's USB port to blame and not the devices.

 

I've tried almost everything to remedy this situation but no luck so far. I tried different USB cables, different USB ports on my laptop (3 of them), different outputs in Foobar such as DirectSound, WASAPI etc, different media players such as MusicBee, J River, WIndows Media Player, different buffer lengths in those programs. I even unplugged all other USB devices apart from the DAC thinking it's a power problem. 

 

I downloaded a program DPC Latendy Checker to see if maybe my laptop couldn't handle audio streaming and this is what I get:

 

 

700

 

For the most part it's green with the occasional yellow spikes. Sometimes the spikes occur more or less around the same time I hear pops, but not always. Also sometimes i hear pop when there are no yellow spikes,so not sure if they're related.

 

Is there anything else I can try? I'm pretty sure this is a USB problem with my laptop since it works fine on my other computer's USB port. Do you think it's a power problem? In this case maybe a powered USB hub could fix it. Or maybe it's a jitter problem, but then why would it work fine with my other computer?

 

Man I'm stumped, really need help here.

 

EDIT: solved by disabling aero.

 

EDIT2: issue has arisen again, please read post 20.

 

EDIT3: solved for good this time hopefully, read post 23 onwards.


Edited by beaver316 - 1/10/13 at 4:37am
post #2 of 56

You can try adjusting the power management for the USB HUB devices.

 

Go to:

 

Control panel

System

Device Manager

---> Universal Serial Bus Controllers

---> USB Root HUBS

 

Right Click on each to access the properties tab

Move over to the Power Management tab

Unclick the Allow this computer...

 

This has helped some users.

post #3 of 56
Thread Starter 

Thank you for your reply but after countless hours troubleshooting, i believe i found the cause of the problem. It is indeed my graphics card. Since i disabled it, i've played 4 songs and not one pop. If it were enabled i would have heard maybe over 100 clicks by now.

 

Specifically it's an Radeon Mobility HD 3470 running Sony's proprietary driver. I may uninstall it and try Microsoft's generic graphic driver to see if that would work without stutters. I can't go without a graphic driver enabled my screen is currently 600x800 and slow as heck! But still happy i found the problem :D

post #4 of 56

Hopefully it is the driver, but I suspect it is still power related.  If you have disabled your graphics card perhaps the power supply has enough oomph to drive the USB ports properly.

post #5 of 56

GPUs have been known to introduce latency, namely because of dynamic clocks adding system latency. An alternative to disabling the display adapter is to set fixed 3D clocks, which won't make the card run hotter if loads are down.

post #6 of 56
Thread Starter 
Quote:
Originally Posted by NA Blur View Post

Hopefully it is the driver, but I suspect it is still power related.  If you have disabled your graphics card perhaps the power supply has enough oomph to drive the USB ports properly.

 

I had not thought of that. Hopefully that's not the case, i just installed AMD's latest driver, will test soon.

post #7 of 56
Thread Starter 
Quote:
Originally Posted by Roller View Post

GPUs have been known to introduce latency, namely because of dynamic clocks adding system latency. An alternative to disabling the display adapter is to set fixed 3D clocks, which won't make the card run hotter if loads are down.

 

Hmm how would i go about doing that? Do you mean keep it at high performance/battery save permanently?

post #8 of 56

Shared resources - yay. Definitely a problem with the computer, not the DAC. 

post #9 of 56
Quote:
Originally Posted by beaver316 View Post

 

Hmm how would i go about doing that? Do you mean keep it at high performance/battery save permanently?

 

First of all what are your specs, hardware and software wise?

post #10 of 56

FYI - it does not sound like power issues to me, but rather data stream issues. I think the graphics card and usb bus share data resources - when one works harder, the other cannot unless you use software to specifically prioritize tasks. 

post #11 of 56
Quote:
Originally Posted by liamstrain View Post

FYI - it does not sound like power issues to me, but rather data stream issues. I think the graphics card and usb bus share data resources - when one works harder, the other cannot unless you use software to specifically prioritize tasks. 

 

Could be. However, shared IRQ issues are more a thing of the past, affecting Windows XP and older.

 

Prioritization is a good idea, but it's a workaround that should be used only in the event beaver316 finds out it is simply mismatched hardware (some hardware doesn't play nice when it comes to smooth audio usage), as fixing the core issue would be a better option since it won't make way for possible future issues due to prioritization.

post #12 of 56
Thread Starter 
Quote:
Originally Posted by Roller View Post

 

First of all what are your specs, hardware and software wise?

 

Ok i'm running WIndows 7 SP1 64 bit on a Sony Vaio FW21E which is quite an old model. It originally came with Vista. When I iinstalled Win 7, i used a combo of my OEMs supplied drivers and WInsows Update drivers. This has me thinking now, perhaps i should have installed my OEM's motherboard driver. I don't remember if i did confused_face.gif Specs include:

 

Intel Core 2 Duo P8400 @ 2.27 GHz

4GB Ram

ATI Mobility Radeon HD 3470 GPU

1600x900 LCD

640GB Hard Disk @ 5400 rpm ( I should mention that i swapped out the hard disk a while ago. It used to be 320GB 5400 rpm, but the newer one is noticeably slower)

 

Software wise i just got AMD's latest driver version up and running, driver version 8.97.100.3-120703a-145534C-ATI and Catalyst version 12.6. Im using Foobar with the new WASAPI 3.0.

 

Something i should mention, since installing the latest AMD/ATI driver, clicks are less common, but still present.


Edited by beaver316 - 11/29/12 at 1:22am
post #13 of 56
Thread Starter 
Quote:
Originally Posted by NA Blur View Post

You can try adjusting the power management for the USB HUB devices.

 

Go to:

 

Control panel

System

Device Manager

---> Universal Serial Bus Controllers

---> USB Root HUBS

 

Right Click on each to access the properties tab

Move over to the Power Management tab

Unclick the Allow this computer...

 

This has helped some users.

 

I tried this and all the options were already unticked. But I noticed something interesting, when i go to Universal Serial Bus Controllers and click the properties of the second option i get this

 

 

700

 

Notice the device us using 1% of the bandwidth. When i start playing a song in Foobar this happens

 

 

700

 

Are these numbers normal? Also it shows that the system reserves 10%, maybe this can be increased.

post #14 of 56
Thread Starter 

Just a little update again, I have solved the problem completely I believe biggrin.gif

 

Changing the default colour settings from 32 bit to 16 bit seems to have fixed it. No clicks at all now for the past 20 minutes. I wish I didn't have to do something so drastic but I can live with this. Aero is disabled and gradients aren't smooth any more, but audio is my priority. 

 

Thanks for all the help guys, hopefully this can help others with my same problem.

post #15 of 56
Quote:
Originally Posted by beaver316 View Post

 

Ok i'm running WIndows 7 SP1 64 bit on a Sony Vaio FW21E which is quite an old model. It originally came with Vista. When I iinstalled Win 7, i used a combo of my OEMs supplied drivers and WInsows Update drivers. This has me thinking now, perhaps i should have installed my OEM's motherboard driver. I don't remember if i did confused_face.gif Specs include:

 

Intel Core 2 Duo P8400 @ 2.27 GHz

4GB Ram

ATI Mobility Radeon HD 3470 GPU

1600x900 LCD

640GB Hard Disk @ 5400 rpm ( I should mention that i swapped out the hard disk a while ago. It used to be 320GB 5400 rpm, but the newer one is noticeably slower)

 

Software wise i just got AMD's latest driver version up and running, driver version 8.97.100.3-120703a-145534C-ATI and Catalyst version 12.6. Im using Foobar with the new WASAPI 3.0.

 

Something i should mention, since installing the latest AMD/ATI driver, clicks are less common, but still present.

 

Overall, your system is more than capable of glitch-free playback. The HDD is on the slower side, being 5400 RPM, however it shouldn't be the culprit. On the other hand, the GPU is a low end model, and if you intend on doing a lot of audio playback/recording, I would recommend you disabling desktop composition entirely.

 

You should never update drivers through Windows Update, always from the hardware manufacturer instead. Unfortunately, Sony is one of the few brands that still do shameful Device ID swapping and sometimes adding hardware adapters to make it harder for replacing hardware, which in that case you should first update to the latest drivers available from Sony, then individually updating drivers from the hardware manufacturer itself.

 

Lowering color depth does indicate that the issue might be related to the GPU. The easiest way to check whether the GPU might be faulty (despite being low end, it should handle full Aero with little degradation) is to go to system properties, Advanced tab, Performance Settings, then selecting the best performance adjustment. Restart your computer and test whether you still suffer from those issues. This, with 32-bit color.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Serious popping, clicking with USB DAC